PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Error Codes p0129, p0508, p0113, p0108, and p0123

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 10 Dec 2017, 01:03 pm
Young Cruiser
 
Join Date: Aug 2012
Posts: 67
Default Error Codes p0129, p0508, p0113, p0108, and p0123

Hello all again,

Im back to pick your brains. yesterday i decided to replace my leaking oil pressure sensor and when i put her back together she won't start. She turns over but no firing of plugs. i sprayed a little starting fluid and still no bang bang. checked for codes and these are the codes i got. I went back through the whole procedure to make sure i didnt miss some connector but all looks in place. Any ideas as to what and where to start with this nightmare? p0129,p0508, p0113, p0108, and p0123
Thank you

2008 standard cruiser base model

Last edited by cinikal; 10 Dec 2017 at 01:06 pm. Reason: car facts
Reply With Quote
  #2 (permalink)  
Old 10 Dec 2017, 01:31 pm
Young Cruiser
 
Join Date: Aug 2012
Posts: 67
Default Re: Error Codes p0129, p0508, p0113, p0108, and p0123

well i redid all the job again to go over everything and i blanked the codes by removing battery for a while and now i get these codes..p0129, p0340, p0335, p0122.

Does this help any?
Reply With Quote
  #3 (permalink)  
Old 10 Dec 2017, 02:26 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,332
Default Re: Error Codes p0129, p0508, p0113, p0108, and p0123

Quote:
Originally Posted by cinikal View Post
Hello all again,

Im back to pick your brains. yesterday i decided to replace my leaking oil pressure sensor and when i put her back together she won't start. She turns over but no firing of plugs. i sprayed a little starting fluid and still no bang bang. checked for codes and these are the codes i got. I went back through the whole procedure to make sure i didnt miss some connector but all looks in place. Any ideas as to what and where to start with this nightmare? p0129,p0508, p0113, p0108, and p0123
Thank you

2008 standard cruiser base model
P0108 - MAP Sensor Circuit High Input Conditions:
Possible Causes:
1. MAP Sensor signal circuit is open
2. MAP Sensor ground circuit is open
3. MAP Sensor signal circuit shorted to 5 volt supply circuit or to battery voltage
4. MAP Sensor has failed or it has failed
5. PCM has failed

P0113 - IAT Sensor Circuit High Input Conditions:
Possible Causes:
1. IAT Sensor signal circuit shorted to VREF 5 volts
2. IAT Sensor signal circuit is open, or the ground circuit is open
3. IAT Sensor is damaged or it has failed
4. PCM has failed

P0123 - Throttle Position Sensor Circuit High Input:
Possible Causes:
1. Throttle Position Sensor sweep TP Sensor ground circuit is open
2. Throttle Position Sensor signal circuit is open or is shorted to VREF - 5 volts
3. Throttle Position Sensor is damaged or has failed
4. Possible intermittent condition
5. PCM has failed

P0129 - Barometric Pressure Out-Of-Range Conditions:
Possible Causes:
1. IAC motor control low or control high circuit has failed
2. MAP Sensor 5 volt circuit is open or shorted to ground
3. MAP Sensor signal circuit is open or shorted to ground
4. MAP Sensor is damaged or it has failed May be an intermittent condition
5. PCM has failed

P0508 - Idle Air Control Motor Sense Circuit Low Input Conditions:
Possible Causes:
1. IAC motor driver circuit is open or shorted to ground
2. IAC motor sense circuit is open or shorted to ground I
3. AC motor is damaged or it has failed
4. PCM has failed

Do not follow the posts where it says you can reset the codes by disconnecting the battery. It is inaccurate information.

I would suggest first doing a battery load test. Also clean the battery cable connectors. First check the battery. You might have a bad cell in the battery. Check the battery voltage as you are starting it and post what the battery voltage drops down to.

You need an OBDII Scan Tool to reset the engine trouble codes. You are going on a wild goose chase until you do purchase the scan tool. Random codes are common when you only disconnect the battery and connect it again and also when the battery voltage is low.
__________________
If at First You Don't Succeed - Try, Try Again

Last edited by ptcruisersteve; 10 Dec 2017 at 02:36 pm.
Reply With Quote
  #4 (permalink)  
Old 10 Dec 2017, 03:04 pm
Young Cruiser
 
Join Date: Aug 2012
Posts: 67
Default Re: Error Codes p0129, p0508, p0113, p0108, and p0123

Thanks ptcruisersteve,

I bought the scan tool this morning. after going through my work and rechecking all connections scan tool now reports p0129, p0340, p0335, p0122

starter voltage has minimal drop
battery is at 12.45 and it is about 3 months old
battery is on a battery tender as i probe around
charging was at 13.98 last week. cant check now as she doesn't start

Any ideas?
Reply With Quote
  #5 (permalink)  
Old 10 Dec 2017, 03:14 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,332
Default Re: Error Codes p0129, p0508, p0113, p0108, and p0123

Quote:
Originally Posted by cinikal View Post
Thanks ptcruisersteve,

I bought the scan tool this morning. after going through my work and rechecking all connections scan tool now reports p0129, p0340, p0335, p0122

starter voltage has minimal drop
battery is at 12.45 and it is about 3 months old
battery is on a battery tender as i probe around
charging was at 13.98 last week. cant check now as she doesn't start

Any ideas?
Unplug the TPS sensor and see if you get P0123 after you reset the engine trouble codes. If you still get P0122 you have a short to ground and you need to check the wiring from the TPS to the PCM. Check the wire harness going from the engine to the PCM for any contacts with ground.

Have you had any wiring repairs in the wire harness?

All of the codes refer to sensors that have the same 5 volt reference going to them. Check the splice S109 in the wiring harness. In the shop manual the S109 supplies 5 volts to all those sensors, it looks like your problem could be between the splice and the camshaft sensor.


Try pulling the TPS sensor and see if you get P0123.
__________________
If at First You Don't Succeed - Try, Try Again

Last edited by ptcruisersteve; 10 Dec 2017 at 03:24 pm.
Reply With Quote
  #6 (permalink)  
Old 10 Dec 2017, 04:06 pm
Young Cruiser
 
Join Date: Aug 2012
Posts: 67
Default Re: Error Codes p0129, p0508, p0113, p0108, and p0123

Disconnected the TPS and got a p0123.and a p0108 in addition to the p0122 and others.
Reply With Quote
  #7 (permalink)  
Old 10 Dec 2017, 04:19 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,332
Default Re: Error Codes p0129, p0508, p0113, p0108, and p0123

Quote:
Originally Posted by cinikal View Post
Disconnected the TPS and got a p0123.and a p0108 in addition to the p0122 and others.
Recommend you connect the TPS connector back on and pull the camshaft sensor connector off. Reset the engine trouble codes first before trying to start the engine. One of the sensors might be shorting out the 5 volt line. Post what codes come up.
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #8 (permalink)  
Old 10 Dec 2017, 04:36 pm
Young Cruiser
 
Join Date: Aug 2012
Posts: 67
Default Re: Error Codes p0129, p0508, p0113, p0108, and p0123

connected TPS sensor, disconnected cam position sensor cleared codes now i get 2 codes.... both are p0129.
Reply With Quote
  #9 (permalink)  
Old 10 Dec 2017, 04:50 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,332
Default Re: Error Codes p0129, p0508, p0113, p0108, and p0123

Quote:
Originally Posted by cinikal View Post
connected TPS sensor, disconnected cam position sensor cleared codes now i get 2 codes.... both are p0129.
P0129 - Barometric Pressure Out-Of-Range Conditions:
Possible Causes:
1. IAC motor control low or control high circuit has failed
2. MAP Sensor 5 volt circuit is open or shorted to ground
3. MAP Sensor signal circuit is open or shorted to ground
4. MAP Sensor is damaged or it has failed May be an intermittent condition
5. PCM has failed

I would suggest disconnecting the map sensor leaving the camshaft sensor disconnected and see if the code comes up for the camshaft sensor.
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #10 (permalink)  
Old 10 Dec 2017, 05:01 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,332
Default Re: Error Codes p0129, p0508, p0113, p0108, and p0123

Quote:
Originally Posted by ptcruisersteve View Post
P0129 - Barometric Pressure Out-Of-Range Conditions:
Possible Causes:
1. IAC motor control low or control high circuit has failed
2. MAP Sensor 5 volt circuit is open or shorted to ground
3. MAP Sensor signal circuit is open or shorted to ground
4. MAP Sensor is damaged or it has failed May be an intermittent condition
5. PCM has failed

I would suggest disconnecting the map sensor leaving the camshaft sensor disconnected and see if the code comes up for the camshaft sensor.
Also with the map sensor off check to see if you have 4 to 5 volts on the map connector.

If no codes for camshaft sensor I would suggest turning the motor over and see if the camshaft is turning.

Post what codes you get for the map sensor disconnected. One of the sensors is most likely shorted out.
__________________
If at First You Don't Succeed - Try, Try Again

Last edited by ptcruisersteve; 10 Dec 2017 at 05:09 pm.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
P0508 / P0579 - codes won't go away MrSpkr Tech & Performance Forum 1 02 Nov 2015 01:57 pm
Error codes P0123 P2074 & P0068 Please Help! ArchieB Tech & Performance Forum 6 15 Nov 2014 11:32 pm
No idle and codes P2074 and P0508 Cat22 Tech & Performance Forum 2 19 Oct 2011 05:57 pm
error codes p0129 and p0106 murman40 General Turbo Discussions 0 11 May 2009 03:33 pm


All times are GMT -5. The time now is 10:52 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors