PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
05 Turbo replaced engine/Trans. mounts, but...

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 27 Apr 2018, 02:51 pm
Fresh Cruiser
 
Join Date: Jan 2016
Posts: 23
Default 05 Turbo replaced engine/Trans. mounts, but...

I still get a clunk noise with slight hesitation upon downshifting -slowing down for stop or off highway offramp... but not everytime...intermittent
(auto Trans) or after initial starting out and hitting higher gear.

Been a long ongoing process starting with motor mount replacement one at a time.

Any suggestion on what I might consider next?

Thank you,

Paul
Reply With Quote
  #2 (permalink)  
Old 27 Apr 2018, 04:54 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,475
Default Re: 05 Turbo replaced engine/Trans. mounts, but...

I would suggest checking the upper and lower torque struts and if that has been replaced has the 4.720 alignment been done?
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #3 (permalink)  
Old 27 Apr 2018, 06:34 pm
Fresh Cruiser
 
Join Date: Jan 2016
Posts: 23
Default Re: 05 Turbo replaced engine/Trans. mounts, but...

Ptcruisersteve..

I would suggest checking the upper and lower torque struts and if that has been replaced has the 4.720 alignment been done?

Yes both are new...what is the alignment you're referring to?
Reply With Quote
  #4 (permalink)  
Old 27 Apr 2018, 07:49 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,475
Default Re: 05 Turbo replaced engine/Trans. mounts, but...

Quote:
Originally Posted by paulwells77 View Post
Ptcruisersteve..

I would suggest checking the upper and lower torque struts and if that has been replaced has the 4.720 alignment been done?

Yes both are new...what is the alignment you're referring to?
There is a step by step procedure to follow to get the 4.720 alignment. It would take too much typing to post it all. You need to have the Factory Shop Manual for your Pt Cruiser so you can make sure you are doing everything correctly. This alignment is important as you can damage your new torque struts if the alignment is off.

Free 01-04 PT cruiser shop manual
__________________
If at First You Don't Succeed - Try, Try Again

Last edited by ptcruisersteve; 27 Apr 2018 at 08:03 pm.
Reply With Quote
  #5 (permalink)  
Old 28 Apr 2018, 07:39 am
Obsessed Cruiser
 
Join Date: Aug 2015
Location: Lake Wales, FL
Posts: 5,011
Default Re: 05 Turbo replaced engine/Trans. mounts, but...

He's talking about the engine alignment. The top mount has to be 4.72" from a hole in the strut tower. If you do a search here, you'll find it. As for the clunking, have you checked your sway bar end links and bushings?
__________________


Aspire to inspire before you expire.
Reply With Quote
  #6 (permalink)  
Old 28 Apr 2018, 11:34 am
Regular Cruiser
 
Join Date: Mar 2015
Location: Liberty MO
Posts: 132
Default Re: 05 Turbo replaced engine/Trans. mounts, but...

Passenger side?

Check torque of the bolt at the a-arm ball joint if you disconnected it during your project.

I've had to revisit this bolt on more than one occasion.
Reply With Quote
  #7 (permalink)  
Old 29 Apr 2018, 03:55 pm
Fresh Cruiser
 
Join Date: Jan 2016
Posts: 23
Default Re: 05 Turbo replaced engine/Trans. mounts, but...

Thank you all for your replies...

very helpful!

Paul
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Replaced ECM, now trans downshifts different Jeffz Tech & Performance Forum 19 02 Dec 2017 08:41 pm
will the turbo engine mounts garyd75 Tech & Performance Forum 12 29 Nov 2016 04:59 pm
Motor Mounts Replaced Now Vibration at Idle falconut Tech & Performance Forum 12 15 Mar 2013 07:48 pm
2004 non-turbo engine mounts replaced cookj Tech & Performance Forum 1 22 Oct 2012 04:31 pm
motor & trans mounts???? tthrift Turbo Performance 13 08 Nov 2003 02:59 am


All times are GMT -5. The time now is 04:03 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors