PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Sudden loss of power, seeming loud intake/exhaust?

 
Like Tree8Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 05 May 2018, 01:06 am
Fresh Cruiser
 
Join Date: May 2018
Posts: 5
Default Sudden loss of power, seeming loud intake/exhaust?

Today I went out to see a movie, about a 20 minute drive from my house. Car felt fine on the way there, no issues. On the way home the car felt like it had lost 20% or so of its power.. Struggled to get up to speed on the free way and then struggled to get up some of the hills near my house.(I live in a particularly hilly area.) I'm pretty mechanically enclined, and have already been inside this engine on more than one occasion. About 10-15k miles ago I did the timing belt, water pump, motor mounts, and a bad head gasket and radiator. I also had the head resurfaced, as it was slightly warped from the overheating caused by a failed radiator. Yesterday I had an issue with the cam position sensor, car seemed to fall flat on it's face under load and threw codes for an intermittent camshaft position sensor. Upon further inspection the connection itself as well as the ground for it appeared to be loose. After cleaning and making sure they were secure, no more issues.

When I got the car home, I noticed a thin white smoke coming out of the tailpipe, and upon popping the hood coming from the header area. I think the smoke from the headers is caused by an oil leak dripping on to the headers, but I can't be sure. I am fairly certain that my PCV is bad, and I noticed today it's line is cracked, which I think is where my oil leak is coming from.

After I saw this, I pulled the car in the garage and did a compression test, fearing another bad head gasket but got ~190 psi on all cylinders, +/- 5 psi. I'm at a total loss as to what could be causing this dip in power. Could my timing have jumped a notch, and that be my issue? I'm not getting a code for a misfire, so I'm doubtful its ignition or fuel. I also thought it could be a clog somewhere in my exhaust, but until tomorrow I can't be sure.

The car runs and drives fine as is, albeit with less power. The idle also doesn't appear to be any different, and it isn't difficult to get started at all. Any ideas?
Reply With Quote
  #2 (permalink)  
Old 05 May 2018, 01:22 am
Handy_Cruiser's Avatar
Obsessed Cruiser
 
Join Date: Oct 2013
Location: Arkansas
Posts: 10,547
Default Re: Sudden loss of power, seeming loud intake/exhaust?

Fix the PCV valve and hose first. See if that has an effect.

If no joy, check for a clogged catalytic converter. Hook up a vacuum gauge and see if the vacuum drops to near zero with increased RPM.

To check the timing belt, remove #1 spark plug and use a wooden dowel rod or something similar to tell when you get #1 cyl. to the top. Then remove the top of the plastic timing dust cover and see if the timing marks are still aligned on the sprockets.
pt06 and dsab like this.
__________________
Reply With Quote
  #3 (permalink)  
Old 05 May 2018, 01:30 pm
Fresh Cruiser
 
Join Date: May 2018
Posts: 5
Default Re: Sudden loss of power, seeming loud intake/exhaust?

Checked the timing, everything is still spot on. About to run to an auto parts store to grab the valve and hose. I'll get back here when I put it all back together and test drive it.
Handy_Cruiser likes this.
Reply With Quote
  #4 (permalink)  
Old 05 May 2018, 01:53 pm
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,901
Default Re: Sudden loss of power, seeming loud intake/exhaust?

Check the hose going to the vac buster. Check turbo hoses if yours is. If one goes bad or comes loose. Its loud and no power.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #5 (permalink)  
Old 05 May 2018, 04:18 pm
Fresh Cruiser
 
Join Date: May 2018
Posts: 5
Default Re: Sudden loss of power, seeming loud intake/exhaust?

Quote:
Originally Posted by Busted_PT View Post
Check the hose going to the vac buster. Check turbo hoses if yours is. If one goes bad or comes loose. Its loud and no power.
Can you point me to where that is? It's N/A. Replaced the PCV and subsequent hose... no luck. Same symptoms. Took the muffler off just to see if that was clogged, it really didn't get as loud as it was from my muffler delete days. Thinking it might be my cat? Or a stuck exhaust valve? Sounds like exhaust coming from the driver side of the engine bay, almost where the intake is. The power loss is so bad its struggling to get out of first with my foot to the floor.
Reply With Quote
  #6 (permalink)  
Old 05 May 2018, 04:26 pm
Handy_Cruiser's Avatar
Obsessed Cruiser
 
Join Date: Oct 2013
Location: Arkansas
Posts: 10,547
Default Re: Sudden loss of power, seeming loud intake/exhaust?

Quote:
Originally Posted by westhesailor View Post
Can you point me to where that is? It's N/A. Replaced the PCV and subsequent hose... no luck. Same symptoms. Took the muffler off just to see if that was clogged, it really didn't get as loud as it was from my muffler delete days. Thinking it might be my cat? Or a stuck exhaust valve? Sounds like exhaust coming from the driver side of the engine bay, almost where the intake is. The power loss is so bad its struggling to get out of first with my foot to the floor.
The brake booster vacuum hose is 3/8 inch rubber and runs from the back of the plastic intake manifold to the brake booster on the drivers side. Here's a photo of where I put a tee in mine for a boost gauge. It's in the same place on the NA PT.




I urge you to try a vacuum gauge. Here's some of the things it can tell you.

__________________

Last edited by Handy_Cruiser; 05 May 2018 at 04:29 pm.
Reply With Quote
  #7 (permalink)  
Old 05 May 2018, 04:28 pm
Fresh Cruiser
 
Join Date: May 2018
Posts: 5
Default Re: Sudden loss of power, seeming loud intake/exhaust?

Quote:
Originally Posted by Handy_Cruiser View Post
The brake booster vacuum hose is 3/8 inch rubber and runs from the back of the plastic intake manifold to the brake booster on the drivers side.

I urge you to try a vacuum gauge. Here's some of the things it can tell you.

This is perfect. I have a gauge, I'll go try it now.
Handy_Cruiser likes this.
Reply With Quote
  #8 (permalink)  
Old 05 May 2018, 04:43 pm
Fresh Cruiser
 
Join Date: May 2018
Posts: 5
Default Re: Sudden loss of power, seeming loud intake/exhaust?

Hooked up a vacuum gauge, looks like the one saying restricted exhaust causing backpressure. Going to try taking off the cat once it cools just as a test.
Handy_Cruiser likes this.
Reply With Quote
  #9 (permalink)  
Old 05 May 2018, 05:29 pm
Handy_Cruiser's Avatar
Obsessed Cruiser
 
Join Date: Oct 2013
Location: Arkansas
Posts: 10,547
Default Re: Sudden loss of power, seeming loud intake/exhaust?

Yep.

If you've had a blown head gasket in the past which let antifreeze get into the exhaust, your cat may be well coated.
__________________
Reply With Quote
  #10 (permalink)  
Old 05 May 2018, 06:18 pm
Obsessed Cruiser
 
Join Date: Aug 2015
Location: Lake Wales, FL
Posts: 5,011
Default Re: Sudden loss of power, seeming loud intake/exhaust?

If you live somewhere that you don't have emissions testing, maybe you can punch the crap out of the cat con and stick it back on. Once they're clogged, you'll have a very noticeable decrease in power. Is is glowing red after you drive the car?
Handy_Cruiser likes this.
__________________


Aspire to inspire before you expire.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
sudden very loud turbo whine Kev General Turbo Discussions 24 22 Mar 2015 12:16 pm
Sudden loss of Power Steering after PT being jump started? lanies_ptcruiser02 General PT Cruiser Discussions 16 08 Sep 2010 10:20 am
AirRaid Intake Power Loss Sam2627 Tech & Performance Forum 10 23 Jan 2008 01:30 pm
Sudden drop in power justine311 Tech & Performance Forum 5 21 Feb 2006 11:24 pm
Sudden loss of power(need tune up?) Ctown Tech & Performance Forum 21 16 Jan 2006 08:41 am


All times are GMT -5. The time now is 03:17 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors