PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
ignition/electrical issue and tranny issue

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 08 Jun 2018, 09:59 am
Fresh Cruiser
 
Join Date: Mar 2014
Posts: 16
Unhappy ignition/electrical issue and tranny issue

I have a 2006 pt cruiser touring edition non turbo manual 5 speed with 135,000 miles. This car has done nothing but give me the worst headaches. But I'm a single mother with 5 kids and need a vehicle to work and take the kids to appointments so im stuck with it.

Ok, so my car is doing a couple weird things here and there. First thing is sometimes when I park the car and go to turn the ignition off and I remove the key from the ignition completely, the car stays running. I have to stall it out or press the clutch all the way down to the floor for it to shut down the engine.

My second problem is the gear shifter. It is hard to get the car into 3rd gear while driving at times. It is also hard to get it to engage for reverse. We have checked the shifter cables and they are snug (we recently replaced the white round piece that holds the cables in place). It doesn't happen every time I go to shift into 3rd but I have noticed a few different times when it was being more difficult than others.

One more question, a few years ago my ac wasn't cooling. It had randomly out of nowhere started blowing hot when I was about halfway to work. I ended up taking it into a shop and they charged the system and had me run to Autozone to get some type of relay or ac switch real fast. They was able to replace whatever the part was in a minute or 2 and it was under the hood. I think it cost me around $50 for the item. My question is does anyone have any idea what that could have been that they had me purchase? I can't find the receipt and I cant remember things so I don't recall.

I'd really appreciate any help I can get! I'd take it to a mechanic but I can't afford to. My brother has worked on cars a little bit so he's been helping me out as best as he can.

Thank you very much
Reply With Quote
  #2 (permalink)  
Old 09 Jun 2018, 06:57 am
Obsessed Cruiser
 
Join Date: Aug 2015
Location: Lake Wales, FL
Posts: 5,011
Default Re: ignition/electrical issue and tranny issue

I don't know about the shifting problem, so won't venture a guess. As for the ac part, sounds like it was either a relay or the pressure cut out switch. Most likely the switch but they don't usually cost much over $20. I guess it depends on where you got it.
__________________


Aspire to inspire before you expire.

Last edited by chuzz; 09 Jun 2018 at 07:03 am.
Reply With Quote
  #3 (permalink)  
Old 09 Jun 2018, 10:28 am
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,475
Default Re: ignition/electrical issue and tranny issue

Quote:
Originally Posted by imlost33 View Post

Ok, so my car is doing a couple weird things here and there. First thing is sometimes when I park the car and go to turn the ignition off and I remove the key from the ignition completely, the car stays running. I have to stall it out or press the clutch all the way down to the floor for it to shut down the engine.
When you take the key out are the gauges still working on the Instrument Cluster?
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
Reply

Tags
ac question, electrical, ignition problems, manual transmission issue


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Auto tranny issue now PTloser32805 Tech & Performance Forum 11 02 Nov 2017 04:43 pm
electrical issue? PaTurboCruiser General PT Cruiser Discussions 11 01 May 2017 10:51 am
Help!! I have an electrical issue Destroyer4 General PT Cruiser Discussions 8 19 Jun 2015 08:23 am
Electrical issue stormnormm Western PT Forum 1 01 Jun 2013 07:45 am
Electrical issue? DMod General PT Cruiser Discussions 38 23 Jan 2012 08:49 pm


All times are GMT -5. The time now is 01:21 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors