PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Same time occasional multiple lights issue - PT 2009

 
Like Tree2Likes
  • 1 Post By ptcruisersteve
  • 1 Post By denis90

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 11 Jun 2018, 12:22 pm
Fresh Cruiser
 
Join Date: May 2018
Posts: 10
Default Same time occasional multiple lights issue - PT 2009

Hi all,

Suddenly noticed the occasional turn signal issue - the light wasn't working and the tic was more frequent then usually.

Was thinking just to replace a bulb but when checked the rest of lights realized when the issue is on place following lights will not work as well:
- left back turn signal
- front right turn signal
- front right low beam
- left high beam

So the issue occasionally comes and goes, either everything is fine or the whole set of signals is failing.

Most likely it's not a steering wheel control leather because when reproduced it can also be observed using the remote to lock/unlock the car - turn signals won't work.

What can be the next research point?

Thank you,
Denys

Last edited by denis90; 11 Jun 2018 at 05:20 pm.
Reply With Quote
  #2 (permalink)  
Old 11 Jun 2018, 03:14 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,066
Default Re: Same time occasional multiple lights issue - PT 2009

Quote:
Originally Posted by denis90 View Post
Hi all,

Suddenly noticed the occasional turn signal issue - the lamp wasn't working and the tic was more frequent then usually.

Was thinking just to replace a bulb but when checked the rest of lights realized when the issue is on place following lights will not work:
- left back turn signal
- front right turn signal
- front right low beam
- left high beam

So the issue occasionally comes and goes, either everything is fine or the whole set is failing.

Most likely it's not a steering wheel control leather because when reproduced it can also be observed using the remote to lock/unlock the car - turn signals won't work.

What can be the next research point?

Thank you,
Denys
What happens if you turn on the turn sigals first before using the remote locks?
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #3 (permalink)  
Old 11 Jun 2018, 09:48 pm
Fresh Cruiser
 
Join Date: May 2018
Posts: 10
Default Re: Same time occasional multiple lights issue - PT 2009

Quote:
Originally Posted by ptcruisersteve View Post
What happens if you turn on the turn sigals first before using the remote locks?
Not sure if correctly got it - when I take a key out of ignition the turn signals stop operation.

When lock a car from outside with a key - only front left and rear right signals will blink.

Along with that when driving front right low beam and left high beam also stopped working.
Reply With Quote
  #4 (permalink)  
Old 11 Jun 2018, 10:01 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,066
Default Re: Same time occasional multiple lights issue - PT 2009

Flashing and all exterior illumination is controlled by the TIPM. A short to ground or voltage on the circuit will set a code.

Some possible codes for the turn signals would be:
B163B - Front Left Turn Control Circuit Low
B163C - Front Left Turn Control Circuit High
B163F - Front Right Turn Control Circuit Low
B1640 - Front Right Turn Control Circuit High
B1643 - Rear Left Turn Control Circuit Low
B1644 - Rear Left Turn Control Circuit High
B1647 - Rear Right Turn Control Circuit Low
B1648 - Rear Right Turn Control Circuit High

The circuits will need to be tested for a short to ground, short to voltage or an open circuit. An open circuit means that there is no continuity between the connector at the TIPM and the suspect lamp location. You may need a long jumper wire to perform these tests.

The driver circuit is on pin 1 at the bulb location.

TIPM locations are listed below:
Front left TIPM location is C4, pin 1.
Front right TIPM location is C4, pin 2.
Rear left TIPM location is C3, pin 4.
Rear right TIPM location is C3, pin 6.

If all wiring checks out fine and there are no shorts to ground, voltage or open circuits, then the TIPM drivers are possibly bad and the TIPM might need to be replaced.

I would suggest first checking the group of ground wires going to the drivers inner fender. They get corroded and start loosing contact.
denis90 likes this.
__________________
If at First You Don't Succeed - Try, Try Again

Last edited by ptcruisersteve; 11 Jun 2018 at 10:03 pm.
Reply With Quote
  #5 (permalink)  
Old 16 Jun 2018, 09:38 am
Fresh Cruiser
 
Join Date: May 2018
Posts: 10
Default Re: Same time occasional multiple lights issue - PT 2009

Thank you Steve!

Alright, the issue is solved by replacing the TIPM. Fix cost - $80 and a little of time.

Frankly I didn't find a way to read error codes with my scanner, was a bit lazy to get to the front light wires through the wheels access and also was suspecting TIPM because of the the strange combination of errors.

So I went on e-bay, found a similar module for $80 with delivery and 60 days return, checked several sources on internet how to make different kinds of "resets" to make TIPM adapted to car and ordered a module.

I had a "56049719AR" module, received a "56049719AN" one.
Dorman says they are interchangable:
https://www.dormanproducts.com/p-508...rol%2520Module

"Resets" I made:
1) take the battery out and short cut + and - terminal to drain the capacitors in car
2) with battery now - on newly installed TIPM turn the key to first or second position and wait for 20 seconds to get it auto-configured.

That's it.
Got a new feature - car now makes a short horn when I lock it with remote.

Denys
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Do the lights stay on all the time? rustymich Tech & Performance Forum 5 01 Feb 2017 07:37 pm
Brake lights and amber turn signal lights come on at same time Mikeecruiser Tech & Performance Forum 4 11 Nov 2016 04:23 pm
Is it time to give up? Constant P0344 issue shortchica Tech & Performance Forum 4 19 Jul 2016 09:55 pm
Multiple Sensor Error Lights Flashing ADKing Tech & Performance Forum 4 28 May 2014 01:29 pm
2009 Base PT Cruiser Cooling Fan Issue donsr1964 General PT Cruiser Discussions 2 02 Apr 2014 03:01 pm


All times are GMT -5. The time now is 02:43 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors