PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Sorry, another AC question

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 13 Jun 2018, 07:18 am
Fresh Cruiser
 
Join Date: Sep 2016
Posts: 3
Default Sorry, another AC question

Seems it's rife with AC stuff but I haven't seen this issue yet so I'll explain what I see and what I've done.

It's a 2003 base model manual transmission.

AC hasn't worked since we bought it 2 years ago, but only had 31k miles on it.

Car started to overhead and radiator fan didn't kick on so I replaced it along with the thermostat just in case, cuz they're cheap.

so after replacing the fan I took out AC refill juice can with a gauge and hooked it up. it was in the white low area while the car was running.

then I'd hear a click and the gauge would go high green, the radiator fan would kick on, then they both would shut back off and the gauge would go into low white again.

It kept doing this every 5 seconds or so. click-on-click-off. cold air never blew but the AC line got cold.

Any clues? It sounds odd.

Last edited by sheepish; 13 Jun 2018 at 07:21 am.
Reply With Quote
  #2 (permalink)  
Old 14 Jun 2018, 08:54 am
Veteran Cruiser
 
Join Date: Aug 2015
Location: Lake Wales, FL
Posts: 4,161
Default Re: Sorry, another AC question

I don't know diddly about a/c, but have noticed that a LOT of people have had problematic low pressure switches. Maybe you should replace that. They're not too expensive. I THINK around $15.
__________________


Farts are just ghosts of the things we eat.
Reply With Quote
  #3 (permalink)  
Old 16 Jun 2018, 08:47 pm
Young Cruiser
 
Join Date: Mar 2014
Location: Tampa
Posts: 83
Default Re: Sorry, another AC question

If you suspect its the switch, you can can that connector off the switch and use a jumper wire across the wiring harness end. The compressor should run as if the system is full.

If it is actually low, the fan and compressor will run and you should feel a lack of cold air from the a/c ducts in the car.

Beware, running the compressor with a lack or low freon can damage the compressor, so don't leave it jumped any longer than needed to troubleshoot the system
__________________
2003 GT
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
:question:daytime running lights!!!:question: jrs61282 Tech & Performance Forum 10 07 Nov 2010 10:53 pm
Luggage Rack question and trailer hitch question Patrick_Dickey General PT Cruiser Discussions 5 26 Apr 2009 09:19 pm


All times are GMT -5. The time now is 02:55 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors