PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
2006 PT Base Engine running w/o Key wont shut down

 
Like Tree2Likes
  • 2 Post By rckstein

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 19 Jun 2018, 05:16 pm
JRR JRR is offline
Fresh Cruiser
 
Join Date: Aug 2017
Posts: 6
Default 2006 PT Base Engine running w/o Key wont shut down

2006 Base PT non turbo. Engine will not shut down. Turn off key and remove key and it keeps running. Last year new PCM installed, new ignition switch, new crank sensor. and the aftermarket remote locks and alarm was removed. Has been running great and runs well now. However I cant shut off the engine! removed key and it continues to run. Very minimal information online on this issue. I saw a post about the high speed fan relay being the issue. When I unplug 1 of the two separate relays mounted on the fire wall drivers side the engine shuts off. Removing the other relay does nothing. Same part # so I swapped them. Still engine keeps running until I unplug the (i am assuming) high speed relay. What would a fan relay have to do with the engine not shutting off? I also have to assume if I swapped them its not the actual relay? Any suggestions? The car runs great, A/C cold, fan works, wipers, lights, radio all working. Just wont shut off after removing the key. Could the ignition switch be bad again? It also starts right back up no problem and idles smooth. Any ideas would be appreciated! Thanks JR
Reply With Quote
  #2 (permalink)  
Old 19 Jun 2018, 05:48 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,473
Default Re: 2006 PT Base Engine running w/o Key wont shut down

Quote:
Originally Posted by JRR View Post
2006 Base PT non turbo. Engine will not shut down. Turn off key and remove key and it keeps running. Last year new PCM installed, new ignition switch, new crank sensor. and the aftermarket remote locks and alarm was removed. Has been running great and runs well now. However I cant shut off the engine! removed key and it continues to run. Very minimal information online on this issue. I saw a post about the high speed fan relay being the issue. When I unplug 1 of the two separate relays mounted on the fire wall drivers side the engine shuts off. Removing the other relay does nothing. Same part # so I swapped them. Still engine keeps running until I unplug the (i am assuming) high speed relay. What would a fan relay have to do with the engine not shutting off? I also have to assume if I swapped them its not the actual relay? Any suggestions? The car runs great, A/C cold, fan works, wipers, lights, radio all working. Just wont shut off after removing the key. Could the ignition switch be bad again? It also starts right back up no problem and idles smooth. Any ideas would be appreciated! Thanks JR
Is your parking lights staying on? Your TIPM is the power source to keep components running but we need to do a complete diagnosis before we starting looking at the TIPM. Sometimes water gets inside the TIPM and shorts out keeping the power source for certain components running.

Is your dash gauges still working with the key removed?
__________________
If at First You Don't Succeed - Try, Try Again

Last edited by ptcruisersteve; 19 Jun 2018 at 05:54 pm.
Reply With Quote
  #3 (permalink)  
Old 19 Jun 2018, 05:51 pm
rsrocket1's Avatar
Fanatic Cruiser
 
Join Date: Mar 2016
Location: Sacramento, CA
Posts: 769
Default Re: 2006 PT Base Engine running w/o Key wont shut down

With the amount of tinkering done to it with the remote locks and alarm, you might be missing a ground connection. The fan relay coil is always hot on the high side and the TIPM grounds the low side to energize the relay coil and turn on the fan so something may be using that path to ground and keeping the ignition system on even when the key should shut it down.

Go around and look for any missing or broken ground wires or lugs on the chassis without wires attached.
Reply With Quote
  #4 (permalink)  
Old 19 Jun 2018, 08:10 pm
rckstein's Avatar
Banned
 
Join Date: Dec 2010
Location: Texas
Posts: 15,518
Default Re: 2006 PT Base Engine running w/o Key wont shut down

Quote:
Originally Posted by JRR View Post
2006 Base PT non turbo. Engine will not shut down. Turn off key and remove key and it keeps running. Last year new PCM installed, new ignition switch, new crank sensor. and the aftermarket remote locks and alarm was removed. Has been running great and runs well now. However I cant shut off the engine! removed key and it continues to run. Very minimal information online on this issue. I saw a post about the high speed fan relay being the issue. When I unplug 1 of the two separate relays mounted on the fire wall drivers side the engine shuts off. Removing the other relay does nothing. Same part # so I swapped them. Still engine keeps running until I unplug the (i am assuming) high speed relay. What would a fan relay have to do with the engine not shutting off? I also have to assume if I swapped them its not the actual relay? Any suggestions? The car runs great, A/C cold, fan works, wipers, lights, radio all working. Just wont shut off after removing the key. Could the ignition switch be bad again? It also starts right back up no problem and idles smooth. Any ideas would be appreciated! Thanks JR
The relays on the firewall are not for the fan, one is for the starter and the other is the auto shut-down relay:



The relays for the fan should actually be mounted on the upper right corner (passenger) side of the fan at the top.
Reply With Quote
  #5 (permalink)  
Old 19 Jun 2018, 09:29 pm
JRR JRR is offline
Fresh Cruiser
 
Join Date: Aug 2017
Posts: 6
Default Re: 2006 PT Base Engine running w/o Key wont shut down

OK this makes more sense Thank you. When I unplug the auto shut down relay the engine shuts off. When I swapped the starter relay for the auto shut down relay no difference. Either way engine starts no issues however will not shut off even when key is removed. No lights are on. Everything else works normally. Any suggestions?
Reply With Quote
  #6 (permalink)  
Old 19 Jun 2018, 09:36 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,473
Default Re: 2006 PT Base Engine running w/o Key wont shut down

Quote:
Originally Posted by JRR View Post
OK this makes more sense Thank you. When I unplug the auto shut down relay the engine shuts off. When I swapped the starter relay for the auto shut down relay no difference. Either way engine starts no issues however will not shut off even when key is removed. No lights are on. Everything else works normally. Any suggestions?
You need to give us more details to help you.

With the key out is your parking lights still on?

With the key out does your gauges still work?
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #7 (permalink)  
Old 20 Jun 2018, 10:38 am
JRR JRR is offline
Fresh Cruiser
 
Join Date: Aug 2017
Posts: 6
Default Re: 2006 PT Base Engine running w/o Key wont shut down

When key is off - engine still running, Gauges are off, lights are off. Thanks
Reply With Quote
  #8 (permalink)  
Old 20 Jun 2018, 01:21 pm
Regular Cruiser
 
Join Date: Aug 2013
Location: Az
Posts: 169
Default Re: 2006 PT Base Engine running w/o Key wont shut down

Have you replaced the ignition switch?
Reply With Quote
  #9 (permalink)  
Old 21 Jun 2018, 12:36 pm
Senior Cruiser
 
Join Date: Jan 2013
Posts: 1,266
Default Re: 2006 PT Base Engine running w/o Key wont shut down

Run the engine, shut off with the ign. key; if it doesn't shut off, pull out the auto-shut down relay [ASD relay]. Using a test light connected to ground, probe the 4 cavities. The 2 larger wires colored red/yellow should be hot. The other 2 wires should not.

Connect the test light to battery positive. Probe the 2 brown wires.

Results?

Was any aftermarket accessory added to the car?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
interior lights wont shut off bluemonster General PT Cruiser Discussions 10 18 Mar 2018 08:33 pm
o4 AC shut down and windows wont work? drumrooster Tech & Performance Forum 2 15 Sep 2016 04:30 pm
COOLING FAN ISSUE WONT SHUT OFF JHL07CRUISER Tech & Performance Forum 2 08 Mar 2014 02:31 pm
2006 base model wont start jclayton973 Tech & Performance Forum 7 26 Jan 2014 04:15 pm
Fan not running after shut off.... derek02PT Tech & Performance Forum 7 27 Aug 2011 02:02 pm


All times are GMT -5. The time now is 09:41 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors