PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
2005 Engine starts, revs up, then dies

 
Like Tree23Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 27 Jun 2018, 10:13 pm
Fresh Cruiser
 
Join Date: Feb 2013
Location: Colonial Heights, VA
Posts: 13
Default 2005 Engine starts, revs up, then dies

My first post. Need help. I have benefited greatly from this forum for years. But now I have a problem I cannot solve. Sorry for lengthy post. Need to lay out all I have done.

Make/Model: 2005 PT Cruiser, non-turbo, automatic trans, 150K miles. Has been running flawlessly. Purchased used at 70K miles. All maintenance performed at prescribed intervals.

Problem: Four days ago--after operating normally earlier in the day--I attempted to start engine. It started, revved up to 2,500-3,000 RPMs, then suddenly died. CEL came on, as did security light. Tried again--same result. Checked error codes. P0508 was only one posted (IAC Valve Voltage Low).

Read extensively in this forum about other members who had the P0508 code appear.

Have done the following:
1. Checked for vacuum leaks by physical inspection -- none found.
2. Removed throttle body and IAC Valve. Cleaned both thoroughly with carb cleaner. Dirty, but cleaned up nicely. Valve spring operated freely.
3. Removed PCV Valve, inspected by shaking--it rattled as it should, so I reinstalled it.
4. Checked resistance across the two electrical connector tangs on the IAC Valve. Reading was 10.2 Ohms--within specified range, so I did not replace it.
5. Checked IAC Valve return circuit for continuity and for short to ground -- no problem found.
6. Checked IAC Valve signal circuit for continuity and for short to ground -- no problem found.
7. Disconnected electrical connectors at IAC Valve, TP Sensor, and MAP Sensor and cleaned with electronic contact cleaner.

Between each of these steps, I cleared the error code, and tried to start engine. Each time, the engine started, revved up to 2,500 RPMs, then died. Also, each time the P0508 code was reposted.

At this point, I suspect the PCM has likely failed. I plan to replace this vehicle in about 6 months and need to make it last until then. I have no experience with PCMs or their replacement.

Is there anything I have overlooked? Are there other suggestions from forum members?

Thanks
Reply With Quote
  #2 (permalink)  
Old 28 Jun 2018, 03:51 am
Senior Cruiser
 
Join Date: Jan 2013
Posts: 1,079
Default Re: 2005 Engine starts, revs up, then dies

Assuming you have good plugs and wires, I'd check the rubber caps on the brake booster. I had one blow off.

The IAC valve [aka IAC motor] is really a variable linear solenoid. The engine computer sends current to it. The amount of current it sends changes the 'plunger position' which changes the engine rpm. Except for cold start up, the rpm should stay between 700-800 rpm, AC on or off.

Because the tangs were not grounded, the computer might be ok. Even if the resistance is ok, the plunger could be binding or hanging up. I'd change that first. Just to eliminate a possible cause.

I change my pcv valve every other plug change [60,000 miles]. They are more complex than the old style ones.
Grasshopper77 likes this.
Reply With Quote
  #3 (permalink)  
Old 28 Jun 2018, 09:35 am
Fresh Cruiser
 
Join Date: Feb 2013
Location: Colonial Heights, VA
Posts: 13
Default Re: 2005 Engine starts, revs up, then dies

Thanks for prompt reply, PT06. Plugs/wires are in great shape.

Where are the rubber caps located on the brake booster? Will look for them next. Unfortunately, I cannot do a thorough vacuum leak search since the engine will not run.

I followed a IAC Valve troubleshooting guide on AutoZone website. Their picture for a 2005 was not like mine, but the one for a 2006-2007 was a match. So I used that guide. It had me first check resistance across the two electrical tangs on the IAC Valve, saying it should be between 8.7-10.7 Ohms. Mine read 10.2. For comparison, I did the same check on a new one I had purchased the night before and it also read 10.2 Ohms. Since the resistance was within acceptable range, the guide advised me to leave it and directed me to the next diagnostic step which was to check wire continuities and possible grounded conditions in the harness between the IAC Valve and the PCM--All checked OK.

I prefer not to throw parts at the problem on a just-in-case basis, but am very willing to replace the IAC Valve if the described resistance check is not a sufficient diagnostic test. The replacement IAC Valve cost $52 at Advance Auto--certainly cheaper than a PCM. However, I read numerous posts on this forum that advised cleaning the IAC Valve was typically adequate to free up any sticking problems. I would appreciate any added thoughts on this.

Thanks for the tip on the PCV valve. Have not changed one on any of my vehicles since the 60s-70s, but it is very inexpensive, so I will definitely pick up a new one.

Again, your help is much appreciated!

Rich (a.k.a. LeftyPicker)
Reply With Quote
  #4 (permalink)  
Old 28 Jun 2018, 09:47 am
Senior Cruiser
 
Join Date: Jun 2014
Posts: 1,511
Default Re: 2005 Engine starts, revs up, then dies

How are you checking the codes? With an actual reader, or by doing the "key dance" and reading the codes in the odometer? If you are not using an actual reader, you may actually have others that are not displayed in the odometer.
Reply With Quote
  #5 (permalink)  
Old 28 Jun 2018, 10:21 am
Fresh Cruiser
 
Join Date: Feb 2013
Location: Colonial Heights, VA
Posts: 13
Default Re: 2005 Engine starts, revs up, then dies

Key dance. Since it will not start, I cannot take it to Advance Auto or a similar place to have them check it. Should probably go ahead and buy me an OBDII to keep here in my garage. Will check with some friends to see if I can borrow one. If not, will buy one.
Thanks
Reply With Quote
  #6 (permalink)  
Old 28 Jun 2018, 02:59 pm
Young Cruiser
 
Join Date: Apr 2018
Location: Sacramento, Commiefornia
Posts: 72
Default Re: 2005 Engine starts, revs up, then dies

Quote:
Originally Posted by LeftyPicker View Post
Key dance. Since it will not start, I cannot take it to Advance Auto or a similar place to have them check it. Should probably go ahead and buy me an OBDII to keep here in my garage. Will check with some friends to see if I can borrow one. If not, will buy one.
Thanks
45 bucks and you can use a 20% off on it as well.
Reply With Quote
  #7 (permalink)  
Old 28 Jun 2018, 05:03 pm
Fresh Cruiser
 
Join Date: Feb 2013
Location: Colonial Heights, VA
Posts: 13
Default Re: 2005 Engine starts, revs up, then dies

Thanks, dercannius. Had already looked it up on their website. Luckily, HF just opened a store only 3 miles away! Going there tonight when my wife returns with our one operational vehicle.
Reply With Quote
  #8 (permalink)  
Old 28 Jun 2018, 05:14 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,063
Default Re: 2005 Engine starts, revs up, then dies

How are you resetting the diagnostic trouble code? You need an OBDII scan tool as disconnecting the battery does not erase the codes.
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #9 (permalink)  
Old 28 Jun 2018, 08:20 pm
Fresh Cruiser
 
Join Date: Feb 2013
Location: Colonial Heights, VA
Posts: 13
Default Re: 2005 Engine starts, revs up, then dies

Went to Harbor Freight tonight to buy one and they were out of stock. Truck coming in tonight, so will pick one up tomorrow. I admit, it is a tool I should have had in my shop a long time ago. Thanks, Steve.

BTW, thus far in my troubleshooting, I have benefited greatly from reading earlier assistance you gave to other forum members having a similar problem.

Many thanks,
Rich
a.k.a. LeftyPicker
Reply With Quote
  #10 (permalink)  
Old 29 Jun 2018, 03:13 am
Senior Cruiser
 
Join Date: Jan 2013
Posts: 1,079
Default Re: 2005 Engine starts, revs up, then dies

Lefty; the brake booster has a valve on the front, on the inward side. Visible looking straight down. A small flashlight in dim light helps. There are 3 nipples on mine [2006]. One has a hose going to the intake manifold. The other two have a black rubber cap on them.

Check the throttle cables. Remove the black plastic cover and check for slack in both of the cables when the throttle plate is closed. A little light oil helps. Check for binding of the cables.

good luck
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
starts and then dies on me Harvey1986 Tech & Performance Forum 8 17 May 2017 04:50 pm
Starts runs dies right away Justontime56 Tech & Performance Forum 13 24 Mar 2017 10:05 pm
Engine dies, car re-starts but shakes like a sick dog before dying again HippysChick Tech & Performance Forum 3 10 Jun 2016 08:54 pm
Engine dies in 'drive', but revs in 'reverse' Ford005 Tech & Performance Forum 3 29 Aug 2013 02:29 pm
Engine Revs and then dies at start Chas777 Tech & Performance Forum 3 12 Jun 2011 06:53 pm


All times are GMT -5. The time now is 04:29 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors