PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Limp mode today

 
Like Tree1Likes
  • 1 Post By siamese_retriever

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 11 Jul 2018, 03:41 pm
Fresh Cruiser
 
Join Date: May 2016
Location: Bolingbrook, IL
Posts: 46
Default Limp mode today

Well, this was a new thing for me! My 2007 went into limp mode today, on the interstate. I have a cheap OBD in the car, and it gave me three codes - P0700, P0882, and C2500. I am hoping to get some tips on what I can check in the next hour or so before my wife picks me up to give me a ride home. Looks like it is an electrical issue from my (very) brief research. I don't have my meter in the car, but she is bringing that along with her. Side note - MIL and the airbag lights came on when this happened, and are still on.

Thanks!
Reply With Quote
  #2 (permalink)  
Old 11 Jul 2018, 06:06 pm
Handy_Cruiser's Avatar
Obsessed Cruiser
 
Join Date: Oct 2013
Location: Arkansas
Posts: 9,671
Default Re: Limp mode today

You may need to inspect for a damaged wiring harness. Remove the air filter housing and check every wire you can find. Unplug the four plugs from the PCM, then clean them and plug them back in.
__________________
Reply With Quote
  #3 (permalink)  
Old 11 Jul 2018, 06:51 pm
Fresh Cruiser
 
Join Date: May 2016
Location: Bolingbrook, IL
Posts: 46
Default Re: Limp mode today

Thanks!! I did another forum search and used a different code from today that time, and found a thread with a whole lot of information. Dealing with this might be more than I have time & patience for right now, so I may look for a shop that can handle electrical gremlins. The ground wires next to the battery _looked_ okay, but I am going to look for contact cleaner and check them a little closer. I am also going to see if I can find the PCM. When this happened, I thought the transmission was shot. I am somewhat relieved that it is more likely an electrical issue.
Handy_Cruiser likes this.
Reply With Quote
  #4 (permalink)  
Old 12 Jul 2018, 08:50 am
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,144
Default Re: Limp mode today

Quote:
Originally Posted by siamese_retriever View Post
Well, this was a new thing for me! My 2007 went into limp mode today, on the interstate. I have a cheap OBD in the car, and it gave me three codes - P0700, P0882, and C2500. I am hoping to get some tips on what I can check in the next hour or so before my wife picks me up to give me a ride home. Looks like it is an electrical issue from my (very) brief research. I don't have my meter in the car, but she is bringing that along with her. Side note - MIL and the airbag lights came on when this happened, and are still on.

Thanks!
Does your OBD tell you what the C2500 is for?
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Limp Mode? Bentron General PT Cruiser Discussions 23 21 Jun 2016 10:54 am
Limp Mode....? CluelessKate Tech & Performance Forum 6 11 May 2016 11:51 am
limp mode questions... sugarplumscruiser Tech & Performance Forum 6 03 Aug 2015 09:21 pm
Transmission going into Limp Mode KariJ Tech & Performance Forum 1 22 Jul 2014 04:02 pm
help..limp mode ivynthemnts758 Tech & Performance Forum 2 09 Sep 2010 08:44 am


All times are GMT -5. The time now is 03:08 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors