PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
06 stutters and hesitates sometimes

 
Like Tree18Likes

Reply
 
LinkBack Thread Tools Display Modes
  #11 (permalink)  
Old 17 Aug 2018, 06:16 am
rckstein's Avatar
Banned
 
Join Date: Dec 2010
Location: Texas
Posts: 15,518
Default Re: 06 stutters and hesitates sometimes

Quote:
Originally Posted by wingman55 View Post
Thank you all for the suggestions.

rckstein, is there a procedure in the Field Service Manuals to do this? Or can I find it somewhere else?

Thanks.
The following is not my procedure, but the info was provided to me by the source that I got my rebuilt PCM from over a year ago:

This is from the Service Manual on the PCM connectors:



Your PCM probably doesn't have the green connector as that is for the auto trans. Please note the last sentence about the black PCM connector.

Before disconnecting the PCM connectors, disconnect the battery:

Remove negative battery terminal
Remove positive battery terminal
Touch both cable ends together for at least 60 seconds
Leave battery disconnected

Disconnect all the PCM connectors and leave PCM disconnected for at least 1 hour

After 1 hour, reconnect PCM, black connector first

Reconnect battery (positive terminal first, then negative)

While the battery is disconnected it's a good idea to take that time to clean the battery posts and the cable ends, and also a good time to install corrosion protection pads.

Also, since you will have the air box out to disconnect the battery, it would also be the ideal time to check the ground wire bundle on the inner fender for any corrosion, clean if necessary. That bundle contains the grounds for the TIPM and cooling fan, as well as several other components.

It won't cost you anything to do the above procedure except a little bit of time and will be like giving the TIPM and PCM a reboot.
pt06, chuzz and wingman55 like this.
Reply With Quote
  #12 (permalink)  
Old 19 Aug 2018, 10:54 am
wingman55's Avatar
Senior Cruiser
 
Join Date: Aug 2015
Location: Pennellville, NY
Posts: 1,616
Default Re: 06 stutters and hesitates sometimes

Quote:
Originally Posted by rckstein View Post
The following is not my procedure, but the info was provided to me by the source that I got my rebuilt PCM from over a year ago:
..................................

Your PCM probably doesn't have the green connector as that is for the auto trans. Please note the last sentence about the black PCM connector.

Before disconnecting the PCM connectors, disconnect the battery:

...................

After 1 hour, reconnect PCM, black connector first

Reconnect battery (positive terminal first, then negative)

While the battery is disconnected it's a good idea to take that time to clean the battery posts and the cable ends, and also a good time to install corrosion protection pads.

Also, since you will have the air box out ...................

................
MUCH appreciated rckstein!!!! I need to remove the airbox again anyway, because when I was trying to track down an ASD Relay (which I discovered is buried in the TIPM much to my chagrin) I found this:

IMG_20180816_190926737 (2) (Phone).jpg

Time to replace.
rckstein likes this.
__________________
2006 Limited Edition, Inferno Red, 5-speed, Bassani dual exhaust, Chrome backup light bezels, taillight trim, fuel door, antenna mount, Ventiports, door spear covers & hood prop. Silver painted lower front grille. American Racing 383 Casino wheels, w/Chrysler emblems, '02 engine cover, PT Cruiser mudguards, cargo mat. EGR Window Visors, dark gray lock pulls, dual horns, Fuzzy Dice, flames and MOPAR emblems added to front door logos, gold Chrysler emblem on rear hatch. Upgraded to RAK radio with 6 CD changer, Cassette Tape and RDS info. Name: "FIREBALL" I bought it Aug 10, 2015, with just over 35,600 miles on it.
Reply With Quote
  #13 (permalink)  
Old 19 Aug 2018, 01:37 pm
LionPT's Avatar
Veteran Cruiser
 
Join Date: May 2014
Location: Central Florida
Posts: 4,456
Default Re: 06 stutters and hesitates sometimes

Quote:
Originally Posted by wingman55 View Post
MUCH appreciated rckstein!!!! I need to remove the airbox again anyway, because when I was trying to track down an ASD Relay (which I discovered is buried in the TIPM much to my chagrin) I found this:
Time to replace.

The ASD is not in the TIPM, it's behind it on the firewall.
__________________

2006 Touring Edition in Cool Vanilla...aka/Ghost
Reply With Quote
  #14 (permalink)  
Old 22 Aug 2018, 12:01 pm
wingman55's Avatar
Senior Cruiser
 
Join Date: Aug 2015
Location: Pennellville, NY
Posts: 1,616
Default Re: 06 stutters and hesitates sometimes

Quote:
Originally Posted by LionPT View Post
The ASD is not in the TIPM, it's behind it on the firewall.
OH! I was wondering what those relays were for. Never thought that the ASD would be outside of the Box of Junk. Thanks!

I 'rebooted' the system as you showed me. Car ran fine on Monday, yesterday it was acting up again. I bought a couple O2 sensors, and will have my mechanic replace them when he does the annual New York State inspection on Monday. I figure since I actually did get a code at one time, I might as well.

And per all recommendations, I bought NTK replacements. They are supposed to be factory equipment I guess.

We'll see how it goes. I've entered FIREBALL in the New York State Fair parade with the local Chrysler (used to be PT) club next Tuesday. Hopefully it will be better by then.
rckstein and LionPT like this.
__________________
2006 Limited Edition, Inferno Red, 5-speed, Bassani dual exhaust, Chrome backup light bezels, taillight trim, fuel door, antenna mount, Ventiports, door spear covers & hood prop. Silver painted lower front grille. American Racing 383 Casino wheels, w/Chrysler emblems, '02 engine cover, PT Cruiser mudguards, cargo mat. EGR Window Visors, dark gray lock pulls, dual horns, Fuzzy Dice, flames and MOPAR emblems added to front door logos, gold Chrysler emblem on rear hatch. Upgraded to RAK radio with 6 CD changer, Cassette Tape and RDS info. Name: "FIREBALL" I bought it Aug 10, 2015, with just over 35,600 miles on it.

Last edited by wingman55; 23 Aug 2018 at 11:56 am. Reason: typo
Reply With Quote
  #15 (permalink)  
Old 22 Aug 2018, 02:18 pm
thehoghunter's Avatar
Cool Cruiser
 
Join Date: Aug 2011
Location: Tampa
Posts: 477
Default Re: 06 stutters and hesitates sometimes

Looks like you need some Booger Bushings! Way cheaper then what Chrysler will tell you needs replacing!

Quote:
I found this:


Time to replace.
wingman55 likes this.
__________________

2005 N/A 5 speed manual - Booger bushings, K&N Filter, MSD spark plug wires, APC Taillights, Accra-Form Running Boards, Hubcap Mike's Spoke Hubcaps, Retrosound radio (usb1-2/aux1-2/bluetooth), Chrysler 1949 Hood Ornament, and a Flameball white pearl shift knob (which makes it go faster).
Reply With Quote
  #16 (permalink)  
Old 23 Aug 2018, 12:00 pm
wingman55's Avatar
Senior Cruiser
 
Join Date: Aug 2015
Location: Pennellville, NY
Posts: 1,616
Default Re: 06 stutters and hesitates sometimes

Quote:
Originally Posted by thehoghunter View Post
Looks like you need some Booger Bushings! Way cheaper then what Chrysler will tell you needs replacing!
Yep, replaced it on Sunday. Had to buy a kit at Advance Auto. $22 for two bushings and one replacement 'cable end piece'. Ridiculously high price for three small pieces of plastic - but they had them, and it's fixed now. I only needed that one bushing.

It's quite noticeable how the shifting has tightened up though. That part has probably been worn out since I owned the car.
rckstein likes this.
__________________
2006 Limited Edition, Inferno Red, 5-speed, Bassani dual exhaust, Chrome backup light bezels, taillight trim, fuel door, antenna mount, Ventiports, door spear covers & hood prop. Silver painted lower front grille. American Racing 383 Casino wheels, w/Chrysler emblems, '02 engine cover, PT Cruiser mudguards, cargo mat. EGR Window Visors, dark gray lock pulls, dual horns, Fuzzy Dice, flames and MOPAR emblems added to front door logos, gold Chrysler emblem on rear hatch. Upgraded to RAK radio with 6 CD changer, Cassette Tape and RDS info. Name: "FIREBALL" I bought it Aug 10, 2015, with just over 35,600 miles on it.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hesitates on cold start mjptcrusier General PT Cruiser Discussions 5 30 Oct 2012 06:18 am
03 turbo stutters bkh67 Tech & Performance Forum 8 04 Jan 2011 12:15 pm
Dream series 1 hesitates in low gear WeatherMike General PT Cruiser Discussions 4 22 Feb 2010 04:46 pm
My PT stutters! bluemonster Tech & Performance Forum 2 09 Aug 2009 01:30 pm


All times are GMT -5. The time now is 11:53 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors