PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
05 GT no boost

 
Like Tree3Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 02 Oct 2018, 03:43 pm
Fresh Cruiser
 
Join Date: Feb 2017
Posts: 38
Default 05 GT no boost

Hi all.
my 05 GT`s turbo quit working. sunday it worked fine. monday drove it to work no boost. i took off the intake hose and the turbo fins turn easy by hand. i started the engine and the fins spin. when i increase the RPMs the fins spin faster but no boost. all the hoses are on. i pumped vacuum into the waste gate diaphragm and it holds no leaks, i pumped vacuum into the blow off no leaks. how do the solenoids on the fender work the turbo ? i feel they have something to do with no boost. nothing was done to the car except it sat for over a week and was not started until sunday to go shopping.
thanks for your time.
Reply With Quote
  #2 (permalink)  
Old 03 Oct 2018, 01:17 am
_PTGT03's Avatar
Fanatic Cruiser
 
Join Date: Oct 2015
Location: Abbotsford, British Columbia.
Posts: 768
Default Re: 05 GT no boost

what evidence do you have for having no boost ?
Handy_Cruiser likes this.
__________________
2003 GT M/T in Onyx Green Pearl on Michelin Pilot Sport AS 3 Plus Tires 205/50ZR17. Dark Slate Gray Interior. OEM cargo net, parcel shelf, slush mats and trunk protector, mud flaps, mopar subwoofer. Platinum edition pedals, Neon SX 2.0 steering wheel with black+grey wrapped leather cover. Generic lowering springs, KYB gas shocks, Valeo solid flywheel conversion and clutch kit. Urethane insert engine mounts. Energy suspension full body urethane bushing kit. Chrysler premium front speakers, Jenson 6x9 rears. Boston Audio 4x55W amp. Panasonic head unit with xtenzi bluetooth. 300W AC power inverter. Escort 360max and Escort Shifter ZR4, dual front+rear dash camera. stage 1 blow off valve and syked tune computer . Boost and oil pressure gauges with Turbo-Timer. Needswings 3" exhaust elbow, Electric valve actuated Y-pipe with catalytic converter. To do: coilovers, 2step controller, quaife diff, Air-Fuel Meter
Reply With Quote
  #3 (permalink)  
Old 03 Oct 2018, 10:42 am
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,473
Default Re: 05 GT no boost

Quote:
Originally Posted by 2_cruisers View Post
Hi all.
my 05 GT`s turbo quit working. sunday it worked fine. monday drove it to work no boost. i took off the intake hose and the turbo fins turn easy by hand. i started the engine and the fins spin. when i increase the RPMs the fins spin faster but no boost. all the hoses are on. i pumped vacuum into the waste gate diaphragm and it holds no leaks, i pumped vacuum into the blow off no leaks. how do the solenoids on the fender work the turbo ? i feel they have something to do with no boost. nothing was done to the car except it sat for over a week and was not started until sunday to go shopping.
thanks for your time.
Are you using an OBDII Scan Tool to check for codes? If so are you getting any codes?
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #4 (permalink)  
Old 03 Oct 2018, 04:29 pm
Fresh Cruiser
 
Join Date: Feb 2017
Posts: 38
Default Re: 05 GT no boost

no codes at all. the boost gauge says on zero. no blow off sounds. i took the hot side off the intercooler tonight and started the engine. very little pressure in the hose. i put my hand over the hose and nothing. i remember it blowing the hoses off at one time in the past. i shook the center of the turbine and it moves a lot. if i give it a good spin with my fingers i can hear it rub the sides of the housing. im thinking now its the bushings inside the turbo. i was told when i bought the car three years ago the turbo was replaced with a new Chrysler turbo. i only put 15,000 moles on it. i wonder if the oil line was plugged and ruined the original turbo and it was never replaced and ruined this turbo. any thoughts ????
Reply With Quote
  #5 (permalink)  
Old 03 Oct 2018, 09:29 pm
Senior Cruiser
 
Join Date: Jun 2014
Posts: 1,653
Default Re: 05 GT no boost

Quote:
Originally Posted by 2_cruisers View Post
no codes at all. the boost gauge says on zero. no blow off sounds. i took the hot side off the intercooler tonight and started the engine. very little pressure in the hose. i put my hand over the hose and nothing. i remember it blowing the hoses off at one time in the past. i shook the center of the turbine and it moves a lot. if i give it a good spin with my fingers i can hear it rub the sides of the housing. im thinking now its the bushings inside the turbo. i was told when i bought the car three years ago the turbo was replaced with a new Chrysler turbo. i only put 15,000 moles on it. i wonder if the oil line was plugged and ruined the original turbo and it was never replaced and ruined this turbo. any thoughts ????
Since you are able to make the turbine contact the housing, if the turbo isn't already finished, it's well on its way. Can you pull the turbine out or will it move at all if you attempt it? If you can pull it out a bit then the shaft almost certainly has broken. It really sounds like you need a new turbo.

There are a few options like buying a new cartridge on ebay for a little over $100. Made in china and probably good enough but who knows. You can also buy one from one of our vendors here, Chris at TurbosUnleashed.com that specializes in turbos and will ensure that it is perfect before it is shipped. It will be a bit more than the ebay piece I believe, but at least it will have been checked and gone through.
rockandroller likes this.
Reply With Quote
  #6 (permalink)  
Old 03 Oct 2018, 10:13 pm
_PTGT03's Avatar
Fanatic Cruiser
 
Join Date: Oct 2015
Location: Abbotsford, British Columbia.
Posts: 768
Default Re: 05 GT no boost

Quote:
Originally Posted by 2_cruisers View Post
no codes at all. the boost gauge says on zero. no blow off sounds. i took the hot side off the intercooler tonight and started the engine. very little pressure in the hose. i put my hand over the hose and nothing. i remember it blowing the hoses off at one time in the past. i shook the center of the turbine and it moves a lot. if i give it a good spin with my fingers i can hear it rub the sides of the housing. im thinking now its the bushings inside the turbo. i was told when i bought the car three years ago the turbo was replaced with a new Chrysler turbo. i only put 15,000 moles on it. i wonder if the oil line was plugged and ruined the original turbo and it was never replaced and ruined this turbo. any thoughts ????
you're always supposed to replace the oil lines when changing a turbo. a restriction in oil flow would have reduced the expected life
__________________
2003 GT M/T in Onyx Green Pearl on Michelin Pilot Sport AS 3 Plus Tires 205/50ZR17. Dark Slate Gray Interior. OEM cargo net, parcel shelf, slush mats and trunk protector, mud flaps, mopar subwoofer. Platinum edition pedals, Neon SX 2.0 steering wheel with black+grey wrapped leather cover. Generic lowering springs, KYB gas shocks, Valeo solid flywheel conversion and clutch kit. Urethane insert engine mounts. Energy suspension full body urethane bushing kit. Chrysler premium front speakers, Jenson 6x9 rears. Boston Audio 4x55W amp. Panasonic head unit with xtenzi bluetooth. 300W AC power inverter. Escort 360max and Escort Shifter ZR4, dual front+rear dash camera. stage 1 blow off valve and syked tune computer . Boost and oil pressure gauges with Turbo-Timer. Needswings 3" exhaust elbow, Electric valve actuated Y-pipe with catalytic converter. To do: coilovers, 2step controller, quaife diff, Air-Fuel Meter
Reply With Quote
  #7 (permalink)  
Old 04 Oct 2018, 04:30 pm
Fresh Cruiser
 
Join Date: Feb 2017
Posts: 38
Default Re: 05 GT no boost

i pressure tested the system tonight i only went to 10 lbs and it held pressure.
so the hoses and inner cooler are ok. now i got a code PO033 probably because i was moving the waste gate by hand while the engine was running.
now the insides of the turbo moves a lot. up and down. but it also pulls in and out very little. i think its self destructing its self. i might as well get a new cartage and oil line.
thanks for the help.
I`ll post when i get the turbo rebuilt. im hoping in two weeks.
Reply With Quote
  #8 (permalink)  
Old 04 Oct 2018, 06:33 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,473
Default Re: 05 GT no boost

Quote:
Originally Posted by 2_cruisers View Post
i pressure tested the system tonight i only went to 10 lbs and it held pressure.
so the hoses and inner cooler are ok. now i got a code PO033 probably because i was moving the waste gate by hand while the engine was running.
now the insides of the turbo moves a lot. up and down. but it also pulls in and out very little. i think its self destructing its self. i might as well get a new cartage and oil line.
thanks for the help.
I`ll post when i get the turbo rebuilt. im hoping in two weeks.
P0033 - Turbocharger Bypass Valve Control Circuit

Possible causes:
1. Faulty Turbocharger Bypass Valve
2. Turbocharger Bypass Valve harness is open or shorted
3. Turbocharger Bypass Valve circuit poor electrical connection
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #9 (permalink)  
Old 26 Oct 2018, 04:07 pm
Fresh Cruiser
 
Join Date: Feb 2017
Posts: 38
Default Re: 05 GT no boost FIXED

the turbo was bad. it was put on new by the previous owner. they should of never touched it. the index pin was not aligned. causing the turbo to leak a little at the manifold. BUT the exhaust side shaft turbine is bent. not the fins the shaft. the hose on the oil line was pinched shut.
i went to a pick your own part junk yard that had 2 GT convertibles . one was smashed in the rear and had a recent turbo put on. nice and clean. most of the bolts missing or loose. the other gt had a original turbo. looked like it was never touched. all the bolts and clips were still in place. body was nice so a mechanical problem killed that car. i bought both for $100 for the pair.
i put the newer looking turbo on with a brand new oil line and now i have boost. a steady 10 LBS.
its a shame for my original turbo. still looks brand new inside. but its trashed.
the by pass valve was perfect and the waste gate was perfect. so i have some extra parts.
Some shade tree mechanics should not mess with cars they dont understand.
Reply With Quote
  #10 (permalink)  
Old 26 Oct 2018, 07:44 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,473
Default Re: 05 GT no boost FIXED

Quote:
Originally Posted by 2_cruisers View Post
the turbo was bad. it was put on new by the previous owner. they should of never touched it. the index pin was not aligned. causing the turbo to leak a little at the manifold. BUT the exhaust side shaft turbine is bent. not the fins the shaft. the hose on the oil line was pinched shut.
i went to a pick your own part junk yard that had 2 GT convertibles . one was smashed in the rear and had a recent turbo put on. nice and clean. most of the bolts missing or loose. the other gt had a original turbo. looked like it was never touched. all the bolts and clips were still in place. body was nice so a mechanical problem killed that car. i bought both for $100 for the pair.
i put the newer looking turbo on with a brand new oil line and now i have boost. a steady 10 LBS.
its a shame for my original turbo. still looks brand new inside. but its trashed.
the by pass valve was perfect and the waste gate was perfect. so i have some extra parts.
Some shade tree mechanics should not mess with cars they dont understand.
So the lesson here is to reset the codes and see if the P0033 code comes back.
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Does the Pt really boost in 4th needmoretoys General Turbo Discussions 24 19 Apr 2013 07:11 am
not enough boost!! jakeiniowa Turbo Performance 17 15 Nov 2011 08:58 pm
Part Throttle boost with boost controller forcedinduction Turbo Performance 2 18 Feb 2006 01:48 pm
ABOUT BOOST!!!!! EDGAR TAMAYO Turbo Performance 2 07 Apr 2004 04:30 pm
What's MAX boost... COP TZER Turbo Performance 7 31 Jul 2003 06:46 pm


All times are GMT -5. The time now is 10:00 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors