PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
yet another error/wiring problem U0025

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 29 Oct 2018, 06:39 pm
Fresh Cruiser
 
Join Date: Aug 2016
Location: ohio
Posts: 26
Default yet another error/wiring problem U0025

ok. 2006 TE with 228k on it. up until yesterday it ran perfect.
last night I started it check engine light.batt/airbag/other warning lights.

pulled U0025 code something about the wiring to the srs system.

took apart steering column and found one badly done electrical connection by PO. fixed, now it starts , but all the warning lights are still there after we cleared the codes and reset it all.

I am a bit stressed right now because I own 2 running vehicles and neither of them are running ATM.
__________________
Retired after 45 years, worked at various things, ran a business for a while.
Married 3 kids, 2 grandkids
Daily Driver 2006 PTC,
hobby car:87 Porsche 944, currently in restoration mode.
99 F250 for hauling stuff.
Reply With Quote
  #2 (permalink)  
Old 29 Oct 2018, 09:42 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,475
Default Re: yet another error/wiring problem U0025

KI would check the group of ground wires on the drivers side fender. They get corroded and lose contact.

Is the battery still being charged up? Are you getting around 14 volts with the engine running?

The plug or wiring going to the plug under the steering column going to the instrument Cluster sometimes goes bad. Check on youtube and see if it matches all the lights coming up on your dash. Other members have had similiar problems.

Key in google Chrysler Pt Cruiser dash light Instrument Cluster
__________________
If at First You Don't Succeed - Try, Try Again

Last edited by ptcruisersteve; 29 Oct 2018 at 10:07 pm.
Reply With Quote
  #3 (permalink)  
Old 30 Oct 2018, 05:01 pm
Fresh Cruiser
 
Join Date: Aug 2016
Location: ohio
Posts: 26
Default Re: yet another error/wiring problem U0025

charged 14.7v yesterday
all grounds clean tight and electric grease
fixed wire, wiggled plug, removed and reset, seems tight
dash lights still..
checked out video on this problem, did as advised, still bad.

update 10-31

replaced ignition switch. no speedometer starts and runs.
__________________
Retired after 45 years, worked at various things, ran a business for a while.
Married 3 kids, 2 grandkids
Daily Driver 2006 PTC,
hobby car:87 Porsche 944, currently in restoration mode.
99 F250 for hauling stuff.

Last edited by 944tim; 31 Oct 2018 at 01:42 pm.
Reply With Quote
Reply

Tags
dashlights, u0025, wiring


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Headlight wiring problem JohnCO General PT Cruiser Discussions 4 15 Oct 2014 12:11 pm
Problem with hitch wiring sToNeCoLd_CrUzR General PT Cruiser Discussions 3 15 Oct 2012 12:44 pm
wiring up switch for fogs, ran into problem. jrbsr05pt Exterior Accessories Forum 3 03 Jun 2012 09:20 pm
Trailer Wiring Harness Problem captspaulding General PT Cruiser Discussions 4 11 Jan 2012 06:11 pm
transmission internal wiring problem??? dcrider81 Tech & Performance Forum 13 14 Aug 2009 12:51 pm


All times are GMT -5. The time now is 09:10 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors