PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Changed motors now it won't start

 
Like Tree5Likes
  • 3 Post By _PTGT03
  • 1 Post By ptcruisersteve
  • 1 Post By rob302

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 19 Feb 2019, 11:46 pm
Fresh Cruiser
 
Join Date: Jan 2018
Posts: 1
Default Changed motors now it won't start

I have a 2002 Pt Cruiser Touring 2.4 automatic. It had a blown head gasket so i had another motor put in it , it came from a 2001 PT cruiser . Now that it's been installed it will not start ...doesn't crank . I told the guy that put the motor in that i read somewhere online that when you switch motors that you need the PCM that was with that motor but all he had was the motor . i can order a PCM from EBay but how would i get the correct ID number for it ? and would i need a different key , one that's programed for the 2001 ? If anyone can answer my questions and has any idea what I should do PLEASE help me . I love my PT Cruiser and it's my only means of transportation .
Reply With Quote
  #2 (permalink)  
Old 20 Feb 2019, 12:20 am
Senior Cruiser
 
Join Date: Jan 2014
Location: SW PA
Posts: 1,357
Default Re: Changed motors now it won't start

If it was running before you switched motors and you installed another NA (Naturally Aspirated) motor
If it was a Turbo motor you would have had to install an other turbo motor.
The computer should be no problem unless I forgot something, I would first check the wiring going to the starter as
it is easy to install the green wire (I think its the color) on the wrong terminal causing a no crank/start.

When you get it to crank and it will not start - check the connector going to the cam-sensor and the ??? as the two connectors are the same configuration
and easily connected to the wrong sensor because of the close proximity to each other

PCM changes with Turbo. Will not work with NA
PCM are CANBUS starting 2006- will not work in earlier Cruisers
__________________
Addicted to Mopar You can tell how old I am..
65 Dodge Coronet 6 cyl 2dr Post
66 Ply Satellite with 273 engine swap to 69 340 4spd
70 340 4spd Dart Swinger "Those were the days my friend"
73 Charger SE
Had a few Vetts on the way 69, 85
Several Neons some flips
01 Sebring flip
Cruiser's 01, 220K Gone to a new home
Cruiser 03 133K Gone to a new home
Cruiser 06 110K Project Gone to new Home
Cruiser 05 Ltd 120,809 bought with broken belt Oct2015
May 16 Resurrected to once again roam the streets.

20 Miles South Of Pittsburgh

Last edited by JoeX; 20 Feb 2019 at 12:32 am.
Reply With Quote
  #3 (permalink)  
Old 20 Feb 2019, 01:21 am
_PTGT03's Avatar
Fanatic Cruiser
 
Join Date: Oct 2015
Location: Abbotsford, British Columbia.
Posts: 768
Default Re: Changed motors now it won't start

Quote:
Originally Posted by Ruthies02 View Post
I have a 2002 Pt Cruiser Touring 2.4 automatic. It had a blown head gasket so i had another motor put in it , it came from a 2001 PT cruiser . Now that it's been installed it will not start ...doesn't crank . I told the guy that put the motor in that i read somewhere online that when you switch motors that you need the PCM that was with that motor but all he had was the motor . i can order a PCM from EBay but how would i get the correct ID number for it ? and would i need a different key , one that's programed for the 2001 ? If anyone can answer my questions and has any idea what I should do PLEASE help me . I love my PT Cruiser and it's my only means of transportation .
im just wondering what kind of mechanic you used when they made an engine swap for you but couldn't get it working as part of the job ?
It's largely impossible to be trying to diagnose this over an internet forum. your mechanic should be troubleshooting with the electrical diagrams to determine why there's no engine cranking before anything else is done.
rckstein, rob302 and the3dgm like this.
__________________
2003 GT M/T in Onyx Green Pearl on Michelin Pilot Sport AS 3 Plus Tires 205/50ZR17. Dark Slate Gray Interior. OEM cargo net, parcel shelf, slush mats and trunk protector, mud flaps, mopar subwoofer. Platinum edition pedals, Neon SX 2.0 steering wheel with black+grey wrapped leather cover. Generic lowering springs, KYB gas shocks, Valeo solid flywheel conversion and clutch kit. Urethane insert engine mounts. Energy suspension full body urethane bushing kit. Chrysler premium front speakers, Jenson 6x9 rears. Boston Audio 4x55W amp. Panasonic head unit with xtenzi bluetooth. 300W AC power inverter. Escort 360max and Escort Shifter ZR4, dual front+rear dash camera. stage 1 blow off valve and syked tune computer . Boost and oil pressure gauges with Turbo-Timer. Needswings 3" exhaust elbow, Electric valve actuated Y-pipe with catalytic converter. To do: coilovers, 2step controller, quaife diff, Air-Fuel Meter
Reply With Quote
  #4 (permalink)  
Old 20 Feb 2019, 01:56 am
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,473
Default Re: Changed motors now it won't start

Quote:
Originally Posted by JoeX View Post
If it was running before you switched motors and you installed another NA (Naturally Aspirated) motor
If it was a Turbo motor you would have had to install an other turbo motor.
The computer should be no problem unless I forgot something, I would first check the wiring going to the starter as
it is easy to install the green wire (I think its the color) on the wrong terminal causing a no crank/start.

When you get it to crank and it will not start - check the connector going to the cam-sensor and the ??? as the two connectors are the same configuration
and easily connected to the wrong sensor because of the close proximity to each other


PCM changes with Turbo. Will not work with NA
PCM are CANBUS starting 2006- will not work in earlier Cruisers
As Joe posted, check and see if the camshaft sensor connector and the ignition coil connector got swapped. It happened to some other members.
pt06 likes this.
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #5 (permalink)  
Old 20 Feb 2019, 06:16 am
Senior Cruiser
 
Join Date: Jan 2013
Posts: 1,266
Default Re: Changed motors now it won't start

There is a difference between 'doesn't crank' and 'cranks but doesn't start'. Assuming the 'doesn't crank' ---- when you try to start the car, turn the key to the run position. The fuel pump should hum for a few seconds, then go quiet. If no hum, check the ASD relay and wiring.

The PCM doesn't know or care about the engine. It only cares about the engine sensor values.
Reply With Quote
  #6 (permalink)  
Old 20 Feb 2019, 08:50 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,473
Default Re: Changed motors now it won't start

Does the lights dim when you try to crank? If so you might want to see if you have 12 volts going to the starter. If you have 12 volts going to the starter your engine might be frozen.

If not first check all your fuses.
__________________
If at First You Don't Succeed - Try, Try Again

Last edited by ptcruisersteve; 20 Feb 2019 at 08:53 pm.
Reply With Quote
  #7 (permalink)  
Old 21 Feb 2019, 02:04 pm
Regular Cruiser
 
Join Date: Jul 2016
Location: east central wisconsin
Posts: 172
Default Re: Changed motors now it won't start

Only possible compatibility problem I could find is if engine has a EGR or non EGR.
Look it up your self.Car-Part.com--Used Auto Parts Market

You would think swapping parts off the blocks would be less confusing than swapping ECUs. Considering all the other things the ECU controls.

Last edited by circus; 21 Feb 2019 at 02:11 pm.
Reply With Quote
  #8 (permalink)  
Old 21 Feb 2019, 04:09 pm
rob302's Avatar
Veteran Cruiser
 
Join Date: Jul 2016
Location: Darien, IL | Forest Park, IL
Posts: 3,557
Default Re: Changed motors now it won't start

Probably left the green wire off the starter.



Quote:
Originally Posted by _PTGT03 View Post
im just wondering what kind of mechanic you used when they made an engine swap for you but couldn't get it working as part of the job ?
she never said she used a mechanic
__________________
.

Last edited by rob302; 21 Feb 2019 at 06:04 pm.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Changed the fuel pump, it won't start UncleJerry General PT Cruiser Discussions 23 23 Oct 2017 03:34 pm
Changed timing belt/water pump and pulleys. Now it wont start 1337DirtAlliance Tech & Performance Forum 21 11 May 2017 12:20 pm
Error Code 0340, changed Cam Sensor, still won't start dave44602 Tech & Performance Forum 19 28 Nov 2014 02:53 pm
Timing Belt Changed and now will not start - HELP rhowle Tech & Performance Forum 3 18 Mar 2012 08:59 pm
Neon SRT Motors/GTPT Motors Only1Balto General Turbo Discussions 5 01 Jan 2011 07:04 pm


All times are GMT -5. The time now is 10:35 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors