PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Problems charging

 
Like Tree4Likes
  • 1 Post By Grasshopper77
  • 3 Post By RVC

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 18 Oct 2019, 04:50 pm
RVC RVC is offline
Regular Cruiser
 
Join Date: Feb 2016
Location: Winter Haven, FL
Posts: 150
Default Problems charging

I recently bought a basic 2006 with about 64.5k miles on it. The only problem encountered so far has been the charging system. I put a new battery in it, fully charged, and when I try to crank it the instrument panel goes blank, it doesn't crank and there are no other sounds.

There is probably a simple explanation for this but so far I haven't found one. Knowledgeable suggestions will be most helpful.

Thank you.

RVC
__________________

2002 2.4L Woody Normally aspirated
Purchased 2/29/16 w/ 104,048 miles
Reply With Quote
  #2 (permalink)  
Old 18 Oct 2019, 05:00 pm
Cool Cruiser
 
Join Date: May 2016
Posts: 323
Default Re: Problems charging

I'd start by checking the battery cable connections on bother ends, as well as, the entire length of the cables. You are not getting a good connection or there is a problem within the ignition system. Hopefully someone a lot more knowledgeable will stop in to offer some better advice.
Handy_Cruiser likes this.
Reply With Quote
  #3 (permalink)  
Old 18 Oct 2019, 06:58 pm
Senior Cruiser
 
Join Date: Jan 2014
Location: SW PA
Posts: 1,347
Default Re: Problems charging

Best guess is a short, possibly in the starter. Alternator charging in 2006 is controled by PCM. Check wires on starter, there is green wire than easily be attached to the wrong terminal getting a no crank condition.
__________________
Addicted to Mopar You can tell how old I am..
65 Dodge Coronet 6 cyl 2dr Post
66 Ply Satellite with 273 engine swap to 69 340 4spd
70 340 4spd Dart Swinger "Those were the days my friend"
73 Charger SE
Had a few Vetts on the way 69, 85
Several Neons some flips
01 Sebring flip
Cruiser's 01, 220K Gone to a new home
Cruiser 03 133K Gone to a new home
Cruiser 06 110K Project Gone to new Home
Cruiser 05 Ltd 120,809 bought with broken belt Oct2015
May 16 Resurrected to once again roam the streets.

20 Miles South Of Pittsburgh
Reply With Quote
  #4 (permalink)  
Old 18 Oct 2019, 07:23 pm
RickinPA's Avatar
Cool Cruiser
 
Join Date: Jun 2014
Location: southeastern PA
Posts: 311
Default Re: Problems charging

Checking the connections, as suggested above, is where to start. If the connections are clean and tight, I'd do a load test on the battery to verify it's OK. Then the next step is going over it with a voltmeter. If you're not handy with a voltmeter, find someone who is. Basically checking voltage levels to check cable & connection integrity.

The fact that the dash goes dark when you try to start it indicates the system voltage dies when the key hits the crank position. The question is why does the system voltage die? Could be a discharged battery, bad battery, bad connection, bad cable, or too much load on the battery.
Reply With Quote
  #5 (permalink)  
Old 19 Oct 2019, 08:12 am
Veteran Cruiser
 
Join Date: Aug 2015
Location: Lake Wales, FL
Posts: 4,838
Default Re: Problems charging

It sure sounds like a loose ground connection to me. I'd remove the air box assembly and check the grounds on the driver side fender AFTER checking the battery ground cable for a tight connection.
__________________


Aspire to inspire before you expire.
Reply With Quote
  #6 (permalink)  
Old 19 Oct 2019, 09:30 am
RVC RVC is offline
Regular Cruiser
 
Join Date: Feb 2016
Location: Winter Haven, FL
Posts: 150
Default Re: Problems charging

Thanks for the replies. As soon as the rain and wind die down here I'll be on it.

RVC
__________________

2002 2.4L Woody Normally aspirated
Purchased 2/29/16 w/ 104,048 miles
Reply With Quote
  #7 (permalink)  
Old 23 Oct 2019, 12:38 pm
RVC RVC is offline
Regular Cruiser
 
Join Date: Feb 2016
Location: Winter Haven, FL
Posts: 150
Default Re: Problems charging

Turns out it was the terminals, especially on the ground side, but none of them were in very good shape. Thanks for the input.

RVC
__________________

2002 2.4L Woody Normally aspirated
Purchased 2/29/16 w/ 104,048 miles
Reply With Quote
  #8 (permalink)  
Old 24 Oct 2019, 07:37 am
Veteran Cruiser
 
Join Date: Aug 2015
Location: Lake Wales, FL
Posts: 4,838
Default Re: Problems charging

So, you've fixed it and you're good to go?
__________________


Aspire to inspire before you expire.
Reply With Quote
  #9 (permalink)  
Old 25 Oct 2019, 11:46 am
RVC RVC is offline
Regular Cruiser
 
Join Date: Feb 2016
Location: Winter Haven, FL
Posts: 150
Default Re: Problems charging

Yep, for now anyway. But it's been sitting up for a while so who knows what's next. Thanks!

RVC
__________________

2002 2.4L Woody Normally aspirated
Purchased 2/29/16 w/ 104,048 miles
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Battery Charging problems. nebular Tech & Performance Forum 11 23 Jul 2018 11:50 am
Charging system robmet55 Tech & Performance Forum 4 22 Jun 2012 11:18 pm
pt not charging. eli Tech & Performance Forum 1 30 Jul 2011 02:03 pm
charging problems with 01 pt cruiser gdxxman General PT Cruiser Discussions 3 11 May 2009 04:59 am
UK crd charging question spiceweasel Tech & Performance Forum 6 15 Dec 2007 04:37 pm


All times are GMT -5. The time now is 06:22 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors