PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Strange issues, need help asap!

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 06 May 2020, 07:54 pm
Regular Cruiser
 
Join Date: May 2008
Location: Wyoming, MN
Posts: 170
Send a message via MSN to Ironman
Default Strange issues, need help asap!

A few months ago the ignition switch on my 2003 Touring got stuck, it wouldn't allow me to turn the key. I took off the cover and gave the cylinder a smack with a hammer, which fixed it. Yesterday, while cruising down the highway at 75mph with cruise control on, all power in the PT cut off. the spedo ramped down quickly as everything shut off. As I was getting ready to move to the shoulder, it fired back up and continued as if nothing ever happened. Today while shifting between 3rd and OD the transmission apparently shifted into neutral and won't shift out. I checked the fluid level, it's fine, The fluid doesn't smell burnt and looks new. I checked that the shift arm on the transmission moves when the selector is moved. It has about 160K on the clock and is an auto. No codes were thrown in either incident. Help!

EDIT: I forgot to mention, over the past few months it sounds like the fuel pump runs for about 10 seconds after I shut off the PT.
__________________
Non Turbo, Automatic Transmission 2003 Touring Edition, 104,xxx miles so far. Extras- cruise control, fog lights, sun roof, rear defroster, ABS, rear disk brakes, six speaker sound system, power locks, power windows, A.C., window tint, locking glove box. My personal mods so far- removed white air restricter, white hibiscus flowers sticker above the rear hatch lock, nice white primer/rust splotch underneath the passenger side tail light from bodywork...more to come once the money starts flowing freer and the car is payed off

Last edited by Ironman; 06 May 2020 at 08:05 pm.
Reply With Quote
  #2 (permalink)  
Old 13 May 2020, 08:43 pm
Regular Cruiser
 
Join Date: May 2008
Location: Wyoming, MN
Posts: 170
Send a message via MSN to Ironman
Default Re: Strange issues, need help asap!

Boy is this place dead. On the advice of people from two Facebook groups, I replaced the ignition switch, actuator, and cylinder. No change. I'll be going over connectors and ground wires this weekend if time allows. Next step, test the TIPM.
__________________
Non Turbo, Automatic Transmission 2003 Touring Edition, 104,xxx miles so far. Extras- cruise control, fog lights, sun roof, rear defroster, ABS, rear disk brakes, six speaker sound system, power locks, power windows, A.C., window tint, locking glove box. My personal mods so far- removed white air restricter, white hibiscus flowers sticker above the rear hatch lock, nice white primer/rust splotch underneath the passenger side tail light from bodywork...more to come once the money starts flowing freer and the car is payed off
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange timing belt failure and other strange symtoms StephenB Tech & Performance Forum 5 28 Mar 2016 12:57 pm
I need help ASAP!!! ebonylocke Tech & Performance Forum 11 15 Jul 2015 09:30 pm
PT Cruiser high rpms and strange acceleration issues CarNoob85 Tech & Performance Forum 9 28 Jan 2014 09:50 pm
NEED HELP ASAP!!!! myyellowty General PT Cruiser Discussions 5 21 Dec 2008 08:21 am
PLease help asap turbomangt General PT Cruiser Discussions 5 12 Oct 2003 12:00 am


All times are GMT -5. The time now is 02:30 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors