PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Goofy oil light

 
Like Tree8Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 22 Jan 2021, 02:38 pm
Cool Cruiser
 
Join Date: Jul 2016
Location: east central wisconsin
Posts: 244
Default Goofy oil light

04 non turbo
When starting cold the oil light comes on and stays on. Go's out if restarted. Replaced the sending unit, no change. A temporarily installed pressure gauge shows 80 to 100 psi cold. The only time the oil light is on. Is it's controlled by the computer?

Usually I say "to hell with it" but the engine needs a head gasket and I'm wondering whether to fix it or not.
Reply With Quote
  #2 (permalink)  
Old 22 Jan 2021, 03:17 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,598
Default Re: Goofy oil light

What brand oil sending unit did you purchase?

Did you use the special tool to install the oil sending unit?

Did you check the oil sending unit wiring from the engine to the PCM? Some members have also reported engine oil traveling up the wire to the PCM and engine oil is found inside the PCM plugin.

"When starting cold the oil light comes on and stays on. Go's out if restarted". Does the oil light go out immediately if you start the engine for a few seconds and then restart?

Was the oil pressure gauge you installed electrical or mechanical?
__________________
If at First You Don't Succeed - Try, Try Again

Last edited by ptcruisersteve; 22 Jan 2021 at 03:39 pm.
Reply With Quote
  #3 (permalink)  
Old 22 Jan 2021, 03:37 pm
Cool Cruiser
 
Join Date: Jul 2016
Location: east central wisconsin
Posts: 244
Default Re: Goofy oil light

Brand? Cheapest O'reilly sold. Masterpro maybe.
Socket? 27mm deep. Worked fine.
Oil travel? I'll look.
If I don't restart, the oil light never go's out. If I start it, run it for a second or two, kill it and restart it the light will be off and not come back on. After the engine isn't run for a couple hours, but not stone cold, a restart is not needed for the light to be off.

Last edited by circus; 22 Jan 2021 at 03:57 pm.
Reply With Quote
  #4 (permalink)  
Old 22 Jan 2021, 05:01 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,598
Default Re: Goofy oil light

Quote:
Originally Posted by circus View Post

Oil travel? I'll look.
Recommend using spray electrical cleaner to clean it up.

__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #5 (permalink)  
Old 22 Jan 2021, 05:07 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,598
Default Re: Goofy oil light

Quote:
Originally Posted by circus View Post
Socket? 27mm deep. Worked fine.
Other members have cracked the replacement oil sending unit by over torqueing it when installing it. No leaks?

Checked the port for oil blockage before installing the new oil sending unit?
__________________
If at First You Don't Succeed - Try, Try Again

Last edited by ptcruisersteve; 22 Jan 2021 at 05:09 pm.
Reply With Quote
  #6 (permalink)  
Old 22 Jan 2021, 05:59 pm
Cool Cruiser
 
Join Date: Jul 2016
Location: east central wisconsin
Posts: 244
Default Re: Goofy oil light

PCM connections clean and dry

Temporary (test) pressure gauge is a mech. dial facing up and 6" of pipe replacing the sending unit.
Using shop pressure found no sending unit leaks. I suppose I can buy a 2nd one but what's the odds the original and replacement has the same fault?

Good new is the engine oil pressure is fine. When warm it has 40 psi @ idle and 80 psi above idle.

What's really weird is, now there's no sending unit and the wire is just hanging, replaced by my test gauge, the light is acting exactly the same.

Last edited by circus; 22 Jan 2021 at 07:03 pm. Reason: What's really weird
Reply With Quote
  #7 (permalink)  
Old 22 Jan 2021, 08:24 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,598
Default Re: Goofy oil light

Quote:
Originally Posted by circus View Post
PCM connections clean and dry

Temporary (test) pressure gauge is a mech. dial facing up and 6" of pipe replacing the sending unit.
Using shop pressure found no sending unit leaks. I suppose I can buy a 2nd one but what's the odds the original and replacement has the same fault?

Good new is the engine oil pressure is fine. When warm it has 40 psi @ idle and 80 psi above idle.

What's really weird is, now there's no sending unit and the wire is just hanging, replaced by my test gauge, the light is acting exactly the same.
I am suggesting you might have a short to ground on the oil pressure sending unit circuit. I would suggest with the wire off of the oil pressure sending unit see with an ohm meter if the wire is shorted to ground. If it is I would disconnect the PCM plug that has the oil pressure sending unit wire going to it and see if it is still shorted after taking the PCM plug off.
__________________
If at First You Don't Succeed - Try, Try Again

Last edited by ptcruisersteve; 22 Jan 2021 at 08:26 pm.
Reply With Quote
  #8 (permalink)  
Old 22 Jan 2021, 09:21 pm
Cool Cruiser
 
Join Date: Jul 2016
Location: east central wisconsin
Posts: 244
Default Re: Goofy oil light

Quote:
Originally Posted by ptcruisersteve View Post
I am suggesting you might have a short to ground on the oil pressure sending unit circuit.
No short found beyond a micro blip from something discharging. Measuring with the key on got battery voltage, almost.
Reply With Quote
  #9 (permalink)  
Old 23 Jan 2021, 02:16 am
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,598
Default Re: Goofy oil light

Quote:
Originally Posted by circus View Post
No short found beyond a micro blip from something discharging. Measuring with the key on got battery voltage, almost.
I would suggest diagnosing to find out why the oil pressure sending unit is not making a difference.
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #10 (permalink)  
Old 23 Jan 2021, 07:07 am
Cool Cruiser
 
Join Date: Jul 2016
Location: east central wisconsin
Posts: 244
Default Re: Goofy oil light

Quote:
Originally Posted by ptcruisersteve View Post
I would suggest diagnosing to find out why the oil pressure sending unit is not making a difference.
Grounded the wire and the oil light stayed on no matter what I did. Faulty sending unit. I found the engine was worth pulling the head so if I still want to fix it after the head's pulled I'll just order another sending unit with all the other parts. Thank for the diagnostic help. What brand is good?
rockandroller likes this.

Last edited by circus; 23 Jan 2021 at 07:10 am.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
ABS Light, Parking Brake Light, Traction Control Light kupothechocobo General PT Cruiser Discussions 9 28 Feb 2017 01:56 pm
Showing ABS light, Brake light, Traction light on Dash fox50h Tech & Performance Forum 19 18 Feb 2014 11:40 pm
car won't start, goofy sound jdmickies Tech & Performance Forum 6 21 Feb 2010 08:50 pm
goofy code jdmickies Tech & Performance Forum 5 03 Nov 2009 10:46 pm
Monster PT mods, and other goofy ideas PTGT-NH General PT Cruiser Discussions 2 07 Jun 2003 04:02 am


All times are GMT -5. The time now is 01:38 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors