PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
i got 2 problems and i need ur help :(

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 17 Dec 2004, 07:42 am
Regular Cruiser
 
Join Date: Apr 2004
Location: Abu Dhabi, United Arab Emirates.
Posts: 136
Default i got 2 problems and i need ur help :(

hey guys, today it rained but that didnt end well.

I was goin at about 40 kms and went over a water pond and the water started goin everywhere like crazy. After about 20 min i stopped for a cup of coffee for like 10 min, and then started the car and it was alright. I drove for like 1 km and i hear this Sound "SSsssSSSsssSSS" it increases as i increase yhe pressure on the pedal. Stopped the car after 2 km and then popped the hood to see whats goin on. I press on the pedal and there is still sound. My friend is saying that its the Engine Belt.

Another problem accured, when u press the pedal u hear both the engine belt "SSSSsssSSSsssSS" and i think also the Throttle body doin "Tssh Tssh " everytime the pedal is pressed.

I checked the airfilter and it was wet, plus there was water at the bottom

Need ur help guys, thx
Reply With Quote
  #2 (permalink)  
Old 17 Dec 2004, 09:56 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,750
Default

SAAD,

It's hard to tell with the noises your describing, but if you have water getting into the intake system..that's not good. The cars running, so that's a good sign. The first thing before driving it anymore is to get rid of that air filter (or completely dry it out) and dry up any water you can find. I'd take the whole air filtering system out right up to the throttle body and make sure it's all dry. I don't think water would hurt the belts, and hopefully any noise from that will go away when it all drys up. Make sure there's no water in the cavity around the spark plugs too. Maybe others will have some advice too. Good luck.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #3 (permalink)  
Old 17 Dec 2004, 10:07 am
Regular Cruiser
 
Join Date: Apr 2004
Location: Abu Dhabi, United Arab Emirates.
Posts: 136
Default

thx for ur reply
Reply With Quote
  #4 (permalink)  
Old 17 Dec 2004, 11:40 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default

Agree (as usual) with Crewzin.
Hard to guess without hearing the sound. A belt usually "squeaks" or "Squeals" when it's wet, and dries pretty quickly.
A Hisss could also be continued sparking somewhere, like alternator, or perhaps sparks pplugs, but if it runs okay, I doubt spark plugs arcing.
Be sure and dry everything out, and I think you'll be fine.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #5 (permalink)  
Old 17 Dec 2004, 03:03 pm
Senior Cruiser
 
Join Date: Jan 2003
Location: Huntington Beach, CA, USA.
Posts: 1,799
Default

Is the car idling okay? The SSSSS could be a vacuum leak somewhere. Make sure all hoses are connected. If not that, you just have water somewhere is shouldn't be. I wouldn't wory too much. The only way you can get hydrolock is to almost submerge the intake. If you are running a stock box you cannot get enough water into the engine to harm it without putting the whole frontend under water. Just wait for everything to dry.
__________________
'03 Inferno Red GT, 5 speed, STAGE 1, Mopar BOV, Plastic Intake, Modified Upper and Lower Airbox, Custom Airbox-to-turbo pipe, Borla dual exhaust, Maddog Short Shifter, Drilled/Slotter Rotors, Ceramic Pads, chrome wheels, chrome door spears, AMP chrome fuel door, PT Cruiser 3rd light diffuser, H&R Springs, Rear Sway Bar added, MGW chrome door lock pulls, Blane's hood struts, Custom license plate mount, some interior dress up stuff...more to come
Reply With Quote
  #6 (permalink)  
Old 17 Dec 2004, 04:09 pm
Regular Cruiser
 
Join Date: Apr 2004
Location: Abu Dhabi, United Arab Emirates.
Posts: 136
Default

anyways am takin it tomorrow to check it at the dealer, thx for ur help guys
Reply With Quote
  #7 (permalink)  
Old 17 Dec 2004, 08:57 pm
Senior Cruiser
 
Join Date: Jan 2004
Location: Columbus, Nebraska, USA.
Posts: 1,574
Default

Quote:
quote:Originally posted by junkno

anyways am takin it tomorrow to check it at the dealer, thx for ur help guys
Good idea, better safe than sorry.
__________________
04 cool vanila Limited Turbo




Wife has a 03 limited
(Steel Blue)
Reply With Quote
  #8 (permalink)  
Old 18 Dec 2004, 11:24 am
Regular Cruiser
 
Join Date: Apr 2004
Location: Abu Dhabi, United Arab Emirates.
Posts: 136
Default

as i was leaving to the dealer, i started my car and the engine belt sound went away, i opened the hood and checked there is only the other sound which is the throttle body letting of air as i press on the pedal.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Window Problems in cold weather franski PT Cruiser Convertible Forum 3 31 Dec 2012 09:08 pm
So much problems before inspection Ctown General PT Cruiser Discussions 3 12 Apr 2005 07:45 pm
Headliner Problems!!! ptgtjoe General PT Cruiser Discussions 9 08 Mar 2005 02:46 pm
Any problems from "Lighting up the tires"? crazie.eddie Tech & Performance Forum 6 19 Oct 2004 06:43 pm
Problems Oddcouple General PT Cruiser Discussions 1 17 Nov 2002 01:58 pm


All times are GMT -5. The time now is 05:39 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors