PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
I think I'm having a power steering problem!

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 16 Jan 2005, 04:56 pm
Fresh Cruiser
 
Join Date: Jan 2005
Location: .
Posts: 6
Default I think I'm having a power steering problem!

Parked my car here in Central New York the other night around midnight and the car was fine. Got in it and drove about 7 hours later and now im having problems steering. its VERY difficult to turn the wheel (i literally have to pull the wheel using both hands, pputting all my weight into it. Takes me about 5 minutes to just pull out of a parking space now becuase of the lack of rotating the wheel will make (and lack of strength on my part). Anyone know what the problem might be? Its been down to single digit temps here recently. Maybe that would have a problem? I added some power steering fluid yesterday, but today I'm still having the same problem. Brother said it might be a bad power steering pump? Anyone know if a bad one would cause the results Im having? I have no clue about cars, so maybe I'm describing a common problem. Thanks for any help you can provide!

Also, thers just under 20000 miles on my PT. If I just brought it into a Chrysler dealer, can they tell me if this problem is covered under my warranty?
Reply With Quote
  #2 (permalink)  
Old 16 Jan 2005, 05:38 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,750
Default

You didn't say what year your PT is so it's hard to tell if your still under warranty. My power steering pump went without any warning at about 40K. I went into a turn using my casual one handed turn style and found the wheel wouldn't turn, had to use all my strength to get it to turn before hitting the center island. Just to get you set, without warranty, it's about $300 to get a new one installed at the dealer.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #3 (permalink)  
Old 16 Jan 2005, 10:57 pm
SRG SRG is offline
Cool Cruiser
 
Join Date: Aug 2002
Location: .
Posts: 320
Default

Did you check the belt? The power steering pump and the AC compressor run off the same belt.

SRG
Reply With Quote
  #4 (permalink)  
Old 17 Jan 2005, 10:22 pm
Hooligan's Avatar
Obsessed Cruiser
 
Join Date: Aug 2003
Posts: 6,023
Default

It is either the pump or the belt. Hopefully it is only the belt. That belt runs everything, A/C compressor, Alternator and Power Steering pump. Seems funny that it would be the belt tho. When was the last time you had the oil changed, at a full service place they check everything, belt included.
Reply With Quote
  #5 (permalink)  
Old 18 Jan 2005, 12:37 pm
Cool Cruiser
 
Join Date: May 2004
Location: East Islip, NY, USA.
Posts: 494
Send a message via AIM to RallyDRock
Default

only ps/ac.
alt is on its own belt
w/p is cam driven
__________________
www.cardomain.com/id/rallydrock
Reply With Quote
  #6 (permalink)  
Old 18 Jan 2005, 01:12 pm
Hooligan's Avatar
Obsessed Cruiser
 
Join Date: Aug 2003
Posts: 6,023
Default

Quote:
quote:Originally posted by RallyDRock

only ps/ac.
alt is on its own belt
w/p is cam driven
My BAD!!![xx(] I thought all were driven by the serpantine belt.[:I]
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Power steering issues matt87951 Tech & Performance Forum 18 24 Apr 2009 07:10 am
Power steering whine problem identified sawdust123 General Turbo Discussions 5 10 Dec 2008 07:24 pm
Yet another Power Steering problem fritz_t_coyote Tech & Performance Forum 3 23 Nov 2005 04:28 pm
ATF + 4 or 5 for power steering? quicksilverdon General PT Cruiser Discussions 2 21 Feb 2005 05:00 pm
Power steering leak . . . gonzowing Tech & Performance Forum 5 15 Apr 2004 10:28 pm


All times are GMT -5. The time now is 04:06 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors