PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Just changed plugs and wire...quick question...

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 10 May 2005, 02:04 pm
Young Cruiser
 
Join Date: Mar 2004
Location: .
Posts: 61
Default Just changed plugs and wire...quick question...

Hi.

I just put champion double platinums and crane 8.5mm FireWires on my Cruiser. I have a quick question (that's a concern but hopefully unwarranted)....

I diconnected the negative battery terminal, did everything else according to the book.

When I start the car it idles nice and smoothly. Driving.. no misses, great acceleration, no spits, sputters or misses.. Here's my question/concern..

When I'm in Park/Neutral and idling, when I slowly rev the engine it's nice and smooth, no misses, etc. When I get to around 4 grand on the tach, it drops off then revs up then drops off... sort of like the engine is cutting back the gas or something to stop over-revving when not moving... Is this normal? Never noticed before as I've never revved standing still. I hope it is that I didn't screw something up (initial torque wrench wasn't good so got a new one, but noticed immediately).

Thanks for the input and hopefully getting rid of my paranoia....
Reply With Quote
  #2 (permalink)  
Old 10 May 2005, 02:10 pm
Cool Cruiser
 
Join Date: Oct 2004
Location: El Cajon, CA, USA.
Posts: 485
Default

They have a rev limiter. It's normal.
__________________

2004 Dark Plum Base with windows tinted, cabin filter, silencers removed, fog lights, 18\'s, all Red taillights, Blaine\'s struts, modesty cover, color-matched center dash, 06 rear bumper
Reply With Quote
  #3 (permalink)  
Old 10 May 2005, 02:41 pm
Young Cruiser
 
Join Date: Mar 2004
Location: .
Posts: 61
Default

Thanks... now I can breathe easier...
Reply With Quote
  #4 (permalink)  
Old 10 May 2005, 04:10 pm
Fanatic Cruiser
 
Join Date: Jul 2002
Location: Secane, PA, USA.
Posts: 530
Default

It's normal so you don't blow the engine when there is no load on it.
__________________
John & Terry
"His" - 2002 Inferno Red Touring Edition
"Hers" - 2003 Electric Blue Limited Edition
Del Val PT Cruisers
Reply With Quote
  #5 (permalink)  
Old 10 May 2005, 04:34 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,750
Default

Don't mind sharing that it scared the heck out of me the first time I hit that limiter...thought I'd broke the darn thing. [:I]
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #6 (permalink)  
Old 10 May 2005, 04:34 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default

Quote:
quote:Originally posted by tpscruiser

It's normal so you don't blow the engine when there is no load on it.
Correct. Should be okay past 4,000 rpm when driven.[|)]
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
spark plugs ote69 Turbo Performance 28 11 Jul 2010 09:59 am
Stage 1 Plugs & Wire Upgrade mervay Stage Turbo Kits 20 13 Dec 2005 03:51 pm
3/25/05 UPDATE - DONE! - New Plugs and Wires NGK BumperBob Tech & Performance Forum 14 31 Mar 2005 01:06 am


All times are GMT -5. The time now is 10:41 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors