PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Acceleration problems

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 26 May 2005, 04:04 pm
Fresh Cruiser
 
Join Date: May 2005
Location: .
Posts: 3
Default Acceleration problems

Ok, so I've got my panic button worked out, here's another question.

Lately I've noticed the pickup on my car is really diminishing, to the point where moderate hills are tough to accelerate on. It's been a noticeable drop for the past 2-3 months. The car has 49k miles on it, is not the Turbo (obviously). I've had regular oil changes since I bought it 8k miles ago, but haven't had the 45k transmission service. It idles a bit strong and there's a faint gas/coolant/something smell sometimes when I open the door after parking. It had a boilover right after I bought it, fixed when they replaced the thermometer, and hasn't had any problems since.

Thanks again!
Reply With Quote
  #2 (permalink)  
Old 26 May 2005, 04:33 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,750
Default

Do you know if the plugs and wires have ever been replaced? They are weak points and many problems can be cured by changing them both. Also make sure you don't have a blockage somewhere either in the intake or exhaust system.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #3 (permalink)  
Old 27 May 2005, 09:19 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default

Agree (as usual) with Crewzin.
Get Crane wires (RaceAndStreet.com) and Champion Platinum plugs (NAPA has them) and gap at 0.045. If you don't know whether they've been changed, do it - can't hurt, and not a huge investment. Stock wires are crap.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
steering problems: 2005 convertible bobsackaminnow PT Cruiser Convertible Forum 0 13 Sep 2006 06:56 pm
Parking Brake Light upon Acceleration JohnM Tech & Performance Forum 5 27 Jan 2006 09:07 am
So much problems before inspection Ctown General PT Cruiser Discussions 3 12 Apr 2005 07:45 pm
Major Turbo problems Iris Turbo Performance 7 04 May 2004 07:06 pm
Problems Oddcouple General PT Cruiser Discussions 1 17 Nov 2002 01:58 pm


All times are GMT -5. The time now is 09:34 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors