PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > 2.4L Turbo Forums > Turbo Performance

PT Cruiser Forum

Advertisements
battery

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 21 Jul 2005, 02:55 am
Young Cruiser
 
Join Date: May 2003
Location: .
Posts: 84
Default battery

Now that my spark plug wires and spark plugs are on their way, I was wondering after the install do i have to disconnect the battery terminals so the computer resets itself? Or will I be good to go without messin with the battery? If I do have to disconnect the terminals, how often do I have to do this? Or is it a one time thing? Thanks in advance.
Reply With Quote
  #2 (permalink)  
Old 21 Jul 2005, 03:10 am
Veteran Cruiser
 
Join Date: Mar 2003
Location: Oregon.
Posts: 3,521
Default

I reset mine anytime I do a new engine mod. Take the negative cable off for a few minutes.
__________________
\'05 Stone White SRT4

\'04 Graphite PT Automatic
Reply With Quote
  #3 (permalink)  
Old 21 Jul 2005, 07:18 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default

Don't think it's needed for plugs and wires, but it's like chicken soup - can't hurt...
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Optima Battery Gear_Head General Turbo Discussions 13 08 Feb 2017 12:57 pm
PT Crusier battery dies after 5 days of no use. PT OWNER General Turbo Discussions 22 28 Jan 2009 11:51 am
battery access Hud Wilson Northwest PT Forum 1 25 Feb 2006 09:17 pm
Battery Corrosion SteelBlueGT General Turbo Discussions 9 19 May 2005 06:47 pm
Volume reduced when battery disconnected tom-t-rifik Sound and Security Forum 0 28 Jun 2004 05:25 pm


All times are GMT -5. The time now is 10:38 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors