PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > 2.4L Turbo Forums > Turbo Performance

PT Cruiser Forum

Advertisements
PO121 fault code

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 13 Feb 2006, 10:30 pm
Fresh Cruiser
 
Join Date: Feb 2006
Location: Long Branch, N.J, USA.
Posts: 3
Default PO121 fault code

a couple weeks after installing my AGP wastegate actuator, while driving on the highway sometimes the check engine light comes on and the code PO121 comes up.Throttle position sensor and MAP sensor disagree with each other. Once this happens the car idles at like 3000 rpm's and does not want to idle down when slowing down. After turing the car off and restarting it, it would be perfectly fine. If anybody has any input on what could be causing this, it would be greatly appreciated. I already relpaced the map sensor and the tps and it did nothing.
Reply With Quote
  #2 (permalink)  
Old 14 Feb 2006, 12:02 am
Obsessed Cruiser
 
Join Date: Dec 2002
Posts: 6,787
Default

is there an idle sensor ?? i had a car 86 duster at least i think it was an 86 ?? well anyway, the idle sensor went three times on that car, but it did the same thing your car is doing let us know what you find out good luck !!
Reply With Quote
  #3 (permalink)  
Old 14 Feb 2006, 11:16 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default

P0121 Throttle/Petal Position Sensor/Switch A Circuit Range/Performance Problem

Strange that it clears with a restart....[:I]
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #4 (permalink)  
Old 14 Feb 2006, 12:14 pm
Fresh Cruiser
 
Join Date: Feb 2006
Location: .
Posts: 47
Default

P0121 is throttle position sensor #1 performance . Could be the sensor, power, or pcm. Leave the code and get car to dealer to diagnose ..... there are 3 pages of diags and you need DRBIII to perform most of them.
__________________
2004 PT GT -Stage 1, K&N Drop-In, Airbox Mods, \'05 Composite Manifold, AMX TTAB, NGK V-Powers at .040, Magnecore KV-85\'s, Mopar BOV, BTG Strut Bar, Mopar Rear Sway, Drilled/Slotted rotors, Hawk HPS Brake Pads, a few visual Mods, a coupla Road Runners, and a Partridge in a Pear tree......
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mopar radio security code. Ian-PT-GT Sound and Security Forum 15 15 May 2016 08:40 pm
P0440 fault resets and comes backin PT cruiser2003 sonny General Turbo Discussions 8 09 Jan 2014 08:34 am
Need diag. code info RIvey Tech & Performance Forum 1 01 Oct 2005 12:05 pm
Fault code RossiePT General Turbo Discussions 8 28 Mar 2004 10:52 pm
P 2302 Fault Code unable to find Turbo Red General PT Cruiser Discussions 2 08 Feb 2004 12:37 am


All times are GMT -5. The time now is 07:28 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors