PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > 2.4L Turbo Forums > Turbo Performance

PT Cruiser Forum

Advertisements
Massive stall/delay/cutout w/ 2003 Turbo...HEEELP!

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 15 Mar 2006, 03:06 pm
Regular Cruiser
 
Join Date: May 2003
Location: .
Posts: 102
Default Massive stall/delay/cutout w/ 2003 Turbo...HEEELP!

Idle:
RMMMMMMMM*CUTOUT*MMMMMMMMMMMMMMMMMMMMMMMMMMMM
MMMMMMMMMMMMMMM*CUTOUT*MMMMMMMMMMMMMMMMMMMMM
Never quits, just entirely drops out

Partial throttle:
Hesitation, and the exhaust 'fart'

Full throttle:
Hesitation throughout the range until about 5k where it evens out.

What is on the PT:

2003 PT Dream Cruiser (Turbo)
Stage 1
Straigh thru muffler
19,000 miles
Plugs installed 3k ago

This is really bugging me [xx(] - I'd like to hear what this may be before the trip to the dealer. Still under warranty until May.

Help?!
Reply With Quote
  #2 (permalink)  
Old 15 Mar 2006, 04:29 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default

Craig,

Don't have a Turbo, but reading your list, I don't see anything about new plug WIRES. That's a weak link in the ignition system. If you haven't put new wires on, Do it! It might be an easy way of fixing your problem.

If your wondering which wires to use...there's an on-going thread under Tech & Performance...

http://www.ptcruiserlinks.com/forum/...TOPIC_ID=14434
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #3 (permalink)  
Old 15 Mar 2006, 05:00 pm
Regular Cruiser
 
Join Date: May 2003
Location: .
Posts: 102
Default

I'll bet it is! Just bought some Magnecors off EBay..........

THANKS!
__________________
\'03 Tangerine Dream Cruiser - Chrome Beltline kit, AMP Billet fuel door, chrome grill kit, H&R Sportline lowering springs, PT-Tuning straight thru exhaust, Hallman boost controller & stage one with Mopar blow off valve kit - 240 hp+
Reply With Quote
  #4 (permalink)  
Old 24 Mar 2006, 01:44 pm
Young Cruiser
 
Join Date: Feb 2003
Location: San Diego, CA, USA.
Posts: 84
Default

I have the same model and had the same problem until I had the plug wires switched, I used the live wires from Moss Motors.
__________________
Reply With Quote
  #5 (permalink)  
Old 28 Mar 2006, 12:16 am
Dedicated Cruiser
 
Join Date: Jan 2003
Location: Washington State, USA.
Posts: 2,525
Default

While I never experienced the above-mentioned problem on my GT Stage 1 turbo car, I replaced the stock wires with Magnecores and new spark plugs at 15K miles -- no regrets at all -- just top performance. [8)]
Reply With Quote
  #6 (permalink)  
Old 28 Mar 2006, 06:51 pm
Obsessed Cruiser
 
Join Date: Dec 2002
Posts: 6,787
Default

het craig, did you change the wires ?? just curious if you got the problem fixed ??
Reply With Quote
  #7 (permalink)  
Old 28 Mar 2006, 10:21 pm
Cool Cruiser
 
Join Date: Sep 2004
Location: .
Posts: 271
Default

I had the same problem with my 03 GT turbo. The pcm was replaced by the dealer, but the miss was still there. I replaced the OEM plug wires with Bosch Premium wires guarenteed for life and changed from stock plugs to single platinium champions. Later when the Iridium NGK's were available I went with heat range 6, which seemed perfect. The OEM Champion plugs I removed had missing ceramic around the electrode which was causing the miss or drop out. I have had the NGK Iridiums for nearly 20k miles and still she has a smooth idle.You may have a combination of problems, the PCM, plug wires and good plugs.I also saw the Champion plugs were leaking that was exibited by the carbon tracing from the metal body up vertically over the ceramic insulator. Both the OEM and single platinum plugs showed this characteristic, I will only use NGK (LZTR6AIX-13) gapped at .045 which never showed any sign of leakage. The use of the std Champion OEM plugs in the turbo can cause engine damage as the ceramic breaks away and falls into the engine and does nasty things before it passes the exhaust valve and goes thru the turbo.
Reply With Quote
  #8 (permalink)  
Old 31 Mar 2006, 12:19 pm
Fresh Cruiser
 
Join Date: Mar 2003
Location: Knoxville, TN, USA.
Posts: 44
Default

I've had similar idle dropout problems on my '03 GT and my radio would also go on and off corresponding to the dropout (and also, my trip odo would reset).

When I wiggle the connection on my positive battery terminal, it completely stops the idle and radio dropout. So, apparently it's not making a great connection. When I drive, it loosens up again, so I have to wiggle it from time to time (I have one of those "quick disconnect" terminals so it will help clear my Prototype Power upper CAI pipe) and I need to do something different there, obviously.

Now, if only that would fix my flickering interior lights/dimming headlights!! (But it doesn't...)
__________________
JC Moore, \'03 Cranberry GT, a.k.a. \"Zippy\"
http://www.mooresmopars.com/GT-Cruiser/index-gt.html
Stage1, BTG Strut Bar, Sun Hyperground system, Prototype Power CAI, no silencers, Eibach ProKit, Borla 2.5\" SSTL single w/dual tip, APC 2G Carbon Fiber Taillights, Chrome Fuel door, \'02 foldaway heated mirrors, OEM-style rear spoiler, Progress 22mm rear sway bar, TYC backup lights, Magnecor 8.5mm, stock plugs, MB Design \"Shifter\" 17x7.5 wheels, Goodyear Eagle F1 GS-D3 235/45/ZR17 tires
Reply With Quote
  #9 (permalink)  
Old 10 Apr 2006, 03:28 am
Fanatic Cruiser
 
Join Date: May 2003
Location: Rhode Island.
Posts: 950
Default

Regap your plugs. The was a TSB about gaps.
__________________

2003 GT Inferno Red,5-spd,Eibach Springs,Koni Sport Adjustables, Eibach front and rear Sway Bars, Mopar Stage 1,Mopar BOV,Custom 2.5\" Dual Tip Exhaust (Magnaflow),Hurst Short Throw Shifter, Pioneer DEH6500 Headunit, RF Punch 300 and 301 Amps,RF 12\" Sub and MB Quart Reference and Premium Speakers,Ronal RT 17x7.5\'s with Michelin Pilot Sport 225/45ZR17s, Koni Adjustible shocks, Keystone single scoop, GT Airraid Intake, Mopar Ground Effects
Homepage:
http://www.cardomain.com/id/ptgtredman

http://blueman.ptenthusiasts.net/index.html
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2003 PT Turbo - Heavily Modified - Check it out..! GT2nr Classifieds: For Sale/Trade 5 02 Dec 2005 12:46 am
2003 PT Cruiser Turbo ESP101 Classifieds: For Sale/Trade 3 20 Jun 2005 02:11 pm
2003 TURBO UP, COLD AIR INTAKE amx1397 Vendors & Buyers Forum 1 18 Nov 2003 05:39 am
2003 PT Turbo Review by AUTOTEST FILE Gary04GT General Turbo Discussions 2 12 Jul 2003 09:14 am
Chrysler to Offer New Cheaper GT Turbo skylight PT Cruiser News and Rumors 19 12 Jun 2003 02:04 pm


All times are GMT -5. The time now is 09:18 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors