PT Cruiser Forum  
       

Go Back   PT Cruiser Forum > 2.4L Turbo Forums > Turbo Performance

PT Cruiser Forum

P0344 codes keep coming up

 
Like Tree1Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 26 Aug 2008, 02:51 pm
Regular Cruiser
 
Join Date: Jan 2005
Location: .
Posts: 125
Default P0344 codes keep coming up

I mentioned this in another thread but thought that a new thread may be in order now that a solution may be at hand.

Here is a rundown of my issues.

Several weeks ago the MIL comes on (in the 2003 GT) with two codes coming up (Cam and Crank sensors). Car runs but with less power and occasional misfiring. Both position sensors were replaced.

A few weeks later just the p0344 code comes up. Mechanic can't find anything, resets the computer. I drive ~1000 more miles with no problem. Pulling out of the driveway on Saturday the MIL comes on again with p0344 code. I delete the code and drive about 200 more miles with no problem. Yesterday the code comes on again. I try reseting it one more time but this only lasts about a quarter mile. Goody! My intermittent problem may no longer intermittent. Maybe we can fix this sucker once and for all.

My mechanic has been pouring over the wiring for several hours since yesterday. Now he seem pretty sure the problem is actually in the MAP sensor. Apparently a short in that sensor will cause other sensors to give bogus readings. I haven't seen diagnosis before but he seems fairly confident in it. I am certainly looking forward to having a working vehicle agian.

BTW, I picked up the Can-Tech OBD reader/EOBD scanner tool from Harbor Freight (item 98614). What a great tool! It doesn't just give you the codes, it explains what they mean. It also gives you great prompts. For instance, the first time I used it, I accidently turned the key in accessory mode, not ignition mode. After a few seconds, it told me to verify the key position. It is so refreshing to find a device with a friendly UI.
__________________
\'03 GT - No mods
\'05 Convertible Touring Ed. - No mods
Reply With Quote
  #2 (permalink)  
Old 01 Sep 2008, 09:13 pm
Regular Cruiser
 
Join Date: Jan 2005
Location: .
Posts: 125
Default Re: P0344 codes keep coming up

My mechanic was wrong. The only thing left I can think of is the engine computer or maybe they installed a bad camshaft sensor.
__________________
\'03 GT - No mods
\'05 Convertible Touring Ed. - No mods
Reply With Quote
  #3 (permalink)  
Old 03 Sep 2008, 03:55 pm
Regular Cruiser
 
Join Date: Jan 2005
Location: .
Posts: 125
Default Re: P0344 codes keep coming up

Well, there is a TSB about false error codes and the solution is to reflash the engine computer. However, I already had the latest s/w on my computer and I still have the problem. My next step is to bypass the wiring harness.
__________________
\'03 GT - No mods
\'05 Convertible Touring Ed. - No mods
Reply With Quote
  #4 (permalink)  
Old 03 Sep 2008, 07:02 pm
Hooligan's Avatar
Obsessed Cruiser
 
Join Date: Aug 2003
Posts: 6,028
Default Re: P0344 codes keep coming up

Here I thought you had a "Eureka" moment, thanks for the info tho, good luck.
__________________

2008 Silver Steel Metallic, Touring, NA, Sirius; Chromed door handles; lower grille; fog light surrounds; chrome front & rear bumpers strips; Airaid air filter; Bassani duals; Modesty Cover; Autolite AP5263 Platinum Plugs (.040); Crane Plug Wires; NAPA Ceramic pads; Blane hood struts; PTeazer Gas, Brake & Foot Rest Pedals, '05 Rear Step Pad, Stainless Door Sills, Llumar tint, "A" Piller chrome; APC Strut Bar
Reply With Quote
  #5 (permalink)  
Old 01 Nov 2008, 01:04 pm
Fresh Cruiser
 
Join Date: Nov 2008
Posts: 1
Default Re: P0344 codes keep coming up

Any update? Did you ever track down the cause of the P0344 code?
Reply With Quote
  #6 (permalink)  
Old 27 Nov 2008, 10:26 pm
Regular Cruiser
 
Join Date: Jan 2005
Location: .
Posts: 125
Default Re: P0344 codes keep coming up

Well, it is finally fixed.

The scanner helped me narrow down exactly how to duplicate the problem. All I had to do was rev the engine north of 2000 before the car had reached operating temperature. To avoid the MIL coming on, I would just wait till the car had warmed up before driving. It brought back fond memories of the carburated cars of old that didn't need no computer with fancy sensors.

As it got colder the problem got worse. I went out of town for 4 days and left the car with the dealer with instructions on how to duplicate the problem. After 8 days the dealer had run out of things to do. They had checked the harness, check the sensors, substituted the computer, etc. Nothing worked. Out of desperation they tried another camshaft sensor. That worked!

The thing is the sensor tested OK. Also, why was the problem temperature dependent? I may never know.
__________________
\'03 GT - No mods
\'05 Convertible Touring Ed. - No mods
Reply With Quote
  #7 (permalink)  
Old 22 May 2011, 04:17 pm
Fresh Cruiser
 
Join Date: May 2011
Posts: 1
Default Re: P0344 codes keep coming up

I had this exact same issue and installed the NAPA part for it. it still threw the code evenn after resetting the ecu. Purchased the mopar part from the dealer and issue was resolved. Its been in 2 days and no issues.

FYI use dodge parts for this sensor if you want it fixed. Just dont let them put it in. It is 2 8mm bolts and very easy to access.

Reset of ecu, swapping the sensor and test drive took total of 30 min.

Thx for the help PT Forum members.
Reply With Quote
  #8 (permalink)  
Old 22 May 2011, 04:25 pm
CREWZIN's Avatar
Obsessed Cruiser
 
Join Date: Sep 2001
Location: West Central Florida
Posts: 24,117
Default Re: P0344 codes keep coming up

If you look at ANY of the fixes the people on this forum recommend, using original Chrysler/MOPAR sensors is always mentioned. Too many times people have come to the forum and replaced aftermarket sensors that didn't work or worked for just a short time and replacing them with OEM solved the problem. Cost a bit more but always worth it.
__________________
......
...just CREWZIN along! . . . PT Cruiser Links Moderator
2000 PT. Original Owner, 118,000 miles
MY technical suggestions are given in GOOD FAITH without total guarantee, if in doubt go to a garage.
Visit My Home Page www.CREWZIN.com
Reply With Quote
  #9 (permalink)  
Old 22 May 2011, 09:19 pm
WolfmanG's Avatar
Veteran Cruiser
 
Join Date: Nov 2010
Location: San Antonio
Posts: 4,507
Send a message via Yahoo to WolfmanG
Default Re: P0344 codes keep coming up

Quote:
Originally Posted by CREWZIN View Post
If you look at ANY of the fixes the people on this forum recommend, using original Chrysler/MOPAR sensors is always mentioned. Too many times people have come to the forum and replaced aftermarket sensors that didn't work or worked for just a short time and replacing them with OEM solved the problem. Cost a bit more but always worth it.
i concur, i had the same prob, then i switched it with a mopar part and wa la, prob never came back.
__________________
-Danny Wolfman G
http://www.facebook.com/WolfmanG
Reply With Quote
  #10 (permalink)  
Old 24 Nov 2012, 11:17 pm
Fresh Cruiser
 
Join Date: Nov 2012
Posts: 1
Smile Re: P0344 codes keep coming up

Hi All , thanks for the tread , helped solve my problem .

I had the same error code coming up .

I thought I would start by unplugging the cable to the camshaft sensor to give it a clean . On doing so I discovered that the cable had been resting against the engine and melted the insulation . One of the wires had been shorting on the engine .

A bit of electrical tape , a cable tie and problem solved .

I hope this helps someone out there .

Photo161.jpg
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error Codes skylight Tech & Performance Forum 7 28 Apr 2011 03:34 pm
Check engine light, ever hear of these codes? MINIHEMI46 Turbo Performance 15 09 Mar 2010 07:58 pm
2003 Error codes Reed Tech & Performance Forum 4 15 Aug 2007 08:12 am
Error Codes thegoldpt Turbo Performance 6 07 Apr 2007 02:26 pm
Fluid coming out of exhaust... crazie.eddie General PT Cruiser Discussions 10 11 Nov 2004 03:21 pm


All times are GMT -5. The time now is 10:16 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors