PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > 2.4L Turbo Forums > Turbo Performance

PT Cruiser Forum

Advertisements
high RPM on start

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 26 Mar 2010, 10:40 pm
Fresh Cruiser
 
Join Date: Feb 2010
Posts: 32
Default high RPM on start

Hello again, anybody know why the engine would start with a short run up in RPM and then drop down to normal idle?
Reply With Quote
  #2 (permalink)  
Old 27 Mar 2010, 10:30 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: high RPM on start

Are you putting your foot on the gas pedal? DON'T. Just turn the key.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #3 (permalink)  
Old 27 Mar 2010, 10:34 am
Fresh Cruiser
 
Join Date: Feb 2010
Posts: 32
Default Re: high RPM on start

No, no foot...just a quick vroooom then normal.
Reply With Quote
  #4 (permalink)  
Old 27 Mar 2010, 04:56 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: high RPM on start

You could have a dirty or malfunctioning IAC (Idle Air Controller). Located in back of and attached to the throttle body.

Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
car didn't start in the cold, got jumped then was a bubbling sound and won't start Saqqara Tech & Performance Forum 1 15 Dec 2009 06:35 am
High mileage buy? oddnumber General PT Cruiser Discussions 10 08 Jan 2009 11:01 am
New problem, high rpm, HELP milPT Tech & Performance Forum 12 16 Feb 2005 10:41 am
high rpm miss gone tthrift Turbo Performance 8 06 Oct 2003 07:39 pm
High RPM miss Lee01 Turbo Performance 23 30 Jun 2003 08:25 pm


All times are GMT -5. The time now is 06:32 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors