PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > 2.4L Turbo Forums > Turbo Performance

PT Cruiser Forum

Advertisements
Slave cylinder connection

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 23 Aug 2011, 08:40 pm
Fresh Cruiser
 
Join Date: Mar 2010
Posts: 14
Default Slave cylinder connection

Hello all, my wife had a 2005 dream cruiser series 4 it has the 2.4L turbo with the 5 speed. The clutch went out on about 2 weeks ago and I have been working on it when I can. I have the new set in and tranny back in place and was going to hook up the fluid line and noticed a big difference in the connection. Is there something I am missing or just not doing right? Attempts to find pictures or videos of an install from factory to aftermarket have failed. Please help me out I need to be done with this thing. Pictures will help greatly. Thanks all.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slave cylinder connection dckoone Tech & Performance Forum 4 26 Aug 2011 07:52 am
03 slave cylinder problem fuhr31 General Turbo Discussions 2 06 Dec 2010 07:40 pm
Clutch Master/Slave Cylinder Replacement 06Cruiser Tech & Performance Forum 1 25 Aug 2009 10:27 am
clutch and slave cylinder chops660 Tech & Performance Forum 2 21 Nov 2007 01:32 pm
I'm considering becoming a slave to a PT LovinPT General PT Cruiser Discussions 19 31 Jul 2003 11:15 pm


All times are GMT -5. The time now is 07:12 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors