PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > 2.4L Turbo Forums > Turbo Performance

PT Cruiser Forum

Advertisements
06 GT Idle Issues

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 05 Feb 2012, 09:19 pm
War_Eagle's Avatar
Cool Cruiser
 
Join Date: Nov 2007
Location: Blythe, Ga.
Posts: 287
Default 06 GT Idle Issues

I have been reading all of the idling problems other PT owners have but I haven't been able to run mine down. It's stumbling like a drunk at happy hour! I replaced the plugs Iridium (gap .40) new high performance wires, and cam idle sensor. I am wondering if it is something computer related? Not throwing any codes. Battery is new and clean terminals. Always running 93 octane. This is frustrating
__________________
2005 Silver GT, auto, black leather, HID Headlights, ST Front sway bar, 215 45/17 tires, dark tinted front windows, stock running gear, sickspeed black pearl shift knob.
Reply With Quote
  #2 (permalink)  
Old 06 Feb 2012, 11:00 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: 06 GT Idle Issues

Was your cam sensor Mopar? There are lots of posts about bad aftermarket cam sensors.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #3 (permalink)  
Old 06 Feb 2012, 07:32 pm
xwing777's Avatar
Senior Cruiser
 
Join Date: Jan 2009
Location: Taylorsville NC
Posts: 1,102
Default Re: 06 GT Idle Issues

Try using a good fuel injector cleaner (dont remember the brand i use but its in black bottle and $7-$8 usually)

Crappy fuel these days can gunk up injectors and can cause rough idle. Or depending on miles or how bad they are, you may need injectors cleaned and flow matched.
__________________
.
2004 Almond GT, autostick - Only car shows, some weekends but with Stage1!
2003 cranberry 5 speed GT - Fishing with a sleeper Stage3 setup!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Low idle stall issues. deb56 General PT Cruiser Discussions 13 15 Jan 2012 02:20 pm
What idle issues? mdfrodolives Tech & Performance Forum 0 31 Dec 2011 02:16 am
High Idle and Cooling issues shadowsnkx Tech & Performance Forum 0 06 Sep 2011 08:55 pm
05; air,idle and now overheat issues Treedweller General PT Cruiser Discussions 8 16 Jul 2011 03:50 pm
Idle Issues CoryMartelca Tech & Performance Forum 2 23 Oct 2007 07:04 am


All times are GMT -5. The time now is 08:30 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors