PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > 2.4L Turbo Forums > Turbo Performance

PT Cruiser Forum

Advertisements
ptgt only boosting 4psi

 
Like Tree1Likes
  • 1 Post By wwpptc

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 05 Dec 2013, 04:29 am
Fresh Cruiser
 
Join Date: Dec 2013
Posts: 4
Default ptgt only boosting 4psi

Hey guys,
Just got an 03 ptgt HO a couple months ago and just got around to putting in a boost guage. The turbo does spool and i can hear the blowoff when i let off the gas, but no matter what gear i am in (manual), the guage only shows a steady 4 psi. i definetly dont feel like i am pushing the 14 psi most people say they get on their gt. i havent yet done a tune up, waiting until next payday, but i dont think that would be the cause. I also live in Utah and so temps are cold and elevation is a bit high. while accelerating, the guage needle climbs very steady, not jumping or anything. no strange sounds or anything. i am also getting trouble codes P0441 and P0522. i have searched and will be replacing the oil sensor tomorrow, but will either of these codes be putting the car into a limp mode or anything?

thanks for all your help.
Reply With Quote
  #2 (permalink)  
Old 05 Dec 2013, 05:14 am
needmoretoys's Avatar
Fanatic Cruiser
 
Join Date: Jul 2012
Location: Rising Sun MD
Posts: 643
Default Re: ptgt only boosting 4psi

Have you done a boost leak test yet? May not be the problem but it's a start.
__________________
Lenny

FEBRUARY CRUISER OF THE MONTH
Reply With Quote
  #3 (permalink)  
Old 05 Dec 2013, 05:35 am
Fresh Cruiser
 
Join Date: Dec 2013
Posts: 4
Default Re: ptgt only boosting 4psi

not yet, was also my next step but i dont have the tools or cash right now :/
Reply With Quote
  #4 (permalink)  
Old 05 Dec 2013, 11:45 am
InfernoGT's Avatar
Fanatic Cruiser
 
Join Date: Mar 2013
Location: Elyria, Ohio
Posts: 541
Default Re: ptgt only boosting 4psi

Have you at least done a visual inspection of the hot and cold turbo tubes? Make sure they are on all the way and clamped tight. No money or tools required
__________________
2006 PTGT with 5spd. ~60k miles
Reply With Quote
  #5 (permalink)  
Old 05 Dec 2013, 01:50 pm
Fresh Cruiser
 
Join Date: Dec 2013
Posts: 4
Default Re: ptgt only boosting 4psi

so i guess its the wastegate control solenoid. i completely removed it from the car and it took off like a rocket! so thats how these cars should perform! lol. guess im off to find a new one. thanks guys

also dont know if its bad juju to post this link but here is how i came to that conclusion:
http://www.ptcrew.com/phpBB2/viewtopic.php?t=30345

Last edited by Ravens; 05 Dec 2013 at 01:59 pm.
Reply With Quote
  #6 (permalink)  
Old 05 Dec 2013, 08:26 pm
Banned
 
Join Date: May 2011
Location: Dallas Texas
Posts: 3,722
Default Re: ptgt only boosting 4psi

Yes it is bad juju, don't come back!



Quote:
Originally Posted by Ravens View Post
so i guess its the wastegate control solenoid. i completely removed it from the car and it took off like a rocket! so thats how these cars should perform! lol. guess im off to find a new one. thanks guys

also dont know if its bad juju to post this link but here is how i came to that conclusion:
PTCrew.com - Learn it or Burn it.
Reply With Quote
  #7 (permalink)  
Old 05 Dec 2013, 10:36 pm
Banned
 
Join Date: Sep 2009
Location: south of Tampa, Florida
Posts: 3,037
Default Re: ptgt only boosting 4psi

Quote:
Originally Posted by Ravens View Post
Hey guys,
Just got an 03 ptgt HO a couple months ago and just got around to putting in a boost guage. The turbo does spool and i can hear the blowoff when i let off the gas, but no matter what gear i am in (manual), the guage only shows a steady 4 psi. i definetly dont feel like i am pushing the 14 psi most people say they get on their gt. i havent yet done a tune up, waiting until next payday, but i dont think that would be the cause. I also live in Utah and so temps are cold and elevation is a bit high. while accelerating, the guage needle climbs very steady, not jumping or anything. no strange sounds or anything. i am also getting trouble codes P0441 and P0522. i have searched and will be replacing the oil sensor tomorrow, but will either of these codes be putting the car into a limp mode or anything?

thanks for all your help.
Quote:
Originally Posted by Ravens View Post
so i guess its the wastegate control solenoid. i completely removed it from the car and it took off like a rocket! so thats how these cars should perform! lol. guess im off to find a new one. thanks guys

also dont know if its bad juju to post this link but here is how i came to that conclusion:
PTCrew.com - Learn it or Burn it.

The 522 is only one of the codes that could possably trigger the pcm to cut back the boost, fuel and timing to protect the engine. It might be perceiving the 522 as either low, or absence of any, oil pressure. The route the PCM uses to control the boost is by controlling the wastegate solenoid to cut back on the wastegate boost signal, so this is entirely possable. If your PT was mine I would fix the oil sending unit first and see if that in turn, fixes your boost issue.

Of course you could have a faulty solenoid, but I would replace the sensor first since it needs to done anyway. Make sense?

Jerry
Busted_PT likes this.
Reply With Quote
  #8 (permalink)  
Old 05 Dec 2013, 11:00 pm
Fresh Cruiser
 
Join Date: Dec 2013
Posts: 4
Default Re: ptgt only boosting 4psi

yeah, im definetly going to be replacing both after work tomorrow. ill let you know the outcome. thanks guys
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
boosting in 4th mattsptgt Tech & Performance Forum 1 13 Nov 2011 01:40 pm
over boosting mattsptgt General PT Cruiser Discussions 17 07 Jul 2011 05:52 pm
Boosting my Bad Ass PT RobertHD General Turbo Discussions 6 20 Apr 2010 07:22 pm
BOOSTING THE BATTERY ? JGN General PT Cruiser Discussions 2 16 Jul 2004 07:58 am
Peformance boosting ebartels Tech & Performance Forum 2 03 Dec 2001 12:58 pm


All times are GMT -5. The time now is 10:45 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors