PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > 2.4L Turbo Forums > Turbo Performance

PT Cruiser Forum

Advertisements
A little help here..what would cause this?

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 10 Apr 2014, 04:21 pm
muzicmax's Avatar
Cool Cruiser
 
Join Date: Mar 2008
Location: Great White North
Posts: 309
Default A little help here..what would cause this?

Hey guys/girls I am experiencing something weird?
I have a 2003 GT and I drove my car as usual today went about 9-10 miles picked some stuff up drove down the hi-way then needed gas and filled up with the 91 octane and got a car wash drove away running fine down the hi-way dropped a buddy off at home turned car off helped him carry some stuff in maybe 10 minutes max. Left his house running good down the hi-way for about 15 minutes again Drove down the highway heading home. came to a red light and car felt like it was going to stall almost like it was choking out. Noticed funny gassy smell but not really bad ...light turned green started to go and there was not a lot of power but noticed a weird sound like a siren almost when I stepped on it a little. Turbo sounded ok with the blow off. Never really punched it cause who knows just in case. Just barley made it home and when I slowed down to go into the drive way it died. Left it for about 5 mins and started it again. Started ok so stepped on it again and that whine siren sound was there, took foot off gas and less then a minute it died like chocking out no gas feel. I can't tell where that sound is coming from so I am going to wait until my friend can come help me and I can listen.
Just thought maybe someone experienced the same problem??
__________________
Reply With Quote
  #2 (permalink)  
Old 10 Apr 2014, 05:04 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: A little help here..what would cause this?

Could it be belt squeal?
Maybe alternator bearing went and it's putting a load on the engine?
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #3 (permalink)  
Old 10 Apr 2014, 08:35 pm
muzicmax's Avatar
Cool Cruiser
 
Join Date: Mar 2008
Location: Great White North
Posts: 309
Default Re: A little help here..what would cause this?

I think you may be on to something there as It almost did the same thing and I just about changed everything and it turned out to be the battery and the symptoms sort of feel the same.
I 'll see if I can test it somehow I just can't remember how.
If I take the negative battery post off and it still runs then the alt should be good?
__________________
Reply With Quote
  #4 (permalink)  
Old 10 Apr 2014, 08:41 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: A little help here..what would cause this?

Not sure that is still true - used to be...
Safer bet is to find a place that tests battery and charging system for free - dunno who does that in Canada, in US, lots of places do - make a few calls.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #5 (permalink)  
Old 10 Apr 2014, 09:12 pm
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,883
Default Re: A little help here..what would cause this?

Quote:
Originally Posted by quicksilverdon View Post
Not sure that is still true - used to be...
Safer bet is to find a place that tests battery and charging system for free - dunno who does that in Canada, in US, lots of places do - make a few calls.
It's definitely not the case today. Go to an auto parts parts store and get a system check.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 09:48 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors