PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > 2.4L Turbo Forums > Turbo Performance

PT Cruiser Forum

Advertisements
Hesistation/Temporary power loss during acceleration

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 13 Aug 2014, 11:31 am
Fresh Cruiser
 
Join Date: Dec 2003
Location: .
Posts: 3
Default Hesistation/Temporary power loss during acceleration

Hi all. I have searched and searched and cannot find my specific problem on the forum. I have an '03 GT Stage 1. The last couple of days I have noticed that after I start the engine and put the car into drive it hesitates and almost dies. Also when I am accelerating the engine will hesistate around ~2000 RPMs and then pick back up power. I not getting any codes or CELs. What could it be??
__________________
\'03 Almond GT
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Loss of power slcpunk Tech & Performance Forum 9 15 Apr 2009 12:51 am
Power loss littleblueGT Turbo Performance 3 11 Apr 2006 11:45 pm
Power Loss LoboMXGT Turbo Performance 2 15 Aug 2005 04:00 pm
Power loss? turbomangt General Turbo Discussions 9 28 Jul 2005 12:55 am
Power loss Betsey General Turbo Discussions 5 10 Dec 2003 03:45 am


All times are GMT -5. The time now is 05:27 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors