PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > 2.4L Turbo Forums > Turbo Performance

PT Cruiser Forum

Advertisements
hit up the track yesterday!

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 24 Oct 2004, 01:26 pm
Fresh Cruiser
 
Join Date: Jun 2004
Location: Richmond Hill, ON, Canada.
Posts: 11
Default hit up the track yesterday!

I have a stock PT GT convertible, 5 speed and I went to the track for the first time yesterday to get some stock times on her.

One thing I learned is: Do not turn the traction off! When it was off I had literally no traction all the way through first gear and into second. Yayyy for crappy stock goodyears!

Anyway, my best slip of the day was:

Reaction .854 (ouch, hehe)
60 ft 2.367
1/8 ET 9.884
1/8 MPH 75.12
1/4 ET 15.105
MPH 93.75

Can't wait till I get some go fast mods on for next year

Reply With Quote
  #2 (permalink)  
Old 24 Oct 2004, 02:38 pm
Senior Cruiser
 
Join Date: Apr 2003
Location: Jacksonville, FL, USA.
Posts: 1,235
Send a message via AIM to sakigt
Default

Sweet. Youre right about the traction control. Until you get better tires it'll spin like crazy...but thats what the track is for...practice!
With my Toyo's when I had traction control ON, it spun like a mofo
Thats a great MPH for a stock PT
__________________

14.67 @ 94.5 <--- Self Proclaimed Fastest East Coast PT with Black wheels!!!
Reply With Quote
  #3 (permalink)  
Old 24 Oct 2004, 03:03 pm
Senior Cruiser
 
Join Date: Sep 2002
Location: Just south of the Mason/Dixon line
Posts: 1,713
Default

We found dropping the air pressure to around 20lbs, helped tons with the tire spin [8)]
__________________
.....................................
'03 GT base w/175k and a 2 speed autostick (read: trans is shot) and powered by a hybrid MOPAR S3 with DSP untuned
1st Forward Motion E1 powered PTGT w/Psi-Fi Power pack fuel tuner back in '07
FS: '03 GT Elec Blue w/rear suicide doors or '03 auto PCM, S3 turbofold, WGA, 3.5" o2 & 3" DP - make offer
Reply With Quote
  #4 (permalink)  
Old 24 Oct 2004, 10:19 pm
Fresh Cruiser
 
Join Date: Jun 2004
Location: Richmond Hill, ON, Canada.
Posts: 11
Default

I dropped the tire pressure to 25 but traction was still pretty bad. A guy that was with our group ran 15.102 at only 88.5 mph! If I had only had traction, I would have been in the 14s easy!
Reply With Quote
  #5 (permalink)  
Old 12 Nov 2004, 08:27 pm
Fresh Cruiser
 
Join Date: Oct 2004
Location: BENSALEM, PA, USA.
Posts: 16
Default

I ran the same time (14.5) with traction control and without traction control. You don't need it. I posted my times. Look for virgin track times.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
I saw a very interesting PT yesterday, please read frances General PT Cruiser Discussions 4 30 Jul 2004 03:59 pm
I raced an SRT-4 yesterday... BlueTurboGT General Turbo Discussions 5 26 Apr 2004 06:19 pm
Lots of Fun At the Track Last Night FRM3 General Turbo Discussions 9 16 Dec 2003 05:12 am
Going to the track today TripleJackInGA General Turbo Discussions 4 25 Oct 2003 09:09 pm
TRACK DAY IN ONTARIO Ptturbine Canada PT Forum 4 24 Sep 2003 07:42 am


All times are GMT -5. The time now is 12:14 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors