PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > 2.4L Turbo Forums > Turbo Wheels/Suspension/Handling

PT Cruiser Forum

Advertisements
Front End Noise on Bumps

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 21 Jul 2013, 11:17 pm
Fresh Cruiser
 
Join Date: Feb 2013
Location: Sachse, Tx
Posts: 18
Default Front End Noise on Bumps

I have an 02 with 85k miles.
She is really noisy over bumps coming from the front end. Not a grinding noise, but knocks. So, I figured i would start with the struts and might as well do the back shocks. Finished that, but the noise is still there. While tires were off, I looked at the bushings on the lower control arm. They look pretty crappy, and spent.

So.... Could this be the noise?

Thanks.
Reply With Quote
  #2 (permalink)  
Old 21 Jul 2013, 11:27 pm
randyincctx's Avatar
Veteran Cruiser
 
Join Date: Jun 2013
Location: Corpus Christi,Tx.
Posts: 3,489
Question Re: Front End Noise on Bumps

Aside from the bushings on your lower control arms(which based on your desription need replacing).....How do the sway bar & end link bushings look????
__________________
2003 PT Cruiser (Base-N/A) Patriot Blue Pearl Purchased @ Police Impound Auction for $1,000.
Aka:~KILLER~
Reply With Quote
  #3 (permalink)  
Old 22 Jul 2013, 07:29 am
Fresh Cruiser
 
Join Date: Feb 2013
Location: Sachse, Tx
Posts: 18
Default Re: Front End Noise on Bumps

They look ok. By the way, I also replaced the top and bottom engine mounts (though they are are not really mounts..... more like anti movement bars).
Reply With Quote
  #4 (permalink)  
Old 24 Jul 2013, 04:34 pm
Fresh Cruiser
 
Join Date: Feb 2013
Location: Sachse, Tx
Posts: 18
Default Re: Front End Noise on Bumps

I just ordered the sway bar and link bushings. I'm starting with those easier ones before the control arm. Hopefully, that fixes the noise.
Reply With Quote
  #5 (permalink)  
Old 24 Jul 2013, 06:03 pm
Fanatic Cruiser
 
Join Date: Sep 2012
Location: Carson City NV
Posts: 675
Default Re: Front End Noise on Bumps

Are the nuts on the end links on the sway bar bushings? Mine was clunking and when I checked things out the nuts on both sides for the front sway bar end links were gone!

I don't know if this is a normal Mopar thing but the front bushings our PT had a threaded insert inside of them! That means that when you take the nuts of the end links you can't slide the end link out!

You have to hold the top washer with vise grips and undo the bolt! Took me 30 minuets to figure that one out...I have never seen that done before? ( threaded end link bushings)
Reply With Quote
  #6 (permalink)  
Old 24 Jul 2013, 10:32 pm
Fresh Cruiser
 
Join Date: Feb 2013
Location: Sachse, Tx
Posts: 18
Default Re: Front End Noise on Bumps

Yes, mine has a nut on the bottom. The bushings don't look too bad on the end links, but since I'm there, I might as well to it. I'm mainly concerned about the two middle ones.

So, hopefully it will be fairly easy. Crossing fingers...
Attached Images
File Type: jpg Screenshot_2013-07-24-21-23-38.jpg (75.1 KB, 36 views)
Reply With Quote
  #7 (permalink)  
Old 25 Jul 2013, 01:39 am
Senior Cruiser
 
Join Date: Nov 2010
Location: oak creek, wi
Posts: 1,141
Default Re: Front End Noise on Bumps

i'll second the swaybar bushings. they may look ok but they could be hard as a rock.
__________________
2005 Toyota Camry LE (Wife's) Super White
2002 Automatic N/A (Mine) Inferno Red
Reply With Quote
  #8 (permalink)  
Old 25 Jul 2013, 07:16 am
Fresh Cruiser
 
Join Date: Feb 2013
Location: Sachse, Tx
Posts: 18
Default Re: Front End Noise on Bumps

Here is a pic of the sway bar bushings. They look hard as a rock.

But, I'm afraid the real issue are the bushings in the lower Control Arm. I attached a pic. You can see the separation! Yuck!

I'm not looking forward to replacing these, but I might as well do it all at the same time.
Attached Images
File Type: jpg PT_swaybar.jpg (80.6 KB, 32 views)
File Type: jpg PT_lower.jpg (76.4 KB, 33 views)
Reply With Quote
  #9 (permalink)  
Old 25 Jul 2013, 07:20 am
Fanatic Cruiser
 
Join Date: Sep 2012
Location: Carson City NV
Posts: 675
Default Re: Front End Noise on Bumps

Quote:
Originally Posted by jim572d View Post
Yes, mine has a nut on the bottom. The bushings don't look too bad on the end links, but since I'm there, I might as well to it. I'm mainly concerned about the two middle ones.

So, hopefully it will be fairly easy. Crossing fingers...
Is that what it m looks like stock? No nut on top? I thought the nuts had come off on mine, I installed nylocks on mine and the clunking went away?

When I installed the Eibach bar I discovered the OEM end link bushings are threaded so maybe they don 't need a nut? Werid...still I put nuts on it and the clunking went away? Don't know?
Reply With Quote
  #10 (permalink)  
Old 25 Jul 2013, 08:05 am
Fresh Cruiser
 
Join Date: Feb 2013
Location: Sachse, Tx
Posts: 18
Default Re: Front End Noise on Bumps

Even though the manual says to hold the upper "retainer/nut", none of the pics actually show that nut (that I'm used to seeing).

I've attached a better pic of mine, and pics of the service manual.

I believe the "retainer/nut" is thin like a washer, but it looks like it is 12 sided. This explains the "nut" part of the description.
Attached Images
File Type: jpg PT_swaybar_Link.jpg (89.1 KB, 30 views)
File Type: jpg PT_manual_1.jpg (93.4 KB, 25 views)
File Type: jpg PT_manual_2.jpg (91.0 KB, 23 views)
File Type: jpg PT_manual_3.jpg (87.6 KB, 21 views)
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Odd Front end noise. pluminator Wheels, Tires, Suspension 3 12 Dec 2012 03:30 pm
front end noise wcerqua General PT Cruiser Discussions 1 05 Jun 2012 09:23 pm
front end noise Luvour04ptgt Wheels, Tires, Suspension 2 29 Sep 2010 08:45 pm
FRONT END NOISE??? help mjb457 Tech & Performance Forum 3 13 Mar 2010 12:41 pm
My front end sqeaks when I go over bumps lilooetruiser Wheels, Tires, Suspension 2 02 Dec 2009 07:23 pm


All times are GMT -5. The time now is 08:45 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors