PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > PTCruiserLinks.com > Welcome New PT Cruiser Members

PT Cruiser Forum

Advertisements
Hello everyone, new owner 05 'vert with a shady past ;)

 
Like Tree6Likes

Reply
 
LinkBack Thread Tools Display Modes
  #11 (permalink)  
Old 13 May 2017, 08:57 pm
Azrak's Avatar
Fresh Cruiser
 
Join Date: Dec 2016
Location: Alabama
Posts: 8
Default Re: Hello everyone, new owner 05 'vert with a shady past ;)

Thanks guys for the warm welcome.

Here's the poor things basics:
2005 Chrysler PT Cruiser Touring Convertible 2-Door 2.4L GAS DOHC Turbo-lite @200k.

She just started overheating a couple of weeks ago.

Things done so far
1) New thermostat, radiator cap and temperature sensor.
2) Made sure air was properly bled out.
3) Observed fan function:
a) Engine cold running turn on AC: fan immediately comes on.
b) Engine cold running with AC off heat on: fan off and comes on when gauge reads halfway.
c) Engine warm running with AC off heat off: fan increases to higher speed as temps go above halfway.
4) Pressure tested with at 18 psi, system held with no pressure drop for over 10 min while inspecting for visible leaks.
5) Rented combustion tester: checked out negative with engine running cold, checked out negative with engine running warm.

Currently doing:
Added a bottle of Blue Devil cooling system flush and ran it for about a half hour and was going to run it a few days for a thorough cleaning.

Got a compression tester to positively rule out head gasket.
I put this on hold as I found number 2 and 3 plug tubes floating in oil.
Ordered valve cover gasket set, plugs and wires.

Noticed a small leak on ground just below radiator drain plug. It wasn't there before!
Upon inspection it appears to be coming from the radiator somewhere above the plug.
My guess is the flushing fluid knocked loose some trash was blocking the leak and acting as a valve so it didn't show under pressure test.
But under negative pressure (cool down) it was allowing air to get sucked into the system.
That's my theory.

New radiator ordered.

Well, that's where I'm at now waiting on parts to get any further.
VsandFords and Carnut like this.

Last edited by Azrak; 13 May 2017 at 10:21 pm.
Reply With Quote
  #12 (permalink)  
Old 14 May 2017, 06:02 pm
VsandFords's Avatar
Fanatic Cruiser
 
Join Date: Apr 2014
Location: Gladewater, Texas
Posts: 853
Default Re: Hello everyone, new owner 05 'vert with a shady past ;)

I think your on to something. Swap out the radiator and let us know the results.
__________________
Life is just a bowl of jello, full of fruits and nuts.

2001 LE, auto, billet grille, K&N filter and Hedman hedder. Why a header? Because it makes me happy!
Reply With Quote
  #13 (permalink)  
Old 19 May 2017, 04:43 pm
Azrak's Avatar
Fresh Cruiser
 
Join Date: Dec 2016
Location: Alabama
Posts: 8
Default Re: Hello everyone, new owner 05 'vert with a shady past ;)

Got the new radiator today, but waiting until I get the valve cover finished before I put it in.

Todays new problem.

Ordered a valve cover gasket but I messed up and got the wrong one.
My mistake not the sellers. I relied on ebay's compatability chart and didn't notice the note from the seller about it being for 8 bolt covers.

Before I screw-up and order another one wrong, I can't seem to find any with pictures that look like they would fit. See pics and please offer a suggestion please.

Here's what the top looks like. I'm going to paint it (except for the lettering).

This is the part number, I can't find it through searching.

This is the part I'm concerned about.
Reply With Quote
  #14 (permalink)  
Old 19 May 2017, 05:07 pm
rckstein's Avatar
Obsessed Cruiser
 
Join Date: Dec 2010
Location: Euless, TX
Posts: 9,006
Default Re: Hello everyone, new owner 05 'vert with a shady past ;)

Quote:
Originally Posted by Azrak View Post
Got the new radiator today, but waiting until I get the valve cover finished before I put it in.

Todays new problem.

Ordered a valve cover gasket but I messed up and got the wrong one.
My mistake not the sellers. I relied on ebay's compatability chart and didn't notice the note from the seller about it being for 8 bolt covers.

Before I screw-up and order another one wrong, I can't seem to find any with pictures that look like they would fit. See pics and please offer a suggestion please.

Here's what the top looks like. I'm going to paint it (except for the lettering).

This is the part number, I can't find it through searching.

This is the part I'm concerned about.
I've always had the best success searching for parts by first calling or stopping in my local dealership. Using the vehicle VIN, they can give you the correct and current MOPAR part number. Then search by that part number and you should find the correct part.
__________________

'06 Touring Edition NA Automatic
143K Miles / Electric Blue Pearl
USMC '83 - '93
Reply With Quote
  #15 (permalink)  
Old 20 May 2017, 01:18 pm
Azrak's Avatar
Fresh Cruiser
 
Join Date: Dec 2016
Location: Alabama
Posts: 8
Default Re: Hello everyone, new owner 05 'vert with a shady past ;)

Hi rckstein,

I did a search of the mopar sites that use a vin search feature. They gave me part# 4781639AB.

Well I did go to the local parts places (though I loath to do so as the general level of competence is pretty lacking).
Maybe the folks in your locale are more knowledgeable, hence my reason for asking here where the smart folks are.

Example: Autozone

Gave them my vehicle info. All they were concerned about with the VIN was the 8th digit which is 'E'.
They came up with four results. Two of which they had in stock and two that would have to be ordered.

After I returned home I went to their site to get these images.

Note the yellow highlight ^^^^

The employee brought out the two they had and I showed him the pictures I had taken.
Here's some of the comments made.

Part #1

Employee: "Well maybe when you push the gasket in the grooves it will round out in the corner enough?"
Me: "Uhm... I don't think so, wouldn't that just mean the gasket wasn't designed for my car and might leak?"

Part #2

Employee: "This one might work. The corner is round."
Me: "What about the indent where the bolt is?"
He proceeds to try to flex the gasket in that area.
Employee: "It looks like has enough give in it to go around there."
I pretty much repeat my comment made about the first one.

Part #3

Employee: "Well I can order you this one."
Me: "Does it look like it fits better?"
He squints at the screen for several minutes and asks another employee to look. They both shrug and turn the monitor toward me.
Me: "WTH is that piece of spaghetti?"
Employee: "Do you want me to order it for you?"
Me: "You said there were four what does the last one look like?"


Part #4

Employee: "Alright, this looks like it's the one you want"
He proudly turns the screen to me.
As I'm looking at it I notice a note about 8 bolt and ask about it.
More shrugs...
Employee: "Do you want me to order it for you?"
Me: "Well, can you look it up by the Mopar part number?"
Employee: "Sure, we can do that."
That just brings us back to part 4 again.
Employee: "Do you want me to order it for you?"
Me: "Thanks, but no, I get back with you if I decide to."

Well, I just ordered one from ebay that is supposed to be the oem mopar.
Guess I'll find out when it gets here.

Since I've been trying to fix this car up I've found many things are very specific and particular to the PT Cruisers that only someone with hands on experience can help with, but thanks for the reply.
Reply With Quote
  #16 (permalink)  
Old 20 May 2017, 01:27 pm
rckstein's Avatar
Obsessed Cruiser
 
Join Date: Dec 2010
Location: Euless, TX
Posts: 9,006
Default Re: Hello everyone, new owner 05 'vert with a shady past ;)

Quote:
Originally Posted by Azrak View Post
Hi rckstein,

I did a search of the mopar sites that use a vin search feature. They gave me part# 4781639AB.

Well I did go to the local parts places (though I loath to do so as the general level of competence is pretty lacking).
Maybe the folks in your locale are more knowledgeable, hence my reason for asking here where the smart folks are.

Example: Autozone

Gave them my vehicle info. All they were concerned about with the VIN was the 8th digit which is 'E'.
They came up with four results. Two of which they had in stock and two that would have to be ordered.

After I returned home I went to their site to get these images.

Note the yellow highlight ^^^^

The employee brought out the two they had and I showed him the pictures I had taken.
Here's some of the comments made.

Part #1

Employee: "Well maybe when you push the gasket in the grooves it will round out in the corner enough?"
Me: "Uhm... I don't think so, wouldn't that just mean the gasket wasn't designed for my car and might leak?"

Part #2

Employee: "This one might work. The corner is round."
Me: "What about the indent where the bolt is?"
He proceeds to try to flex the gasket in that area.
Employee: "It looks like has enough give in it to go around there."
I pretty much repeat my comment made about the first one.

Part #3

Employee: "Well I can order you this one."
Me: "Does it look like it fits better?"
He squints at the screen for several minutes and asks another employee to look. They both shrug and turn the monitor toward me.
Me: "WTH is that piece of spaghetti?"
Employee: "Do you want me to order it for you?"
Me: "You said there were four what does the last one look like?"


Part #4

Employee: "Alright, this looks like it's the one you want"
He proudly turns the screen to me.
As I'm looking at it I notice a note about 8 bolt and ask about it.
More shrugs...
Employee: "Do you want me to order it for you?"
Me: "Well, can you look it up by the Mopar part number?"
Employee: "Sure, we can do that."
That just brings us back to part 4 again.
Employee: "Do you want me to order it for you?"
Me: "Thanks, but no, I get back with you if I decide to."

Well, I just ordered one from ebay that is supposed to be the oem mopar.
Guess I'll find out when it gets here.

Since I've been trying to fix this car up I've found many things are very specific and particular to the PT Cruisers that only someone with hands on experience can help with, but thanks for the reply.
It's very hard to tell what a part will actually look like from just a drawing or sketch, even MOPAR pictures or drawings are lacking in any actual detail or true representative of what the part actually looks like. Some parts in my Gen2 Parts Manual are pics that they used of Gen1 items, they just never bothered to update the drawings.

About all you can do it hope for the best and keep trying if your parts place doesn't get it right the first time. Or contact an actual dealership and they will give you the correct part number for the item you are looking for, good luck.
__________________

'06 Touring Edition NA Automatic
143K Miles / Electric Blue Pearl
USMC '83 - '93
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
cant get past step one.... scroller Sound and Security Forum 7 22 Jul 2015 10:40 pm
Car past its MOT whiteclaw General PT Cruiser Discussions 11 21 Aug 2012 07:34 pm
New Vert Owner! fotoguy PT Cruiser Convertible Forum 8 09 Feb 2011 12:25 pm
New 2006 PT Cruiser GT Vert owner here...... PA_NC_Cruiser General PT Cruiser Discussions 11 06 Apr 2010 09:51 pm
Will not go past 40mph BWTL Tech & Performance Forum 3 17 Jul 2009 09:39 pm


All times are GMT -5. The time now is 03:37 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors