PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Wheels, Tires, Suspension

PT Cruiser Forum

Advertisements
Poping on left turn.

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 03 Jun 2006, 05:34 pm
Fresh Cruiser
 
Join Date: Oct 2005
Location: Jacksonville, FL, USA.
Posts: 43
Default Poping on left turn.

See other posts but didn't find the solution or problem. Have a popping noise on sharp left turnes or when I'm turning left and go over a bump or alot of gas turning left. Can feel it in the steering wheel and sounds like it's coming from the left side. Did take a look at the tie rod ends and they don't seem to be faulty but I've not dealt with these or this problem before. Anyone know what the problem is or might be.
Reply With Quote
  #2 (permalink)  
Old 04 Jun 2006, 03:01 am
Young Cruiser
 
Join Date: Mar 2005
Location: San Bernardino, Ca, USA.
Posts: 92
Send a message via AIM to TurboCruiser13
Default

My first response would be CV joints. Check the boots to see if there's any rips or tears or holes in them...if anything gets up in there it's pretty much over for your joints.
Reply With Quote
  #3 (permalink)  
Old 05 Jun 2006, 10:51 am
Young Cruiser
 
Join Date: May 2004
Location: SE Michigan.
Posts: 85
Default

Check your upper strut mounts first, but since the 'popping' only occurs on hard left turns (which significantly loads the RIGHT side suspension) have a look at the lower right control arm bushings as well. It's not uncommon to have the rearmost bushing fail to the point that you can readily see the rubber being squeezed from the joint.

Brian
__________________
\'03 5-speed S2 Dream Cruiser #1582 w/MP Stage 1 & BOV. Plastic Intake Manifold, rear Eibach springs and Supertrapp axle-back exhaust.
Crane 8.5mm FireWires & Champion Copper Plus plugs, K&N drop in filter. Chrome Plastic AMX TTAB pipe.
(Metro Detroit Area)
Reply With Quote
  #4 (permalink)  
Old 05 Jun 2006, 02:56 pm
Fresh Cruiser
 
Join Date: Oct 2005
Location: Jacksonville, FL, USA.
Posts: 43
Default

OK, it doesn't have to be at any speed just turn the wheel far enough and it'll pop, sometimes louder then others ofcourse. Now on the CV Joint? what other problems if failing will this cause or tell since it's been doing this for months now, I assume if this damages another part that part is going to be toast as well. I only know what I've changed or fixed when it comes to cars, lowering is all I've ever done in this area.
__________________
2003 Silver GT Auto Stick
MODS:dual ram-air hood, flames, carbon fiber interior kit,dvd nav tv tuner 7\"touchscreen, Fosgate 4 channel amp, 12\" dual subs with LED box, mb-quart modual speakers, windshild visor, leather racing seats, Goldline springs 3\"drop, Tokico shocks, BOV, C.F. tail lights, and more. Need to install xeon side skirts, rocker pod guages.
Reply With Quote
  #5 (permalink)  
Old 05 Jun 2006, 07:52 pm
Obsessed Cruiser
 
Join Date: Dec 2002
Posts: 6,787
Default

i would say cv joints, they always make noise when they are shot
Reply With Quote
  #6 (permalink)  
Old 29 Jun 2006, 10:25 pm
Fresh Cruiser
 
Join Date: Oct 2005
Location: Jacksonville, FL, USA.
Posts: 43
Default

Should I expect it to get worse with time. The loudness and feel three the s-wheel varies but shouldn't the popping start to multiply. I've delt with it for about 8k or more miles. Almost thought it was gone for a couple of days but wouldn't you know it would pop itself back when it pleases. Consistent that it does pop but sometimes louder than others and haven't narrowed down if angle, speed, or surface condition makes any difference.
__________________
2003 Silver GT Auto Stick
MODS:dual ram-air hood, flames, carbon fiber interior kit,dvd nav tv tuner 7\"touchscreen, Fosgate 4 channel amp, 12\" dual subs with LED box, mb-quart modual speakers, windshild visor, leather racing seats, Goldline springs 3\"drop, Tokico shocks, BOV, C.F. tail lights, and more. Need to install xeon side skirts, rocker pod guages.
Reply With Quote
  #7 (permalink)  
Old 05 Jul 2006, 09:11 am
Cool Cruiser
 
Join Date: Aug 2003
Location: Hampstead, NC.
Posts: 308
Default

You might want to have the Rack & Pinion checked out. Mine gave me a pop or clunk noise thay was faint at first but grew worse over time. It finally got to where it did not want to turn left when first starting out. Took it to a dealer (while on vacation in FL) and they replaced the rack. Cost a bit over 700 bucks but it cured the problem.
__________________
2008 Sunset Boulevard
Reply With Quote
  #8 (permalink)  
Old 07 Jul 2006, 05:40 am
thegoldpt's Avatar
Fanatic Cruiser
 
Join Date: Apr 2005
Location: Port Orchard, Washington
Posts: 771
Send a message via MSN to thegoldpt Send a message via Yahoo to thegoldpt
Default

Could it be your CV joints?
Reply With Quote
  #9 (permalink)  
Old 07 Jul 2006, 11:31 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default

I found this -
03-006-04 09/15/2004 Powertrain:Axle Assembly:Axle Shaft -
Front Hub/Half Shaft Click/Pop Sound.

But I don't have the text of the Tech Service bulletin...
Check that the rubber boots are okay on the driveshafts.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Noise in front when making left turn; not right Runkle Wheels, Tires, Suspension 2 12 Feb 2007 01:04 pm
Turn Signals Not Working Indynick General PT Cruiser Discussions 9 15 Sep 2004 02:25 pm
Turn signal & stop light gonzomania General PT Cruiser Discussions 12 25 Apr 2004 01:18 pm
Granada Hills, CA Christmas Parade -- Dec. 7th. Basset Hound Western PT Forum 0 02 Dec 2003 01:25 am
02 PT Drifts to the left. kdioquino Tech & Performance Forum 3 09 Apr 2003 11:59 am


All times are GMT -5. The time now is 01:10 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors