PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Wheels, Tires, Suspension

PT Cruiser Forum

Advertisements
05 Vert handling/noise problems

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 18 Mar 2010, 08:20 pm
Fresh Cruiser
 
Join Date: Mar 2010
Location: Minneapolis
Posts: 5
Default 05 Vert handling/noise problems

I have an 05 Turbo vert. I bought it last summer with 94,000 on it knowing it needed some suspension work. Just turned 100,000 miles. In the past 6 months I have replaced both lower ball joints, control arm bushings with energy suspension, sway bar links and bushings, both outer tie rod ends, all the struts and shocks with upper mounts, The ps upper motor mount, and 4 new goodyear eagles. The problem being is the car still has a terrible shudder when going over bumps. It also feels like it wants to wander on the freeway and pulls when accelerating. It also handles really funny, anything over 35 mph on a cloverleaf and it feels unsafe. The 07 sedan we have drives completely different. Any ideas? I'm at my wits end with it.
Reply With Quote
  #2 (permalink)  
Old 20 Mar 2010, 11:52 am
Fanatic Cruiser
 
Join Date: Mar 2010
Location: Billings, MT
Posts: 745
Default Re: 05 Vert handling/noise problems

What about springs? You could have a broken spring or spring seat. You're wandering could be an alignment issue. Did you get a 4-wheel alignment after all your suspension work?

Are you sure all your tires are balanced properly?

You listed everything you did to the front, did you replace everything in the rear suspension as well?
__________________
-Chris
2010 PT Cruiser Classic, Deep Water Blue
Reply With Quote
  #3 (permalink)  
Old 20 Mar 2010, 06:40 pm
Fresh Cruiser
 
Join Date: Mar 2010
Location: Minneapolis
Posts: 5
Default Re: 05 Vert handling/noise problems

Springs were fine when I put in new struts and it has new upper mounts also. I had a front alignment done only as none of the rear suspension was changed. I had them re balance and rotate the tires also. Everything in the rear is tight, so I just put new shocks in. I'm thinking it has to be something in the steering linkage or rack, when I hit a bump the wheel shakes and the car shudders. I was thinking rack, but the steering is tight no play. I'm going to check the rack mount bolts next and also the k frame for cracks or loose mounts.
Reply With Quote
  #4 (permalink)  
Old 21 Mar 2010, 09:23 am
Decsr's Avatar
Regular Cruiser
 
Join Date: Dec 2008
Location: Nashville Tennessee
Posts: 131
Default Re: 05 Vert handling/noise problems

Have you checked your wheel bearings?
__________________


This PT Convertible use to be my BABY it was a 2005 Base 5 speed, Black on black on black, Red rims with full moons hubcaps, Amber fog lights, 6 disc indash CD, Polk speakers, Suicide knob, Black 15" spring ant., Gauges in console, APC air filter system, Complete bullet/turbo exhaust system, Hurst Shifter. May its new owner enjoy it as much as we did. We do still have a 2007 Limiter PT in Cool Vanilla with no mods and two HHRs now.
Reply With Quote
  #5 (permalink)  
Old 21 Mar 2010, 09:34 pm
Fresh Cruiser
 
Join Date: Mar 2010
Location: Minneapolis
Posts: 5
Default Re: 05 Vert handling/noise problems

Has 2 new wheel bearings also, forgot to add that.

I changed the oil and tranny fluid today, so I gave it a thorough go through again. Nothing is loose or broken on the steering or suspension. I think I'll try a 4 wheel alignment next.

I disconnected the battery to change the prndl(nuetral safety/back up) switch in the tranny because I had no back up lights and now the windows and top don't operate. I read that it has to reset itself after being disconnected, so hopefully that works. But I still have no back up lights I checked all the fuses and bulbs before I did it, but it has to be a wiring problem somewhere now.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bad handling, need help. visual1 Turbo Wheels/Suspension/Handling 4 18 Dec 2008 07:49 pm
2006 GT Poor Handling jayguliano Turbo Wheels/Suspension/Handling 18 04 Feb 2007 03:21 am
Cargo Handling Question NewBluCruzr Turbo Wheels/Suspension/Handling 3 30 Jun 2004 02:12 am
What's the best mod to improve handling ? Wingdale Dave Turbo Wheels/Suspension/Handling 15 03 Jun 2004 11:03 pm


All times are GMT -5. The time now is 07:44 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors