PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Wheels, Tires, Suspension

PT Cruiser Forum

Advertisements
front end clunk at low speed

 
Like Tree4Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 24 Apr 2012, 03:41 pm
Fresh Cruiser
 
Join Date: Jul 2010
Location: Central Massachusetts
Posts: 17
Default front end clunk at low speed

Hi everybody - This is my first post here and I am STUMPED. I have an '08 Cruiser. I just replaced the control arms (Moog), both tie rod ends, installed 2 strut packs, both sway bar links and the other 2 sway bar bushings (24mm).
I then had 4 new Goodyears installed and an alignment. My problem is a clunking noise (not creaking) when I hit a bump at low speed. It feels as though it is coming through the floor. I am thinking of removing the sway bar to see if it goes away. What do you guys think? The stabilizer links are kind of funky, too. They have a spacer on them between the bushings. I can provide a pic, if you need one. Everything is tight and torqued to spec, the ball joints are greased, and the car doesn't make any noise if I put a bar under the tire and raise it or if I push down on it when the car is on the ground. BTW - The clunking was there before the alignment. Am I missing something?
Reply With Quote
  #2 (permalink)  
Old 24 Apr 2012, 03:53 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: front end clunk at low speed

You also have 9 other posts under the non-working washer so it isn't your first post. As far as the banging over bumps, have yo looked at your exhaust pipe where it goes over the rear axle? Many have found the pipe hits the axle when going over bumps.
Reply With Quote
  #3 (permalink)  
Old 25 Apr 2012, 05:08 am
Fresh Cruiser
 
Join Date: Jul 2010
Location: Central Massachusetts
Posts: 17
Default Re: front end clunk at low speed

You are right....I have posted before (9 times!) Forgot all about them...age related I am sure....The pipe will be checked tonight after work....I'm still eyeballing the sway bar, though.....might pull it anyway while I am under there and see what happens.....Thanks for the reply.....
Reply With Quote
  #4 (permalink)  
Old 05 May 2012, 02:39 pm
Fresh Cruiser
 
Join Date: May 2012
Posts: 8
Default Re: front end clunk at low speed

I did the same thing.2007 pt Cruiser, replaced control arms with Moog. it started to clunk at low speed's. I then replaced stabilizer bar bushings, links. Still clunk's. took bar completly off clunk gone. I then ordered, original part link's, worse.
I do not know what to do next. I am wondering if the moog arms are different from the original, seems like the links are binding.
Reply With Quote
  #5 (permalink)  
Old 05 May 2012, 03:57 pm
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,883
Default Re: front end clunk at low speed

Quote:
Originally Posted by buzzsaw0553 View Post
I did the same thing.2007 pt Cruiser, replaced control arms with Moog. it started to clunk at low speed's. I then replaced stabilizer bar bushings, links. Still clunk's. took bar completly off clunk gone. I then ordered, original part link's, worse.
I do not know what to do next. I am wondering if the moog arms are different from the original, seems like the links are binding.
What about were bar fastens too the frame? Is it loose?
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #6 (permalink)  
Old 05 May 2012, 10:11 pm
Fresh Cruiser
 
Join Date: May 2012
Posts: 8
Default Re: front end clunk at low speed

I even tried what someone did on another post, I cut a couple of peices of serpentine belt and put it under the clamp. didn't help. Tried lubricating the bushings no help.
Reply With Quote
  #7 (permalink)  
Old 06 May 2012, 04:26 pm
Fresh Cruiser
 
Join Date: Jul 2010
Location: Central Massachusetts
Posts: 17
Default Re: front end clunk at low speed

I got mine fixed finally. Removing the sway bar eliminated the noise, so when I put it back in, I tightened the stabilizer links much tighter than before, and it went away. The bushings had a pretty good bulge to them when I was done, buut it worked! Hope this helps.
Reply With Quote
  #8 (permalink)  
Old 07 May 2012, 09:03 pm
Fresh Cruiser
 
Join Date: May 2012
Posts: 8
Default Re: front end clunk at low speed

I think the hole for the stabilizer link is in the wrong place. The only thing I changed is the control arm's. I may have to get new bushings pressed into the old arms, and reinstall them. I tried factory plastic links, very bad. I now have the kind of links with the blue donuts and washers, they are a lot beter,but still make noise on big bumps.
Reply With Quote
  #9 (permalink)  
Old 08 May 2012, 03:32 pm
Fresh Cruiser
 
Join Date: Jul 2010
Location: Central Massachusetts
Posts: 17
Default Re: front end clunk at low speed

Before you spend any more money try making the links good and tight. And dont forget to make sure that the wheels are in their normal position (like they are on the ground when you go back to tighten the bar. I let my car down on the ground and then just reached under it and did the final tightening of the sway bar like that.
Reply With Quote
  #10 (permalink)  
Old 09 May 2012, 09:59 pm
Fresh Cruiser
 
Join Date: May 2012
Posts: 8
Default Re: front end clunk at low speed

I tighten them down they look like squshed donuts. So far they are quiet. Thanks for the sugestion.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
clunk clunk durango Tech & Performance Forum 11 01 Aug 2016 10:26 am
Front wheels shake at speed 50+ mph bigger_hammer Wheels, Tires, Suspension 5 26 Aug 2010 04:00 pm
Slip and a clunk delbassman General Turbo Discussions 15 17 Sep 2007 07:50 am
Low speed front end rattle MYCRSROH General PT Cruiser Discussions 5 14 Jul 2006 12:19 am
SRT-4 and GT 5 speed "clunk" noises lip General Turbo Discussions 9 13 Oct 2003 07:35 pm


All times are GMT -5. The time now is 08:31 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors