PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Wheels, Tires, Suspension

PT Cruiser Forum

Advertisements
Loud clunk from front end suspension

 
Like Tree1Likes
  • 1 Post By pluminator

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 14 Dec 2012, 12:48 pm
Fresh Cruiser
 
Join Date: Feb 2009
Location: Indiana
Posts: 14
Default Loud clunk from front end suspension

The car in question is a 2007 GT.

A month back I had my car lowered with the Tokico blues and Eibach springs. It wasn't long after that I noticed a thunk noise any time I went down/up a 90 degree angle. It doesn't matter the size, even the tiny little bump on the way into a parking lot causes the noise. It only does regularly on a straight cut off, if it's a rounded hump it almost never does it. Another thing I've noticed is that when my car gets put on a lift, jack, etc. the noise doesn't happen for a while. The noise is clearly coming from the suspension and it happens on both the passenger and driver side independently.

I got this all done right before I moved, so going back to the place I had it done just isn't going to happen. While I'm not a mechanic if I were so inclined I could tear apart the suspension and put it back together. I'm skilled enough to tackle the basics, do my own brakes, etc. I'm thinking of using this weekend to rip it apart.

I'm just not sure at this point in time what the problem could be. It's not the sway bar, although I'm going to replace the bushings and end links anyway because they're cheap and I might as well do it while I'm down there. I do have one tie rod end with a tiny bit of play in it and plan on replacing both, but that was already like that before the overhaul. It should only be happening on the side with the bad tie rod end if that was the cause.

Sometimes on a really bumpy road I think I can hear a rattle coming from the suspension. Almost like plastic on metal, as if the spring's top mount is jiggling around. It's hard to tell though because of all the other noises that come from driving on the world's crappiest road.

I've been reading up on it and I'm kind of at a loss at this point. I plan on getting underneath it this weekend and was hoping someone might have a few ideas on what to look for while I'm down there. Most of the other complaints I've found threads on mention things I've already ruled out, which is why I'm about to tear the suspension apart and put it back together in the hopes I find something broken/loose while I'm in there.

I also recently had the control arms replaced. The car has 90k miles on it and it's on its second replacement set of control arms. Other than this extremely annoying suspension issue the car is doing great, and I'd like to keep it that way.


I haven't googled this yet because I just thought of it while writing this post, but do those ground wires have anything to do with radio reception? I noticed one was broken when I did my brakes a while back so I fixed it and I noticed my radio reception was a heck of a lot better. Now once again I get absolutely no reception.
Reply With Quote
  #2 (permalink)  
Old 14 Dec 2012, 06:22 pm
Senior Cruiser
 
Join Date: May 2012
Posts: 1,354
Default Re: Loud clunk from front end suspension

i just had this issue myself.

And its relatively simple and thanks to another member, i was able to remedy it.

Swaybar........bushings that connect it to the vehicle. Give em a look.

Even with new control arms, swaybar links and a whole suspension mine clunked too.

Apparently the mounting bushings for the swaybar itself were shot, causing it to sway back and forth, thus slamming into the car ;-) $5 fix :-D
Busted_PT likes this.
Reply With Quote
  #3 (permalink)  
Old 14 Dec 2012, 08:15 pm
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,883
Default Re: Loud clunk from front end suspension

Quote:
Originally Posted by pluminator View Post
i just had this issue myself.

And its relatively simple and thanks to another member, i was able to remedy it.

Swaybar........bushings that connect it to the vehicle. Give em a look.

Even with new control arms, swaybar links and a whole suspension mine clunked too.

Apparently the mounting bushings for the swaybar itself were shot, causing it to sway back and forth, thus slamming into the car ;-) $5 fix :-D
Glade that worked for you.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #4 (permalink)  
Old 15 Dec 2012, 10:28 am
Fresh Cruiser
 
Join Date: Feb 2009
Location: Indiana
Posts: 14
Default Re: Loud clunk from front end suspension

Quote:
Originally Posted by pluminator View Post
i just had this issue myself.

And its relatively simple and thanks to another member, i was able to remedy it.

Swaybar........bushings that connect it to the vehicle. Give em a look.

Even with new control arms, swaybar links and a whole suspension mine clunked too.

Apparently the mounting bushings for the swaybar itself were shot, causing it to sway back and forth, thus slamming into the car ;-) $5 fix :-D
Unfortunately I already checked into that. 3 of the bolts broke off even with liberal use of Blaster and slowly trying to ease them out. The only one that didn't break was the one I said screw it and used an impact wrench on. Go figure. And to top it off the parts advance auto sold me weren't the right bushings and end links.

The bushings weren't in the best condition, but they were still usable. I'm going to end up replacing them anyway. I'll have to wait until next weekend though because nobody carries half the parts I want so I'll have to buy them online.
Reply With Quote
  #5 (permalink)  
Old 15 Dec 2012, 01:48 pm
Senior Cruiser
 
Join Date: May 2012
Posts: 1,354
Default Re: Loud clunk from front end suspension

Quote:
Originally Posted by RainWind View Post
Unfortunately I already checked into that. 3 of the bolts broke off even with liberal use of Blaster and slowly trying to ease them out. The only one that didn't break was the one I said screw it and used an impact wrench on. Go figure. And to top it off the parts advance auto sold me weren't the right bushings and end links.

The bushings weren't in the best condition, but they were still usable. I'm going to end up replacing them anyway. I'll have to wait until next weekend though because nobody carries half the parts I want so I'll have to buy them online.
Thats the issue i ran into. when i did all my swaybar work it took a few hours when it should have taken one.

One of my links was sheared clean off, and the bushings were almost fused to the bolt, so i had to use a dremel, chiesel and hammer to get it out, other side was rotted and fused to the swaybar itself, had to use a grinder to cut it out.

Then when i got to the bushings holding the swaybar on, noone carried them. ended up buying them direct from the dealer because out of 9 shops around me, noone had them haha.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
front end clunk at low speed gfp55 Wheels, Tires, Suspension 54 12 Jan 2016 11:42 pm
loud noise from front end...cooling fan? Bonecruiser Tech & Performance Forum 4 27 Nov 2012 11:05 pm
front end suspension babygms2005 Wheels, Tires, Suspension 9 10 Dec 2010 08:26 pm
front suspension noise RaceWilson Wheels, Tires, Suspension 7 23 Apr 2010 07:12 am
Loud clunk from suspension since replace lower control arms mwoodengr General PT Cruiser Discussions 4 09 Nov 2009 08:58 am


All times are GMT -5. The time now is 10:06 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors