PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Wheels, Tires, Suspension

PT Cruiser Forum

Advertisements
Seems to steer itself and wander

 
Like Tree14Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 23 Nov 2014, 04:28 am
Fresh Cruiser
 
Join Date: Oct 2014
Location: Chilliwack, BC Canada
Posts: 16
Question Seems to steer itself and wander

I recently bought my cruiser pretty much sight unseen. It is in very nice condition body and interior wise. 2003 non turbo base model. It was running rough and lots of front end noise (box of rocks sounds). I took it in for good tune up and inspection. Got a laundry list of things that needed fixing. One lower control arm bushing was so bad the mechanic said it was just resting on the frame. Brakes bad all around with some cylinder leak, shocks in rear needed replacing, and recommendation to do timing belt based on mileage. Before I took it in I drove at highway speeds for about 30 miles. Other than rough running and poor acceleration it seemed to steer and track fine. I have someone helping me get work done on suspension and brakes. I purchased moog lower control arms and we did the passenger side. It was a major pain to do. After it was done I returned home driving about 20 miles on highway. That's when I first noticed the wonky steering issues. It was like it would momentarily lose steering control and also start going off to one side all on it's own and then to the other side. This was also just momentarily then it went back to proper steering. I also noticed it seemed to pull to either or both sides on acceleration and deceleration. We have tried to systematically check and repair/replace a few things now but the problem persists. We noticed lower engine strut mount had rubber torn through, replaced with a good used one (engine was twisting quite a bit but seems better. We did the driver's side LCA, much easier. Neither of these helped with steering issue but it sounds better. Replaced rear shocks, and just put new bushings and end links (moog) on the sway bar. I have search for answers to no avail and was hoping for some feedback or suggestions here. I haven't had an alignment and was hoping to wait until the end of work that needs doing before getting one. Tires are 16 with lower profile all matched seem to have good tread and even wear. They are first tires that take higher than the 32-34 psi I'm use to (they say 51psi) when I checked the were all over map (even so like I said initially no steering problems noticed) I filled them all evenly but seems they are leaking a little. Going to get them all checked shortly. Anyways that the long and short of it any help is appreciated.
__________________
2003 Silver 2.4L non-turbo AT 175,000 km - currently all stock equipment with cd, power windows and door locks, charcoal cloth interior.
Reply With Quote
  #2 (permalink)  
Old 23 Nov 2014, 09:18 am
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,891
Default Re: Seems to steer itself and wander

Quote:
Originally Posted by eaglewise View Post
I recently bought my cruiser pretty much sight unseen. It is in very nice condition body and interior wise. 2003 non turbo base model. It was running rough and lots of front end noise (box of rocks sounds). I took it in for good tune up and inspection. Got a laundry list of things that needed fixing. One lower control arm bushing was so bad the mechanic said it was just resting on the frame. Brakes bad all around with some cylinder leak, shocks in rear needed replacing, and recommendation to do timing belt based on mileage. Before I took it in I drove at highway speeds for about 30 miles. Other than rough running and poor acceleration it seemed to steer and track fine. I have someone helping me get work done on suspension and brakes. I purchased moog lower control arms and we did the passenger side. It was a major pain to do. After it was done I returned home driving about 20 miles on highway. That's when I first noticed the wonky steering issues. It was like it would momentarily lose steering control and also start going off to one side all on it's own and then to the other side. This was also just momentarily then it went back to proper steering. I also noticed it seemed to pull to either or both sides on acceleration and deceleration. We have tried to systematically check and repair/replace a few things now but the problem persists. We noticed lower engine strut mount had rubber torn through, replaced with a good used one (engine was twisting quite a bit but seems better. We did the driver's side LCA, much easier. Neither of these helped with steering issue but it sounds better. Replaced rear shocks, and just put new bushings and end links (moog) on the sway bar. I have search for answers to no avail and was hoping for some feedback or suggestions here. I haven't had an alignment and was hoping to wait until the end of work that needs doing before getting one. Tires are 16 with lower profile all matched seem to have good tread and even wear. They are first tires that take higher than the 32-34 psi I'm use to (they say 51psi) when I checked the were all over map (even so like I said initially no steering problems noticed) I filled them all evenly but seems they are leaking a little. Going to get them all checked shortly. Anyways that the long and short of it any help is appreciated.
Tie rod ends inner or outer. Ckeck that you got everything tight. Odd That this only showed up after the work. Check all that was done very carefully.
eaglewise likes this.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #3 (permalink)  
Old 23 Nov 2014, 12:11 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Seems to steer itself and wander

Quote:
Originally Posted by eaglewise View Post
. Tires are 16 with lower profile all matched seem to have good tread and even wear. They are first tires that take higher than the 32-34 psi I'm use to (they say 51psi)


NO! Where are you getting 51PSI? Look at the sticker inside the driver's door - should be more like 36 PSI.
If the 51 is on the tire, that is the maximum PSI the tire is rated for.
eaglewise likes this.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #4 (permalink)  
Old 23 Nov 2014, 12:54 pm
Fresh Cruiser
 
Join Date: Oct 2014
Location: Chilliwack, BC Canada
Posts: 16
Thumbs up Re: Seems to steer itself and wander

Quote:
Originally Posted by Busted_PT View Post
Tie rod ends inner or outer. Ckeck that you got everything tight. Odd That this only showed up after the work. Check all that was done very carefully.
Thanks Busted_PT I will do that next. I bought this vehicle to use everyday but I also look at it different than any car I've owned. Fixing something doesn't give me that oh no I've got to spend money to fix this or that its like an investment that simply improves it in some way. Not that I like throwing money at anything but its not throwing it away since I feel like I'm restoring/improving something. If it needs something, so be it. I want it to run perfectly. PT Perfect that is! I also have some rear noises haven't clarified yet that are more noticeable now that the "box of rocks" sound is gone. Going to continue reading that manual I downloaded, checking forum, and online researching rear suspension. Me and my PT - getting to know it getting to know all about it"
__________________
2003 Silver 2.4L non-turbo AT 175,000 km - currently all stock equipment with cd, power windows and door locks, charcoal cloth interior.
Reply With Quote
  #5 (permalink)  
Old 23 Nov 2014, 01:23 pm
Fresh Cruiser
 
Join Date: Oct 2014
Location: Chilliwack, BC Canada
Posts: 16
Smile Re: Seems to steer itself and wander

Quote:
Originally Posted by quicksilverdon View Post


NO! Where are you getting 51PSI? Look at the sticker inside the driver's door - should be more like 36 PSI.
If the 51 is on the tire, that is the maximum PSI the tire is rated for.
I just went and rechecked the tires. They are Goodyear Assurance P205/55R16 and tire sidewall says max 51 psi. When I first checked them one was over 60 and the rest ranged down to a low 25. Initially I freaked thinking good God these are going to blow up and started letting air out of the over 60 one. I mentioned it to the guy helping me and he looked and saw higher rating. I filled them evenly to that level. Checked few days later and some had dropped into 40's so going to get them taken off rims, maybe new valve stems, and resealed back on rims to see how that goes. Like I said tires are matched, wear seems even with enough left for awhile now (also gives me chance to decide longer term plan for rims and tires -although I think the stock 16 rims look nice as is) so hoping don't need to replace right now, plus as Busted_PT noted odd problems just started after started working on it.
__________________
2003 Silver 2.4L non-turbo AT 175,000 km - currently all stock equipment with cd, power windows and door locks, charcoal cloth interior.
Reply With Quote
  #6 (permalink)  
Old 23 Nov 2014, 01:28 pm
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,891
Default Re: Seems to steer itself and wander

Quote:
Originally Posted by quicksilverdon View Post


NO! Where are you getting 51PSI? Look at the sticker inside the driver's door - should be more like 36 PSI.
If the 51 is on the tire, that is the maximum PSI the tire is rated for.
No that is incorrect. The tire doesn't know what a particular sticker says. The inflation is based off the max psi of the tire. I would start at around 40 lbs or so and watch the tire ware. There Probobly leaking around the rim. If it's the chrome ones You will need to check to see if the chrome is blistering where the bead seals. That is the vertical lip of the rim not the flat part at the bottom of the lip.
eaglewise likes this.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com

Last edited by Busted_PT; 23 Nov 2014 at 01:34 pm.
Reply With Quote
  #7 (permalink)  
Old 23 Nov 2014, 01:32 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Seems to steer itself and wander

Quote:
Originally Posted by Busted_PT View Post
No that is incorrect. The tire doesn't know what a particular sticker says. The inflation is based off the max psi of the tire. I would start at around 40 lbs or so and watch the tire ware.
And the tire doesn't know what car it's going on. The same tire can be used on different cars and should be inflated for the car, not to its max rating.
His 205/55 16 tires should be at 36 PSI on a PT.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #8 (permalink)  
Old 23 Nov 2014, 01:37 pm
Fresh Cruiser
 
Join Date: Oct 2014
Location: Chilliwack, BC Canada
Posts: 16
Unhappy Re: Seems to steer itself and wander

Quote:
Originally Posted by eaglewise View Post
I just went and rechecked the tires. They are Goodyear Assurance P205/55R16 and tire sidewall says max 51 psi. When I first checked them one was over 60 and the rest ranged down to a low 25. Initially I freaked thinking good God these are going to blow up and started letting air out of the over 60 one. I mentioned it to the guy helping me and he looked and saw higher rating. I filled them evenly to that level. Checked few days later and some had dropped into 40's so going to get them taken off rims, maybe new valve stems, and resealed back on rims to see how that goes. Like I said tires are matched, wear seems even with enough left for awhile now (also gives me chance to decide longer term plan for rims and tires -although I think the stock 16 rims look nice as is) so hoping don't need to replace right now, plus as Busted_PT noted odd problems just started after started working on it.
Actually I just reread this. So I shouldn't be filling to max? I am not sure but I thought I used sidewall max before and it was like the 34 psi. Now I'm really feeling dumb. I have always ranged between 32-34 in my tires. 34 in winter and 32 in summer to adjust for heat expansion. The door says 34 for both size rims
__________________
2003 Silver 2.4L non-turbo AT 175,000 km - currently all stock equipment with cd, power windows and door locks, charcoal cloth interior.
Reply With Quote
  #9 (permalink)  
Old 23 Nov 2014, 01:50 pm
Fresh Cruiser
 
Join Date: Oct 2014
Location: Chilliwack, BC Canada
Posts: 16
Default Re: Seems to steer itself and wander

Here is sticker pix Just checked quality my phone camera sometimes produces these crappy out of focus shots
Attached Images
File Type: jpg 002.jpg (101.7 KB, 16 views)
__________________
2003 Silver 2.4L non-turbo AT 175,000 km - currently all stock equipment with cd, power windows and door locks, charcoal cloth interior.

Last edited by eaglewise; 23 Nov 2014 at 01:55 pm.
Reply With Quote
  #10 (permalink)  
Old 23 Nov 2014, 01:58 pm
Fresh Cruiser
 
Join Date: Oct 2014
Location: Chilliwack, BC Canada
Posts: 16
Default Re: Seems to steer itself and wander

Here is shot of my PT in underground showing stock 16 rims I have.
Attached Images
File Type: jpg 001.jpg (95.1 KB, 12 views)
__________________
2003 Silver 2.4L non-turbo AT 175,000 km - currently all stock equipment with cd, power windows and door locks, charcoal cloth interior.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
power steer cruizinla Tech & Performance Forum 1 29 Dec 2008 10:24 pm
Torque Steer 2step Turbo Performance 23 02 Feb 2005 03:14 am
Torque steer gone GTSteve Turbo Wheels/Suspension/Handling 21 30 Sep 2003 11:32 pm
torque steer GTSteve Tech & Performance Forum 2 24 Sep 2003 01:18 am
torque steer Punch Turbo Performance 9 07 Sep 2003 08:18 pm


All times are GMT -5. The time now is 03:23 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors