PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Loosing anti-freeze? ...Rats!!

 
Closed Thread
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 20 May 2004, 09:24 am
Regular Cruiser
 
Join Date: Dec 2003
Location: .
Posts: 115
Default Loosing anti-freeze? ...Rats!!

This is the 2nd time now (got the car Dec 10th) that I noiced a drop in my anti-freeze level. It's gone from the full mark to about halfway between add and full. The car has 11K miles on it and just had it's 3rd oil change.
Is this drop in anti-freeze normal?
When I notice the drop I just fill it with some quick fill (pre distilled) Dex-cool to the full line. I'm gonna monitor it this time and see just how much it looses over time. Everything else is running just fine.

On a side note... Yesterday I noticed something that looked like a piece of an onion peel on the engine block, then I saw them...rodent droppings (on the block and in the air box)!! Cleaned it out with some compressed air. I hope he stayed in the air box till about 50 mph !!
  #2 (permalink)  
Old 20 May 2004, 10:33 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default

Suggest you don't add 'till it's by low when cold. It should be halfway or lower when cold, and only near full when warm - suspect what you add goes out on the road when it's warmed up, if you're topping it to full when cold.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
  #3 (permalink)  
Old 20 May 2004, 11:43 am
Regular Cruiser
 
Join Date: Dec 2003
Location: .
Posts: 115
Default

Quote:
quote:Originally posted by quicksilverdon

Suggest you don't add 'till it's by low when cold. It should be halfway or lower when cold, and only near full when warm - suspect what you add goes out on the road when it's warmed up, if you're topping it to full when cold.
Actually I was topping when warm. I'm gonna watch it anyway...
Closed Thread


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Anti Sway Bar Question skydive69 Tech & Performance Forum 11 12 Nov 2002 01:52 am


All times are GMT -5. The time now is 07:15 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors