PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
2006 2.4L non turbo P0480

 
Like Tree10Likes

Reply
 
LinkBack Thread Tools Display Modes
  #11 (permalink)  
Old 17 Jun 2017, 08:27 am
rsrocket1's Avatar
Fanatic Cruiser
 
Join Date: Mar 2016
Location: Sacramento, CA
Posts: 791
Default Re: 2006 2.4L non turbo P0480

Quote:
Originally Posted by kcbuechler View Post
Hey all,

The fan didn't come on until the car reached the half way mark on the temp gauge even though the A/C was on, so I still think somethings wrong with the computer sending the signal to turn on the low speed relay. .
Look at the chart again. The high speed fan (or no fan at all) will not come on with the A/C button pressed until the temp is at least 180F.

This is what 185F looks like on my dial, YMMV.
Reply With Quote
  #12 (permalink)  
Old 17 Jun 2017, 09:20 am
Fresh Cruiser
 
Join Date: Jun 2017
Location: scappoose, OR
Posts: 16
Default Re: 2006 2.4L non turbo P0480

So by bleeding off some pressure, the fan now works as soon as you turn on AC like it should. Still have the check engine light so I tried clearing it and it came right back. Cleared it again, this time with the AC off and no check engine light, turn the AC on and I noticed it took maybe 10 seconds for the compressor to start cycling and the fan turned on as soon as the compressor started and then the check engine light came back on. Still just the P0480 at the moment. So maybe the sensor for the compressor?
Reply With Quote
  #13 (permalink)  
Old 17 Jun 2017, 09:34 am
rckstein's Avatar
Banned
 
Join Date: Dec 2010
Location: Texas
Posts: 15,518
Default Re: 2006 2.4L non turbo P0480

Quote:
Originally Posted by rsrocket1 View Post
Look at the chart again. The high speed fan (or no fan at all) will not come on with the A/C button pressed until the temp is at least 180F.

This is what 185F looks like on my dial, YMMV.
This is what's misleading about this chart, because everyone says that on a cold engine, as soon as you turn on the a/c, the fan comes on. This is how my PT, as well as many others, operate in this manner, and that's considered normal operation.
Reply With Quote
  #14 (permalink)  
Old 17 Jun 2017, 10:24 am
Fresh Cruiser
 
Join Date: Jun 2017
Location: scappoose, OR
Posts: 16
Default Re: 2006 2.4L non turbo P0480

just wanted to reiterate that yes the fan does come on in low speed when you turn on the A/C, as it should be. With a pressure gauge on the refill port I can watch the pressure go up to around 45psi and then back down to about 25psi. It will do this the entire time its in park and when the compressor kicks on and brings the pressure down you get cold air out, then it switches off and gets warm again. I don't know what the pressure should be reading, maybe now I've bled off too much? But the problem still remains why does it take 10 seconds for the AC to engage from the time you turn it on?
Reply With Quote
  #15 (permalink)  
Old 17 Jun 2017, 10:47 am
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,600
Default Re: 2006 2.4L non turbo P0480

Since both P0480 and P0481 are being triggered I would suggest checking the G104 ground which applies to both low and high speed on the radiator fan.
kcbuechler likes this.
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #16 (permalink)  
Old 17 Jun 2017, 05:26 pm
Fresh Cruiser
 
Join Date: Jun 2017
Location: scappoose, OR
Posts: 16
Default Re: 2006 2.4L non turbo P0480

Ill check the ground cable when I have time, I did eventually swap the two relays with new ones, got them from Oreilly's, just to say for sure they were good.

Had a mechanic look at it and he said if the relays didn't fix it then its probably the TIPM, so really really hoping its not that!

He did say my A/C pressure was too low again so need to go back to flush the system and try again.
Reply With Quote
  #17 (permalink)  
Old 18 Jun 2017, 02:40 am
Fresh Cruiser
 
Join Date: Jun 2017
Location: scappoose, OR
Posts: 16
Default Re: 2006 2.4L non turbo P0480

Quote:
Originally Posted by ptcruisersteve View Post
Since both P0480 and P0481 are being triggered I would suggest checking the G104 ground which applies to both low and high speed on the radiator fan.
any chance anyone out there has a decent wiring diagram?
Reply With Quote
  #18 (permalink)  
Old 18 Jun 2017, 06:57 am
rckstein's Avatar
Banned
 
Join Date: Dec 2010
Location: Texas
Posts: 15,518
Default Re: 2006 2.4L non turbo P0480

.....
kcbuechler likes this.

Last edited by rckstein; 19 Aug 2017 at 11:07 pm. Reason: Edited because of one other member that wants to control everything.
Reply With Quote
  #19 (permalink)  
Old 21 Jun 2017, 11:38 am
Fresh Cruiser
 
Join Date: Jun 2017
Location: scappoose, OR
Posts: 16
Default Re: 2006 2.4L non turbo P0480

can anyone out there verify if this is correct or not? Does it normally take about 15 seconds from the time you turn on the A/C for it to actually engage and start cycling the compressor and turn on the fan?

thanks!
Reply With Quote
  #20 (permalink)  
Old 21 Jun 2017, 11:43 am
Regular Cruiser
 
Join Date: Aug 2013
Location: Az
Posts: 180
Default Re: 2006 2.4L non turbo P0480

Yes that is how it is to work
Reply With Quote
Reply

Tags
2006 pt cruiser, a/c problems, non-turbo, radiator fan


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Codes P0480, P0622 - seems erratic Jester1 Turbo Performance 10 26 Aug 2017 12:03 pm
Codes P0201-204, P0301-304, P0351, P0480 PTATER Tech & Performance Forum 2 04 Feb 2017 12:51 pm
P0480 - Cooling Fan Relay but weird... robert99ranger Tech & Performance Forum 6 03 Feb 2014 12:07 am
P0480 need help asap 203turbopt General Turbo Discussions 7 25 Sep 2012 04:49 pm
Computer code # P0480 MINIHEMI46 General Turbo Discussions 10 17 Jul 2007 04:04 pm


All times are GMT -5. The time now is 07:52 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors