PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > Members List

PT Cruiser Forum

Advertisements
brian_jill's Profile

 

brian_jill brian_jill is offline

Fresh Cruiser

Visitor Messages

Showing Visitor Messages 1 to 2 of 2
  1. brian_jill
    26 Oct 2011 07:45 am - permalink
    brian_jill
    I have a 2005 PT Cruiser with 180K miles on it. For the last few days it is randomly over heating. The fan is working (replaced it 2 years ago) and after it over heats it cools down and there is not problem. It would appear that the thermostat is not functioning correctly. Can anyone confirm my diagnosis. Thanks
  2. brian_jill
    03 Feb 2010 06:15 pm - permalink
    brian_jill
    I have a 2004 PT Cruiser. After a long drive of about 90 miles I stopped the car for about 30 minutes. When I started it up again it ran rough and the engine light came on. Then the engine light started flashing. I was not in a place where I could leave the car to wait for a tow, so I put it in gear to move it a few hundred yards and the transmission would barely engage - I had to rev the engine pretty high to get the car to move. I checked the transmission fluids and oil, they are both OK. It seems like this may be a computer problem. Can anyone shed any light. Thanks.

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 26 Oct 2011 10:36 am
  • Join Date: 19 Dec 2008
  • Referrals: 0

All times are GMT -5. The time now is 11:37 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors