PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > PT Cruiser Videos

PT Cruiser Forum

Advertisements
multiple sudden electrical issues

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 30 Sep 2014, 07:43 pm
Fresh Cruiser
 
Join Date: Sep 2014
Posts: 1
Default multiple sudden electrical issues

2003 PT Cruiser 101K miles automatic transmission
Sudden loss of multiple electrical systems
has had the fog light issue for some time but all of a sudden we have lost power mirrors power locks and interior lights vehicle has had starting issues battery is good fuses are good the puzzling part is gauge cluster flashes no fuse but fuse is good where do I start looking what do I need to replace
Reply With Quote
  #2 (permalink)  
Old 30 Sep 2014, 07:45 pm
NitroPT's Avatar
Obsessed Cruiser
 
Join Date: Jun 2012
Location: USA kalyfornia
Posts: 16,119
Default Re: multiple sudden electrical issues

http://www.ptcruiserlinks.com/forum/...ead-first.html
__________________
To view larger pictures simply "click " on the picture!

Dalai Lama
"Share you knowledge. It's the best way to achieve immortality."
ASE MASTER TECHNICIAN
Reply With Quote
  #3 (permalink)  
Old 30 Sep 2014, 10:04 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: multiple sudden electrical issues

Look at the wiring going to the fuse blocks by driver's knee, and one under the hood by battery....
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #4 (permalink)  
Old 30 Sep 2014, 10:11 pm
Veteran Cruiser
 
Join Date: Sep 2010
Location: Walking distance to the embassy
Posts: 3,248
Default Re: multiple sudden electrical issues

Check fuse #18 (20 amp) in the under-hood PDC. It protects RKE door locks, power mirrors, instrument cluster, dome, overhead console, visor mirror lights, cargo lamp and radio.
Dash fuse block #13 (10 amp) also protects these circuits.

"No Fuse" is flashing because the instrument cluster is not getting circuit M1 power through PDC fuse 18 and dash fuse 13.
Reply With Quote
  #5 (permalink)  
Old 03 Oct 2014, 05:25 pm
2step's Avatar
Senior Cruiser
 
Join Date: Oct 2004
Location: New Braunfels, Texas.
Posts: 1,672
Default Re: multiple sudden electrical issues

Most times electrical issues like you describe are because of a low or failing battery. When the PCM senses low power it starts sacrificing power to many second line systems in order to keep the car running. Take another hard look at the battery. Even if it's a fresh battery, that doesn't mean it isn't bad. Your problem could be something else but that's where I would focus first.
Reply With Quote
  #6 (permalink)  
Old 04 Oct 2014, 02:38 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,600
Default Re: multiple sudden electrical issues

I would suggest that if you have a volt meter check the voltage of the battery. It should be around 12 volts engine not running and 14 to 14.5 volts running.
Reply With Quote
  #7 (permalink)  
Old 21 Mar 2015, 01:08 pm
Fresh Cruiser
 
Join Date: Feb 2015
Location: Tampa, FL
Posts: 4
Default Re: multiple sudden electrical issues

IOD fuse under hood in the PCM box next to the air cleaner slightly behind...20 amp fuse in special black plastic hinged door...flip the plastic lid up that is over the fuse... and the 20 amp std IOD fuse is there...replace it...likely all will be well...mine was! 2003 PT non-turbo...
Reply With Quote
Reply

Tags
electrical, fog_lights, no_fuse, power_locks, power_mirror


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Multiple issues started w/ p0300 Sieve29 Tech & Performance Forum 2 04 Nov 2013 12:15 pm
having electrical issues PT_L01A General PT Cruiser Discussions 4 04 Sep 2013 10:15 pm
'01 Electrical Issues Mabel General PT Cruiser Discussions 1 15 Apr 2012 06:22 pm
Help Please ! Electrical issues. thegooch2 Tech & Performance Forum 5 16 Aug 2010 06:53 am
Multiple issues with 2003 Cruiser. bjagd02 General PT Cruiser Discussions 20 22 Jul 2010 03:32 pm


All times are GMT -5. The time now is 03:08 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors