PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Sound and Security Forum

PT Cruiser Forum

Advertisements
Red Security Light Flashing; Vehicle Won't Start

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 12 Jan 2016, 08:59 am
Fresh Cruiser
 
Join Date: Jan 2016
Posts: 11
Default Red Security Light Flashing; Vehicle Won't Start

Hi all! I have a 2007 PT Cruiser that sits as my backup vehicle. Just the other day I went for a routine start (I live in Alaska) and the battery was dead af. Nothing came on at all. I hooked it up to a charger and all the lights/radio/etc started working. However, when I went to turn the key, the vehicle wouldn't turn over. It didn't even engage the starter. I figured it might just be a worthless battery (I can't even remember how old it is). Sometimes the cold messes with things. Well I picked up a new battery and same deal. I have, however, noticed a red flashing dot on the dash. I've done some research and it seems this is part of the factory security system. I don't know what could have caused this to trigger. I've changed batteries before with no issues, but I don't know if it's ever been that dead. For the record I have the big fat black keys with the lock, unlock, and panic buttons. I've tried locking and unlocking the doors electronically, and it doesn't disable it. Neither of the keys work, as well. The only reason I'm thinking it's the security system is because I've never seen that dot flash like that before. Also, it sometimes makes a ding if I leave the key in for a bit. Thank you in advanced.

Last edited by ImplicitWeevil; 14 Jan 2016 at 03:02 pm.
Reply With Quote
  #2 (permalink)  
Old 12 Jan 2016, 09:34 am
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,600
Default Re: Red Security Light Flashing; Vehicle Won't Start

I have not had this problem but another member posted that it did work for him.

Try opening the rear hatch with the chipped key. Post back and let us know if this works. If it doesn't then there is another method but it requires a battery charger.

You might want to introduce yourself and tell us a little about your Pt Cruiser.
__________________
If at First You Don't Succeed - Try, Try Again

Last edited by ptcruisersteve; 12 Jan 2016 at 10:21 am.
Reply With Quote
  #3 (permalink)  
Old 12 Jan 2016, 06:44 pm
Fresh Cruiser
 
Join Date: Jan 2016
Posts: 11
Default Re: Red Security Light Flashing; Vehicle Won't Start

Thanks for the response! No, unfortunately it didn't work. I also tried unlocking the driver door with the key. The first time it shut off the light (until I put it in the ignition and tried to start it). The second time I unlocked the door it set off the alarm when I opened it. Huh. Hatch opened no problem. Well if there's another method I'm all for it. I do have a battery charger. Are the ones for home use, that you plug in, suitable? Also, I just came across this video.


He has the exact same problem as me, except his light is solid. Do you happen to know the location of that fuse in this vehicle? I might give this a try, as well.
Also, my mistake, this is on the 2007 PT Cruiser, Touring Edition. It has 83,XXX miles. It ends up being my backup vehicle most of the year; it gets driven maybe a 4 times. I really like the red these come in. XD

Last edited by ImplicitWeevil; 14 Jan 2016 at 03:03 pm.
Reply With Quote
  #4 (permalink)  
Old 12 Jan 2016, 06:59 pm
Handy_Cruiser's Avatar
Obsessed Cruiser
 
Join Date: Oct 2013
Location: Arkansas
Posts: 10,785
Default Re: Red Security Light Flashing; Vehicle Won't Start

Remove the battery cable for about ten minutes and then hook it back up. The SKIM has to do a handshake with the PCM when the the battery is initially hooked up or when the SKEM or PCM is installed. If something went wrong to mess up this handshake, it may give you the effect you have.

It's also possible that this has nothing to do with the SKEM but is just a blown ignition fuse. There are conditions where the red light will keep blinking if the car is not started or at least the ignition is turned. And if this can't fully happen, you might see what you are getting now. But do the battery thing first.

Also, are you really sure the old battery was bad? Did they load test it before selling your the new one? We could well be obsessing over the wrong problem here.
__________________

Last edited by Handy_Cruiser; 12 Jan 2016 at 07:06 pm.
Reply With Quote
  #5 (permalink)  
Old 12 Jan 2016, 07:21 pm
Fresh Cruiser
 
Join Date: Jan 2016
Posts: 11
Default Re: Red Security Light Flashing; Vehicle Won't Start

Awesome, thanks; I'll go do that. That's a very good possibility; I believe it had to be jumpstarted at one point. It's possible that f'd up a fuse somewhere. Well, I'm pretty sure the battery is still usable; however, it was 100% drained at one point. No lights or anything. I don't even think the shift lever light was on, or it was really dim. I did manage to charge it, though. So I don't think it was bad so much as it was drained. Tbh I just changed the battery because old ones can sometimes cause no crank conditions in the cold, and it was probably like 5 years old. I can bring it back if need be, but it needed to happen anyway. There's a new one in there now, so it should be a non-factor now but I can't say what happened with the fiddling on the old one.
Reply With Quote
  #6 (permalink)  
Old 12 Jan 2016, 09:41 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,600
Default Re: Red Security Light Flashing; Vehicle Won't Start

I would suggest another method that another member had said it worked for him to unlock the security system after I had him try these instructions.

Park the PT Cruiser where you can leave it for two hours with a battery charger hooked up.

First fully charge the battery with the battery charger. After it is fully charged turn the ignition key to the "ON" position with the battery charger still charging (The engine is not running). Do not have anything else on such as lights, radio, etc. Leave the ignition to the "ON" position for two hours. After two hours turn the ignition key to the "OFF" position and then disconnect the battery charger. Now try to start the PT Cruiser. Post what happens.
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #7 (permalink)  
Old 12 Jan 2016, 10:38 pm
Fresh Cruiser
 
Join Date: Jan 2016
Posts: 11
Default Re: Red Security Light Flashing; Vehicle Won't Start

Well I've tried disconnecting the battery for well over ten minutes; same deal. I've set it up for the process Steve has suggested. I'll check on it in two hours (if I wake up anyway). It's getting pretty late in my day so I'll take a nap (I might make even less sense otherwise). Thank you guys for all the help! By the way, Handy, where might the ignition fuse be located?
Reply With Quote
  #8 (permalink)  
Old 13 Jan 2016, 01:35 pm
Veteran Cruiser
 
Join Date: Sep 2010
Location: Walking distance to the embassy
Posts: 3,251
Default Re: Red Security Light Flashing; Vehicle Won't Start

Because Trump

Last edited by sanatanadharma; 10 Nov 2016 at 06:59 pm. Reason: MUST WEAR MY DIGUISE
Reply With Quote
  #9 (permalink)  
Old 13 Jan 2016, 02:35 pm
Fresh Cruiser
 
Join Date: Jan 2016
Posts: 11
Default Re: Red Security Light Flashing; Vehicle Won't Start

Everything works as far as I can tell. Radio, clock, dash lights, outside lights, dome light, locks, horn. I'll go check the wipers, heater and.. I'm not sure there's much else unless I'm forgetting something. The only thing that doesn't seem to function is the starter, but it doesn't have any of the typical starter problems; nor did it show any signs it was going out. It simply does nothing. I turn the key to initiate the starter and not a single thing happens. No sound, nothing. There's just that flashing dot, battery sign, and airbag/seatbelt sign that's usually lit before you start the vehicle. Good to know about the ding; I don't believe it happens everytime, though (should it?). I'll check that as well.
Reply With Quote
  #10 (permalink)  
Old 14 Jan 2016, 02:10 pm
Fresh Cruiser
 
Join Date: Jan 2016
Posts: 11
Default Re: Red Security Light Flashing; Vehicle Won't Start

I might be crazy but I don't see a #1 fuse in there. I see where it's labeled and I guess should be, but there's no fuse there.
Reply With Quote
Reply

Tags
flashing, immobilizer, red flashing dot, security, won't start


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
What to do when the red security light stays on and car won't start Jarcher9 Tech & Performance Forum 3 20 Nov 2015 10:51 pm
My PT Cruiser WON'T start (flashing red dot) caponeeatabone Tech & Performance Forum 11 29 Nov 2014 11:15 am
Adding OEM vehicle theft security system (VTSS) alarm sanatanadharma Sound and Security Forum 4 11 May 2013 06:09 pm
Tail Light Security !!!! HELP c13ckb Sound and Security Forum 4 01 Feb 2010 04:07 am
How many times does it take to start you vehicle? alexatanes General PT Cruiser Discussions 8 25 Nov 2008 08:26 pm


All times are GMT -5. The time now is 07:43 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors