PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
WEAK STARTING LIKE LOW BATTERY

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 15 Dec 2008, 06:53 pm
Fresh Cruiser
 
Join Date: Dec 2008
Posts: 2
Default WEAK STARTING LIKE LOW BATTERY

REPLACED BATTERY WORKED OK FOR A FEW WEEK NOW IT IS SLOW TO START CHARAGING IS 14,5 VOLT STARTS GOOD WITH A JUMP ARE THESE CARS HARD ON BATTERYS OR DO I HAVE ANOTHERE BAD BATTERY
Reply With Quote
  #2 (permalink)  
Old 15 Dec 2008, 07:41 pm
Hooligan's Avatar
Obsessed Cruiser
 
Join Date: Aug 2003
Posts: 6,023
Default Re: WEAK STARTING LIKE LOW BATTERY

Welcome to the Forum, but using caps = SHOUTING!!!

It is possible you have a bad battery, but not knowing where you are located, I can take a wild guess that you are in the US. Take the PT to Advance Auto, Pep Boys or where ever you got the battery. Tell them the problem you are having and let them check your starting system. Most will check it IF they think there will be a sale. Good Luck and let us know how you make out.
__________________

2008 Silver Steel Metallic, Touring, NA, Sirius; Chromed door handles; lower grille; fog light surrounds; chrome front & rear bumpers strips; Airaid air filter; Bassani duals; Modesty Cover; Autolite AP5263 Platinum Plugs (.040); Crane Plug Wires; NAPA Ceramic pads; Blane hood struts; PTeazer Gas, Brake & Foot Rest Pedals, '05 Rear Step Pad, Stainless Door Sills, Llumar tint, "A" Piller chrome; APC Strut Bar
Reply With Quote
  #3 (permalink)  
Old 17 Dec 2008, 04:52 pm
Fresh Cruiser
 
Join Date: Dec 2008
Posts: 2
Default Re: WEAK STARTING LIKE LOW BATTERY

found out last night that new battery leaked out fumes or acid that ran down postive post and caused corosive action on connection replaced battery cable al is well
Reply With Quote
  #4 (permalink)  
Old 17 Dec 2008, 07:20 pm
Hooligan's Avatar
Obsessed Cruiser
 
Join Date: Aug 2003
Posts: 6,023
Default Re: WEAK STARTING LIKE LOW BATTERY

Congratulations!!!!
__________________

2008 Silver Steel Metallic, Touring, NA, Sirius; Chromed door handles; lower grille; fog light surrounds; chrome front & rear bumpers strips; Airaid air filter; Bassani duals; Modesty Cover; Autolite AP5263 Platinum Plugs (.040); Crane Plug Wires; NAPA Ceramic pads; Blane hood struts; PTeazer Gas, Brake & Foot Rest Pedals, '05 Rear Step Pad, Stainless Door Sills, Llumar tint, "A" Piller chrome; APC Strut Bar
Reply With Quote
  #5 (permalink)  
Old 19 Dec 2008, 09:52 am
Senior Cruiser
 
Join Date: Dec 2003
Location: Tallahassee, FL, USA.
Posts: 1,984
Default Re: WEAK STARTING LIKE LOW BATTERY

I wouldn't go back to the shop again if I was you.
The damaged battery was caused by bad install.
__________________
Kingkole02
Just Cruisin, 03 N/A auto. TE Steel Blue w/ pearl coat & chrome package. Too many extras to list, see pics
Reply With Quote
  #6 (permalink)  
Old 19 Dec 2008, 09:56 am
Senior Cruiser
 
Join Date: Dec 2003
Location: Tallahassee, FL, USA.
Posts: 1,984
Default Re: WEAK STARTING LIKE LOW BATTERY

Oh and by the way, that acid, can cause some serious damage to the engine, rinse as quickly as you can.

I had a battery blow up in my engine after my front end accident and it eat the paint all under the hood and side wall, nothing I could do about it then the wrecker had taken the PT to the shop directly, where it stayed for 2 weeks.
__________________
Kingkole02
Just Cruisin, 03 N/A auto. TE Steel Blue w/ pearl coat & chrome package. Too many extras to list, see pics
Reply With Quote
  #7 (permalink)  
Old 19 Dec 2008, 10:28 am
crusierdad76's Avatar
Fanatic Cruiser
 
Join Date: Aug 2008
Location: St James Missouri
Posts: 641
Default Re: WEAK STARTING LIKE LOW BATTERY

Quote:
Originally Posted by KingKole02 View Post
I wouldn't go back to the shop again if I was you.
The damaged battery was caused by bad install.

Hey don't take this wrong but I'm really wondering how exactly you can install a battery "WRONG" cause if you are suggesting that they switched the leads---- Positive on ground and ground on hot ----- that didn't happen ir the car would have fried most of the systems plus that sparking thing is a pain---so how can you put on in wrong???im just asking cause i have heard this before and never understood it..was it just the wrong battery???
Reply With Quote
  #8 (permalink)  
Old 19 Dec 2008, 11:57 am
Senior Cruiser
 
Join Date: Dec 2003
Location: Tallahassee, FL, USA.
Posts: 1,984
Default Re: WEAK STARTING LIKE LOW BATTERY

I was talking about a bad install or wrong install with the channels or positive or negative. I was speaking about tech damageing the battery with tools.

Doesn't take much to place a hole in a battery.
After mine blew up, I noticed how soft they were on the sides and other places.

My thought was the tech jammed the wrench into the terminal or a screw driver by accident for whatever reason, things happen.

Or during shipping the battery was dropped or something dropped onto it causing damage.
__________________
Kingkole02
Just Cruisin, 03 N/A auto. TE Steel Blue w/ pearl coat & chrome package. Too many extras to list, see pics
Reply With Quote
  #9 (permalink)  
Old 19 Dec 2008, 12:16 pm
crusierdad76's Avatar
Fanatic Cruiser
 
Join Date: Aug 2008
Location: St James Missouri
Posts: 641
Default Re: WEAK STARTING LIKE LOW BATTERY

See now that all makes so much more scene to me

I have actually saw a battery EXPLODE when i guy was trying to jump a dead battery--actually the battery was dead and also had no water in it(that is what the fireman said anyway)
And I can see stabbing a battery and causing it to leak that actually are pretty
i am thinking about putting in one of them Gel batteries that you can turn upside down they are expensive but are supposed to be a awesome battery

Thanks for the explaination
Reply With Quote
  #10 (permalink)  
Old 19 Dec 2008, 12:39 pm
Senior Cruiser
 
Join Date: Dec 2003
Location: Tallahassee, FL, USA.
Posts: 1,984
Default Re: WEAK STARTING LIKE LOW BATTERY

I'm saving to find a kinetic battery. It is suppose to recharge as you drive, but are very expensive like 300-400 to power a car last I checked on it.

You can only find these through audio stores and the right connections in my area, only one shop I know of has one.
That would help a ton for both my stereo and my starting.
__________________
Kingkole02
Just Cruisin, 03 N/A auto. TE Steel Blue w/ pearl coat & chrome package. Too many extras to list, see pics
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
problem with the PCM after battery replacement MrDove Tech & Performance Forum 20 04 Jun 2015 03:56 pm
PT Turbo 2.4 starting problems evgenia General Turbo Discussions 10 22 Sep 2012 10:00 am
2002 PT Intermittent Starting Problems, Very Long, Goes Back 3 Years BeBeCroozer Tech & Performance Forum 21 11 Jul 2011 09:30 am
New Turbo Owner Battery Questions freakengine General Turbo Discussions 4 01 Jun 2008 09:21 pm
How difficult is it to change battery cables? sawdust123 General Turbo Discussions 0 20 Aug 2007 12:57 am


All times are GMT -5. The time now is 01:19 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors