PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
At wit's end-2007 non-turbo-A/C problem

 
Reply
 
LinkBack Thread Tools Display Modes
  #11 (permalink)  
Old 23 Aug 2011, 12:38 pm
Fresh Cruiser
 
Join Date: Aug 2011
Location: Louisiana
Posts: 10
Default Re: At wit's end-2007 non-turbo-A/C problem

Thanks guys,
I will look into these suggestions.
Reply With Quote
  #12 (permalink)  
Old 23 Aug 2011, 01:26 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,758
Default Re: At wit's end-2007 non-turbo-A/C problem

Your probably right. Too bad there there wasn't one continuous post and not spread the facts around in different threads. I didn't see or answer up on the other post.
Reply With Quote
  #13 (permalink)  
Old 02 Sep 2011, 10:17 pm
Fresh Cruiser
 
Join Date: Sep 2011
Location: Alabama
Posts: 3
Default Re: At wit's end-2007 non-turbo-A/C problem

I have a '06 non-turbo. Had the problem with pressure build up and release of freon through pressure releif valve. Also had shuddering when idling - noticed more when A/C was on. Replaced fan relays with no success. Finally replaced the entire fan assembly ($85 and about 90 minutes).

Followed these directions:

You CAN do it yourself; it's relatively easy. It helped that I had mini drive-up ramps and a floor creeper, but, these are not mandatory. ( I used a jack and one jack stand just to get under the front)

Remove the negative battery terminal but don't waste time removing the entire battery and battery shelf. (I did not remove the neg terminal but made sure to plug the new fan in after all other work was done.) Removing the wiring connector is a little tricky. Look at the connection in good lighting. Slide a small-bladed screwdriver between the (fan side) catch prongs and the body of the connector (the raised hump). Then pull out the (car-side) jack.

I did not open the radiator drain plug. ( I used the drain plug.) I just shoved a short piece of plastic tubing into the radiator cap (the metal cap over the front of engine, not the plastic over-flow cap) and after it filled with fluid, I pinched the end and pulled it out to create a siphon. I drained out two beer cans worth of fluid. With the car on the ramps, this was enough to drop the fluid level below the upper radiator hose flange.

Remove the two lower fan cowling bolts then the bolt on each side. The driver's side bolt is the most problematic - having a thin arm helps. Remove the front grill by removing the four bolts on top and then unsnapping the grill by pulling each side forward until it pops out - you'll see the two snaps on each side as you pull it toward you.

Twist the two radiator retainers (black oval-shaped plastic about the size of a dollar coin) on the top of the radiator counter -clockwise and pull them off. Lift off the front portion of the rubber hood gasket and set it out of your way. Remove the upper radiator bracket bolts and the one center brace bolt. Remove the remaining two upper fan cowling bolts, tilt the radiator forward and behold! You can now pull out the entire fan assembly. Just install the new fan by reversing the process.

Easy. Budget about 90 minutes of your time. (EASY)
Reply With Quote
  #14 (permalink)  
Old 03 Sep 2011, 03:38 pm
Gastawito's Avatar
Fresh Cruiser
 
Join Date: Sep 2011
Location: Arcadia
Posts: 1
Default Re: At wit's end-2007 non-turbo-A/C problem

Hi everyone, welcome to forum!
__________________
The exploitation of limited essay writing service primarily is staple for me in-full. I appreciate correspondent work of answerable experts.
Reply With Quote
Reply

Tags
a/c, air conditioning, pressure, sensor, switch


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Horn Problem 2007 Cruiser crandon71 General PT Cruiser Discussions 8 15 Jul 2017 02:22 pm
Turn Signal Problem 2007 Pt Twinb2 General PT Cruiser Discussions 4 26 Sep 2012 02:46 pm
1ST SMALL PROBLEM W/ 2007 PT VARELAGIRL Tech & Performance Forum 4 11 Nov 2010 05:52 pm
2007 Pt with a transmission problem Sam31 Tech & Performance Forum 10 10 Nov 2010 09:28 am


All times are GMT -5. The time now is 11:15 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors