PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Need help! '05 2.4 non-turbo pt cruiser

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 23 Jun 2012, 12:45 am
Fresh Cruiser
 
Join Date: Jun 2012
Posts: 13
Default Need help! '05 2.4 non-turbo pt cruiser

So my story begins like so..
I was just leaving from my son's doctors appointment when I started the car and put it in reverse it went a few feet and just died! It wouldn't start again, it would turn over but not start. $72 later in towing fees it was dropped off in my drive way. We found a forum that told us how to pull any codes. The code came up P0340, which is the camshaft sensor. I look at how to fix it and get really excited since it is so simple. I pick my part up from a local auto part store and install it. Still the same result! The next day I find that you should change the crankshaft sensor as well so I do that, still nothing! I call a couple family mechanics and they come look at the car and find that my camshafts are stuck. I pay for a rebuild head because my old one was warped (the car never over heated). Everything is put back together and a new timing belt as well. The mechanics go to start the car and still the exact same result! It will turn over but not start! My mechanics are going to tare down the car and see if the timing is off since we have noticed the difficulty so many people have had before us. I guess I am just hoping someone might have an idea of what could be going on? Any information could help! Thank you in advance!
Reply With Quote
  #2 (permalink)  
Old 23 Jun 2012, 01:24 am
mdfrodolives's Avatar
Senior Cruiser
 
Join Date: May 2010
Posts: 1,313
Default Re: Need help! '05 2.4 non-turbo pt cruiser

Sounds like your new mechanic put the timing belt in wrong. Was it the same guy who said you had a warped head?

Tim
Reply With Quote
  #3 (permalink)  
Old 23 Jun 2012, 01:46 am
Fresh Cruiser
 
Join Date: Jun 2012
Posts: 13
Default Re: Need help! '05 2.4 non-turbo pt cruiser

It is the same mechanic that said I had a warped head.

I have the head sitting in my front yard, figured I'd keep it as a lawn ornament! The cams were so bad they wouldn't turn when the car first died.

If the timing is off would it still act the same as it did when it originally died? I know the same code is coming up p0340, which I know is the camshaft position sensor.

I did buy an after market sensor not OEM and I have heard that it could make a difference. Not sure if I should just bite the bullet and buy a OEM sensor or let them re-time the car and hope it starts.
Reply With Quote
  #4 (permalink)  
Old 23 Jun 2012, 05:34 am
Ray_Dockrey's Avatar
Senior Cruiser
 
Join Date: May 2012
Location: Mustang, OK
Posts: 1,213
Default Re: Need help! '05 2.4 non-turbo pt cruiser

The reason they wouldn't turn when the car died and then wouldn't start is because you broke the timing belt. I am sure there was nothing wrong with the original head.
Reply With Quote
  #5 (permalink)  
Old 23 Jun 2012, 07:47 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Need help! '05 2.4 non-turbo pt cruiser

I'd get OEM sensors if it were me - the aftermarket one's may be the cause, and don't last, so it's safer.
It MAY be possible that when timing belt broke, valves hit jamming cams, but the cams won't turn without belt when cranking - I assume they tried with head off turning cams by hand?
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #6 (permalink)  
Old 23 Jun 2012, 11:01 am
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,904
Default Re: Need help! '05 2.4 non-turbo pt cruiser

If the cams won't turn motor won't turn over unless belt is off. Far as a warped head,if you don't have cam rock it can be milled flat. Has the magnet for the sensor been looked at? If the timing was even close it should at least run if it was a timing issue.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #7 (permalink)  
Old 23 Jun 2012, 01:39 pm
Fresh Cruiser
 
Join Date: Jun 2012
Posts: 13
Default Re: Need help! '05 2.4 non-turbo pt cruiser

The timing belt never broke, it was intact when the car just died. After changing the sensors I did some more looking and found that it could have been the timing that jumped time so went for a new timing belt. While we were taking things apart we found that the cams would not turn until you loosened the cam housing and even then it was most difficult to get them to turn.

After removing the head and taking a nice look at it you could see where oil and air had been pushing through the head gasket. The head was also very warped and looked from a side view, kind of twisted.

My mechanic did state that he had thought he might have got the timing wrong since he has never done a pt cruiser and the Haynes manual we have has a few different ways of timing and none of them state that they are the timing for the '05 model. I did find a forum on here that stated they had to use the '07 timing for their '03 engine. I was just hoping to find someone that knows about the '05 2.4 non-turbo engine and might know the right timing that is needed and if the aftermarket sensors could be a main cause of this mess?

I have owned this car for a year and never had any problems with it until the beginning of this year when I was rear ended and $4300 damage was done to the rear end of my car. Ever since then the gas mileage went to crap and a month or so later I had to fill the engine coolant because it went nearly bone dry and then a month later the same thing happened. All the up keep on this car is done on time.
Reply With Quote
  #8 (permalink)  
Old 23 Jun 2012, 01:43 pm
Fresh Cruiser
 
Join Date: Jun 2012
Posts: 13
Default Re: Need help! '05 2.4 non-turbo pt cruiser

And to answer the question about the magnet. We did look at that and there is no visible signs of damage. We are taking the car back apart again today to see if we can figure out the timing.
Reply With Quote
  #9 (permalink)  
Old 23 Jun 2012, 02:39 pm
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,904
Default Re: Need help! '05 2.4 non-turbo pt cruiser

The accident has nothing to do with anything. Unless someone drove the car and hurt the motor rawhiding it. The fact that you had no coolant in it twice explains the head and the cams. It wont show over heating on the gauge when there is no coolant on the temp sensor. But the head would be extremely hot and you would never know it. If the head was warped as bad as you say the cams wont turn because the journals are no longer in strait line and binding the cams.Put the original sensor back and try that.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #10 (permalink)  
Old 23 Jun 2012, 02:56 pm
Fresh Cruiser
 
Join Date: Jun 2012
Posts: 13
Default Re: Need help! '05 2.4 non-turbo pt cruiser

Thank you! I am glad to have answer to why the head was warped when I did not see it over heating. I think we are still having the problem with the timing. Any idea or suggestions on how it should be done on a '05 2.4 non-turbo? I am hoping to have the old sensor still handy. I will keep you updated on this. Thank you again, it has been a very long wait for my beauty to get back on the road and I am hoping today will be the day she is up and running!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
PT Cruiser Turbo fun Bigjoedo General PT Cruiser Discussions 3 09 Feb 2012 07:01 pm
Is my Cruiser turbo? joegosox General PT Cruiser Discussions 15 10 Jul 2011 08:18 pm
Colima Pro Street Shadow Turbo VS PT Cruiser Turbo skylight PT Cruiser Videos 5 31 Dec 2008 03:21 pm
Turbo on non-turbo cruiser 04VanillaCruiser General Turbo Discussions 7 02 Aug 2005 07:59 am
new pt cruiser turbo cesar General Turbo Discussions 8 24 Dec 2003 04:58 pm


All times are GMT -5. The time now is 07:59 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors