PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
engine bucking bronco

 
Like Tree1Likes
  • 1 Post By ptcruisersteve

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 14 Mar 2015, 11:12 pm
Fresh Cruiser
 
Join Date: Dec 2009
Posts: 14
Default engine bucking bronco

While driving highhway speed, engine started to buck and as i eassed off the gass, engine light came on. I was able to keep it going around 40 or 50 mph.. If I applied gas to fast the engine would buck and not respond. Then I noticed that cruise control stopped working..I made it home....50 miles later..any thoughts, have to take it to shop on Monday!
2004 limited. 145,000 miles.timing belt, plugs and wires changed at 100000.
Reply With Quote
  #2 (permalink)  
Old 14 Mar 2015, 11:17 pm
Young Cruiser
 
Join Date: Feb 2015
Location: South Bend Indiana
Posts: 80
Default Re: engine bucking bronco

Quote:
Originally Posted by jadmiral View Post
While driving highhway speed, engine started to buck and as i eassed off the gass, engine light came on. I was able to keep it going around 40 or 50 mph.. If I applied gas to fast the engine would buck and not respond. Then I noticed that cruise control stopped working..I made it home....50 miles later..any thoughts, have to take it to shop on Monday!
2004 limited. 145,000 miles.timing belt, plugs and wires changed at 100000.
Check your engine codes. Mine did this and it was the cam position sensor. Easy fix, if that's it.

Last edited by 1911ly; 14 Mar 2015 at 11:30 pm.
Reply With Quote
  #3 (permalink)  
Old 15 Mar 2015, 01:47 am
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,600
Default Re: engine bucking bronco

If it is the camshaft sensor engine trouble code P0344 try checking the wiring and the connector. If both is okay then check the camshaft sensor. it is recommended to buy only Mopar sensors.

Its pretty easy to replace.

Attached is a link to a video that shows how to replace the camshaft sensor.

Reply With Quote
  #4 (permalink)  
Old 15 Mar 2015, 03:28 am
rockandroller's Avatar
Obsessed Cruiser
 
Join Date: Feb 2013
Location: Western Canada! (Okanagan)
Posts: 8,809
Default Re: engine bucking bronco

And if you are in limp mode due to that code - disconnecting the battery for a few minutes will clear it, and it will run normal again. Mine did that for a week, before it threw another code. Then I cleared it again, and got another week.

Then it threw one again, and I went and bought a genuine Mopar sensor ( $100 at the local Stealership, but its been fine ever since...)
__________________
2004 'Turbo Lite'
Reply With Quote
  #5 (permalink)  
Old 15 Mar 2015, 02:09 pm
soonercruiser's Avatar
Obsessed Cruiser
 
Join Date: Jun 2007
Location: Oklahoma City
Posts: 14,891
Cool Re: engine bucking bronco

Gonna bet it's the Cam sensor!
Doing mine right now on a 2005 at 45K.
Code 0339!

I had some appointments for her, like custom pin striping job.
So, I've been driving around under 2,500 rpm and all is well for now.
__________________
Frank, aka SOONERCRUISER,

2003 PT Cruiser GT Panel Van Conversion as new day driver.

Have now owned 6 PT Cruisers = Me PT Crazy!
Reply With Quote
  #6 (permalink)  
Old 15 Mar 2015, 02:20 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,600
Default Re: engine bucking bronco

Quote:
Originally Posted by soonercruiser View Post
Gonna bet it's the Cam sensor!
Doing mine right now on a 2005 at 45K.
Code 0339!

I had some appointments for her, like custom pin striping job.
So, I've been driving around under 2,500 rpm and all is well for now.
Soonercruiser
Isn't the code P0339 for the crankshaft sensor?
soonercruiser likes this.
Reply With Quote
  #7 (permalink)  
Old 17 Mar 2015, 07:43 pm
Fresh Cruiser
 
Join Date: Dec 2009
Posts: 14
Smile Re: engine bucking bronco

Thank you everyone. this is the best forum! I replaced cam sensor and so far car is running great and Cruise control is back. Did not have access to computer codes, so I took a chance and replaced anyway, since 4 out of 4 of you said the same thing. BTY, dealer had same price as Internet and I installed same day! $70 bucks and I'm back on the road!
Thank you, thank you,
John
Reply With Quote
  #8 (permalink)  
Old 17 Mar 2015, 09:45 pm
soonercruiser's Avatar
Obsessed Cruiser
 
Join Date: Jun 2007
Location: Oklahoma City
Posts: 14,891
Unhappy Re: engine bucking bronco

Quote:
Originally Posted by ptcruisersteve View Post
Soonercruiser
Isn't the code P0339 for the crankshaft sensor?
Damn!
You're right!
I didn't look close enough.
__________________
Frank, aka SOONERCRUISER,

2003 PT Cruiser GT Panel Van Conversion as new day driver.

Have now owned 6 PT Cruisers = Me PT Crazy!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bucking PT dvddmc Tech & Performance Forum 6 10 Jun 2013 10:48 pm
2006 PT Cruiser bucking when accelerating + no check engine codes mattamusprime General PT Cruiser Discussions 4 26 Mar 2012 08:59 pm
03 Stage 1 2.4 Engine miss/bucking getuoutthere Stage Turbo Kits 7 15 May 2011 04:29 pm
Bucking bquik Tech & Performance Forum 5 06 May 2010 08:26 pm
Engine Light + Bucking When Accelerating kalyhan Tech & Performance Forum 9 06 May 2010 10:06 am


All times are GMT -5. The time now is 10:35 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors