PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > 2.4L Turbo Forums > Turbo Wheels/Suspension/Handling

PT Cruiser Forum

Advertisements
power steering low pressure hose blowing off

 
Reply
 
LinkBack Thread Tools Display Modes
  #11 (permalink)  
Old 28 Feb 2011, 06:52 pm
Fresh Cruiser
 
Join Date: Nov 2010
Location: Upstate New York
Posts: 8
Default Re: power steering low pressure hose blowing off

The first time it blew off after the radiator replacement they said it was a "Bad Hose Clamp", so they put the hose back on and put a heavy duty clamp on. That lasted 8 days and it blew off Saturday. I went in this morn before they even took the car in a raised hell about it. They are 100% sure that it was just some oil or some slippery substance left on the metal section of the line under the motor. So they flared the end of the pipe so it wont be so easy to slide off this time. If it blows off again, I am just going to take it to another shop and have it looked at. The service rep this morning was treating me like I was stupid and didn't know what I was talking about when I was saying there shouldn't be hardly any pressure in that line, especially not enough to blow it off. I also told him that now the pump whines a bit all the time and is real loud on first start, especially when cold, but he told me that it sounded fine and that even tho its been run 5 time now without fluid that its still perfectly fine and he didn't hear it being louder that any other he has heard. I told him to run mine next to the 09 PT rental I had and he would hear the difference. He proceeded to tell me thats like comparing apples and oranges. Well Mr service idiot, If you knew anything you would know thats its a similar 2.4L motor and it the SAME pump that is in mine. I am done with Nemer Chrysler in Queensbury and would hope that anyone in this area who reads this would avoid them too.
Reply With Quote
  #12 (permalink)  
Old 29 Apr 2012, 09:09 pm
Fresh Cruiser
 
Join Date: Apr 2012
Location: Renfrew, Ontario, Canada
Posts: 3
Default Re: power steering low pressure hose blowing off

Hi there, I was wondering if u ever figured it out. My car is doing almost the same thing right now. I just had a timing belt and water pump(as well as many other parts) installed at the dealership and it never leaked coolant before it was leaking ps fluid originally.
Reply With Quote
  #13 (permalink)  
Old 02 May 2012, 05:00 pm
chigger_ns's Avatar
Cool Cruiser
 
Join Date: May 2010
Posts: 278
Default Re: power steering low pressure hose blowing off

Ill chime in on this. I have a 2001 Grand Caravan. One day it decided to blow off its Power steering hose at the cooler. So I figured I would put a new one on. They wanted to sell me the whole cooler unit because that is how it is sold. I said no.
I went and got some gas rated hose and put it on. 2 weeks later it shredded. Too much pressure. But its was a return hose so what is with that? On my van it is the stupid location that is likely the big problem. the hose has to bend in a 120 degree angle in a short distance..
I went and got some funky grey hose rated for a higher pressure and put it on and so far it has lasted for 3 years.
Moral to my story is try another type of hose or go some where else.
__________________
2001 PT 5 speed Touring Edition
Eibach Pro Springs, Energy Suspension HyperFlex Master Kit bushings, 17" RTX Euro wheels, K&N drop in air filter, MotoMaster flat plate AGM battery, KYB GR2 shocks and struts, Booger standard shifter bushings, Ooogah horn.
Reply With Quote
  #14 (permalink)  
Old 05 Jun 2012, 12:17 pm
Fresh Cruiser
 
Join Date: Nov 2010
Location: Upstate New York
Posts: 8
Default Re: power steering low pressure hose blowing off

They ended up replacing the radiator saying there was to much back pressure.
Reply With Quote
  #15 (permalink)  
Old 05 Jun 2012, 12:36 pm
cruserdad1976's Avatar
Obsessed Cruiser
 
Join Date: Sep 2009
Location: st james mo
Posts: 8,217
Default Re: power steering low pressure hose blowing off

my question is how do they keep blowing off ??? if the hose is new it should be solid
Reply With Quote
  #16 (permalink)  
Old 06 Jun 2012, 10:25 pm
Fresh Cruiser
 
Join Date: Nov 2010
Location: Upstate New York
Posts: 8
Default Re: power steering low pressure hose blowing off

There was to much back pressure in the line going into the radiator, that's is where it was blowing off. once they replaced the radiator and flared that metal line under the engine it has not blown off since.
Reply With Quote
  #17 (permalink)  
Old 12 Mar 2013, 11:05 am
Fresh Cruiser
 
Join Date: Mar 2013
Posts: 1
Default Re: power steering low pressure hose blowing off

having the same problem, i put in a new hose myself sometimes to save money, last time it cost us $450 dollars, but it came off again, sometimes the hose would just bust, i have a pt cruiser turbo engine gt, so if you solved your problem yet, i would be glad to here how you did it
Reply With Quote
  #18 (permalink)  
Old 08 Apr 2013, 06:34 am
Fresh Cruiser
 
Join Date: Apr 2013
Location: Medford, MA
Posts: 2
Default Re: power steering low pressure hose blowing off

My hose burst and I am replacing it. Replacement only $75. Getting the end disconnected from the pump was fairly easy. Now my problem is reaching the rack to disconnect that end. Does any one have a trick or know a best approach for reaching this? I can barely get my hand and wrench in there but have no viability since the return is in the way.

Though folks?
Reply With Quote
  #19 (permalink)  
Old 20 Feb 2015, 09:59 am
Handy_Cruiser's Avatar
Obsessed Cruiser
 
Join Date: Oct 2013
Location: Arkansas
Posts: 10,785
Default Re: power steering low pressure hose blowing off

Very interesting reading. I seem to be having this same issue for a second time. The cold seems to bring this on for me. Time to look for restriction in the cooling line that run through the radiator itself.
__________________
Reply With Quote
  #20 (permalink)  
Old 02 Mar 2015, 07:25 pm
Cool Cruiser
 
Join Date: Jun 2014
Location: southeastern PA
Posts: 370
Default Re: power steering low pressure hose blowing off

My Cruiser has been whining for a short time when first started in extreme cold. I also lost my power steering assist during a spirited run one morning. I think the return hose collapsed under a vacuum, it later recovered.

As soon as we get some warm weather, I'm going to remove the reservoir, clean the screen and flush the system.

Here's a couple of interesting threads on the subject -
one with good pictures:
http://www.ptcruiserlinks.com/forum/...-steering.html
one with a simpler screen cleaning method:
http://www.ptcruiserlinks.com/forum/...reservoir.html
Reply With Quote
Reply

Tags
hoses, power steering, pump


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Replacing Power Steering Pressure Hose wapasha General PT Cruiser Discussions 0 20 May 2010 09:08 am
2006 cruiser power steering high pressure hose TOMisKING Tech & Performance Forum 0 01 May 2010 03:38 pm
Need Power Steering hose, Reservoir 340x Classifieds: Want To Buy 1 07 Jul 2009 11:07 pm
Power Steering Hose Needed 340x Classifieds: For Sale/Trade 1 29 Jun 2009 04:53 pm
power steering pressure sensor ravix Tech & Performance Forum 2 15 Apr 2007 09:46 am


All times are GMT -5. The time now is 03:09 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors